You are not logged in.

#1 2020-06-20 21:47:54

daftaupe
Member
From: France
Registered: 2010-07-02
Posts: 12

amdgpu on Ryzen 2200G (vega 8) shifted HDMI display with DVI adapter

I'm having an issue with amdgpu and my Ryzen 3 2200G which is plugged via HDMI cable plus a HDMI/DVI-D adapter between the cable and my monitor. The motherboard is a MSI B450I gaming plus AC.
The monitor only offers DVI-D and VGA , it's an ACER X233H.

It's not a fresh install, I moved the system from a partition on my laptop (running on Intel) to this new computer.

At first after seeing some boot lines, I had only a black screen, like no output at all (the latest usb image of Archlinux gives that same blackscreen when booted), but I discovered the computer was reachable by ssh, so I added video=HDMI-A-1:D to my kernel parameters to force the output to be on and digital on the HDMI output, and now at least I have some output. I've also tried with nomodeset and in that case the output is perfectly fine, but also the amdgpu driver is not in use.

Now, the problem : I still have a good POST and the beginning of boot is displayed alright, but as soon as the driver is loaded (I've tried with early KMS and without, and the timing at which the display becomes wrong changes) what is displayed is sort of shifted a little bit down and to the right (the output is fine until the module is loaded). I'm using latest kernel available on Arch : 5.7.4 and it looks like https://arch.cccp.io/2020-06-20%2017.02.53.jpg
To sum up, I'm trying to remove that top part (purple/blue) and the left column to get a proper display back smile

I'm booting with a EFISTUB kernel and a startup.nsh script

\EFI\archlinux\vmlinuz-linux-zen rw root=UUID=5c1d9370-54f7-465e-a0cd-e48a27bfa16b rootflags=subvol=archlinux initrd=\EFI\archlinux\amd-ucode.img initrd=\EFI\archlinux\initramfs-linux-zen.img audit=0 video=HDMI-A-1:D amdgpu.audio=0
$ uname -a
Linux korobka 5.7.4-zen1-1-zen #1 ZEN SMP PREEMPT Thu, 18 Jun 2020 16:01:10 +0000 x86_64 GNU/Linux
29:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c8) (prog-if 00 [VGA controller])
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7a40
        Flags: bus master, fast devsel, latency 0, IRQ 43, IOMMU group 8
        Memory at 7fe0000000 (64-bit, prefetchable) [size=256M]
        Memory at 7ff0000000 (64-bit, prefetchable) [size=2M]
        I/O ports at e000 [size=256]
        Memory at fcb00000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

Full dmesg available at https://arch.cccp.io/dmesg.txt

To give more details :
- I've tried running on my TV and the HDMI works fine in that case (that makes me think the adapter might have something to do with the wrong display)
- I've tried another HDMI cable -> same result
- I don't have another external monitor to try the adapter
- I did try to build a 1920x1080 EDID .bin file from tools/edid in the kernel sources, and load it accordingly to the wiki article, that didn't help
- I did try almost all combinations of options and resolution for the video= option, that didn't change much things, resolutions did change, but were still shifted as in the linked picture
- Except from being shifted it's running fine, I can startx and run programs etc.. just can't used them properly as a part of the screen is missing.
- I tried without amdgpu.audio=0 the result is the same, but I don't need audio through HDMI so I thought it could remain on the kernel line

I've tried to sum up all I've tried (not entering all details for every attempt though).

Last edited by daftaupe (2020-06-20 21:53:20)

Offline

Board footer

Powered by FluxBB