You are not logged in.

#1 2020-06-23 17:38:09

Registered: 2020-01-05
Posts: 2

Issue with Generic Xbox One wired controller (Power A brand)

I am having trouble getting my Power A brand controller (24c6:543a) to work in Steam, and the LED isn't turning on like it would expect it to if it is communicating correctly and being recognized. I can see the device enumerating on the USB controller using lsusb, I can see that I have the steamos-xpad-dkms module loaded via lsmod. I have tried running the xboxdrv software, but the controller isn't recognized in the stable version, it is in the git version however but it throws errors. See I have even looked at installing custom xpad modules from github, see I even thought it could have been a group issue, and made sure I was in the input group. I am out of ideas at this point. I can cat the device, both the joystick and event files, and they seem to be reading the controller. I installed jstest-gtk, and I can see the controller and get input, and calibrate it. But I am still not seeing the controller in Steam or anything else I have tried, which makes me think it might not be initializing correctly, even though I can see the input events. I have used this controller on my Steam Link, and I do remember having to use a cabinet file on Windows 10 to get it to install and work, but nothing I have tried has worked on Arch. Any ideas would be much appreciated, and I apologize if I am missing some information, I am fairly new to the forum as far as posting.

Edit: I forgot to mention that I was also able to configure the controller in wine through PlayOnLinux, and using the control panel in a wine bottle. I can see the controller and the input is functioning there.

Last edited by kuitthegeek (2020-06-23 17:53:16)


Board footer

Powered by FluxBB