You are not logged in.

#1 2020-06-25 00:54:38

Rurisk
Member
Registered: 2018-02-18
Posts: 2

[solved] I have no sound on my laptop, since alsa-lib 1.2.3

Good day all. I updated my laptop on the 11th June, and the sound stopped working on all applications. As I update frequently, I was fairly quickly able to identify that it was the alsa-lib package that seemed to be causing the issue. However I couldn't find what could be causing the issue. After some time searching I found this forum thread in Linux questions suggesting that there where many out there with the same issue, and that it was a matter for waiting for the upstream fix.

So I decided to roll back my system to the 10th June using this method, and waited out. alsa-lib has seen an update since then, and the Linux questions forum has seen comments suggesting all if fixed, but I'm still not getting any sound. I don't know how to debug this further, I've looked through the Arch Linux forum and the wiki but to no avail. I'm hoping that there is someone out there that might be able to push my troubleshooting in the right direction.

I just updated my system, and I've ran speaker-test:

% speaker-test -c 2

speaker-test 1.2.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition 'defaults.pcm.tstamp_type'
ALSA lib conf.c:4743:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5231:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM dmix:PCH
Playback open error: -2,No such file or directory 

Any help in finding these errors would be greatly appreciated.

I haven't changed my configuration in any way:

% cat .asoundrc.asoundconf
# ALSA library configuration file managed by asoundconf(1).
#
# MANUAL CHANGES TO THIS FILE WILL BE OVERWRITTEN!
#
# Manual changes to the ALSA library configuration should be implemented
# by editing the ~/.asoundrc file, not by editing this file.
!defaults.pcm.card PCH
defaults.ctl.card PCH
defaults.pcm.device 0
defaults.pcm.subdevice -1
defaults.pcm.nonblock 1
defaults.pcm.compat 0
defaults.pcm.minperiodtime 5000
defaults.pcm.ipc_key 5678293
defaults.pcm.ipc_gid audio
defaults.pcm.ipc_perm 0660
defaults.pcm.dmix.max_periods 0
defaults.pcm.dmix.channels 2
defaults.pcm.dmix.rate 48000
defaults.pcm.dmix.format "unchanged"
defaults.pcm.dmix.card defaults.pcm.card
defaults.pcm.dmix.device defaults.pcm.device
defaults.pcm.dsnoop.card defaults.pcm.card
defaults.pcm.dsnoop.device defaults.pcm.device
defaults.pcm.front.card defaults.pcm.card
defaults.pcm.front.device defaults.pcm.device
defaults.pcm.rear.card defaults.pcm.card
defaults.pcm.rear.device defaults.pcm.device
defaults.pcm.center_lfe.card defaults.pcm.card
defaults.pcm.center_lfe.device defaults.pcm.device
defaults.pcm.side.card defaults.pcm.card
defaults.pcm.side.device defaults.pcm.device
defaults.pcm.surround21.card defaults.pcm.card
defaults.pcm.surround21.device defaults.pcm.device
defaults.pcm.surround40.card defaults.pcm.card
defaults.pcm.surround40.device defaults.pcm.device
defaults.pcm.surround41.card defaults.pcm.card
defaults.pcm.surround41.device defaults.pcm.device
defaults.pcm.surround50.card defaults.pcm.card
defaults.pcm.surround50.device defaults.pcm.device
defaults.pcm.surround51.card defaults.pcm.card
defaults.pcm.surround51.device defaults.pcm.device
defaults.pcm.surround71.card defaults.pcm.card
defaults.pcm.surround71.device defaults.pcm.device
defaults.pcm.iec958.card defaults.pcm.card
defaults.pcm.iec958.device defaults.pcm.device
defaults.pcm.modem.card defaults.pcm.card
defaults.pcm.modem.device defaults.pcm.device
defaults.pcm.file_format "raw"
defaults.pcm.file_truncate true
defaults.rawmidi.card 0
defaults.rawmidi.device 0
defaults.rawmidi.subdevice -1
defaults.hwdep.card 0
defaults.hwdep.device 0
defaults.timer.class 2
defaults.timer.sclass 0
defaults.timer.card 0
defaults.timer.device 0
defaults.timer.subdevice 0
defaults.namehint.showall off
defaults.namehint.basic on
defaults.namehint.extended off

Last edited by Rurisk (2020-06-25 11:32:19)

Offline

#2 2020-06-25 08:42:02

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,088

Re: [solved] I have no sound on my laptop, since alsa-lib 1.2.3

That's just unnecessarily overblown, asoundconf creates too verbose configuration and messes with values that will break standard upstream improvements.

defaults.pcm.!card "PCH"
defaults.ctl.!card "PCH"

is all configuration you need, without unnecessarily changing many lower level components.

The reason this error happens is that the dmix plugin received a new parameter which is properly set by package provided configuration. asoundconf  completely breaks the default configuration, only to set it back up basically the same way as mandated by the shipped default configuration but it will of course not include new parameters that have been included by upstream since last executing it.

Last edited by V1del (2020-06-25 09:04:07)

Offline

#3 2020-06-25 11:31:38

Rurisk
Member
Registered: 2018-02-18
Posts: 2

Re: [solved] I have no sound on my laptop, since alsa-lib 1.2.3

V1del wrote:

...all configuration you need...

Thank you very much for taking the time to answer. Clearly this goes by the ethos 'Keep It Simple, Stupid' and after a little over a year on Arch, you'd think I would have learned that.

In case any other Newbies ever come across this post, to solve my lack of sound, I first created a back up:

cp ~/.asoundrc.asoundconf ~/.asoundrc.asoundconf.bk

and then I removed all the verbose from ~/.asoundrc.asoundconf, added the lines

defaults.pcm.!card "PCH"
defaults.ctl.!card "PCH"

to

~/.asoundrc

and then performed the full upgrade and all sound is functional again.

Offline

Board footer

Powered by FluxBB