You are not logged in.

#1 2020-06-26 08:52:38

muhlinux
Member
Registered: 2019-11-19
Posts: 5

[SOLVED] Nvidia 440.100 API mismatch

Hi I just updated the nvidia drivers

 uname - Linux 5.7.5-arch1-1  x86_64 GNU/Linux
[2020-06-26T10:04:39+0200] [ALPM] upgraded nvidia-utils (440.82-2 -> 440.100-1)

Now i have this error in dmesg

NVRM: API mismatch: the client has the version 440.100, 
NVRM: this kernel module has the version 440.82.  
NVRM: make sure that this kernel module and all NVIDIA 
NVRM: components have the same version.

How do i proceed? Cheers.

Last edited by muhlinux (2020-06-26 11:32:44)

Offline

#2 2020-06-26 09:11:07

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,947
Website

Re: [SOLVED] Nvidia 440.100 API mismatch

Sounds like you've done a partial update. Please elaborate on how you updated, and post your complete pacman.log.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-06-26 09:38:52

muhlinux
Member
Registered: 2019-11-19
Posts: 5

Re: [SOLVED] Nvidia 440.100 API mismatch

WorMzy wrote:

Sounds like you've done a partial update. Please elaborate on how you updated, and post your complete pacman.log.

Did a normal update with

yay

full log from today:

[2020-06-26T09:59:30+0200] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2020-06-26T09:59:30+0200] [PACMAN] synchronizing package lists
[2020-06-26T09:59:30+0200] [PACMAN] starting full system upgrade
[2020-06-26T10:04:39+0200] [ALPM] transaction started
[2020-06-26T10:04:39+0200] [ALPM] upgraded iana-etc (20200601-1 -> 20200624-1)
[2020-06-26T10:04:39+0200] [ALPM] upgraded nvidia-utils (440.82-2 -> 440.100-1)
[2020-06-26T10:04:39+0200] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2020-06-26T10:04:39+0200] [ALPM] upgraded ffmpeg (2:4.2.3-1 -> 2:4.2.3-2)
[2020-06-26T10:04:39+0200] [ALPM] upgraded lib32-nvidia-utils (440.82-1 -> 440.100-1)
[2020-06-26T10:04:39+0200] [ALPM] upgraded libxnvctrl (440.82-1 -> 440.100-1)
[2020-06-26T10:04:39+0200] [ALPM] upgraded nvidia (440.82-24 -> 440.100-1)
[2020-06-26T10:04:39+0200] [ALPM] upgraded nvidia-settings (440.82-1 -> 440.100-1)
[2020-06-26T10:04:40+0200] [ALPM] transaction completed
[2020-06-26T10:04:40+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2020-06-26T10:04:40+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-06-26T10:04:40+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-26T10:04:40+0200] [ALPM] running '60-depmod.hook'...
[2020-06-26T10:04:48+0200] [ALPM] running 'update-desktop-database.hook'...
[2020-06-26T10:22:33+0200] [PACMAN] Running 'pacman -S st'
[2020-06-26T10:23:57+0200] [PACMAN] Running 'pacman -S rxvt-unicode rxvt-unicode-terminfo'
[2020-06-26T10:23:59+0200] [ALPM] transaction started
[2020-06-26T10:23:59+0200] [ALPM] installed rxvt-unicode-terminfo (9.22-10)
[2020-06-26T10:23:59+0200] [ALPM] installed rxvt-unicode (9.22-10)
[2020-06-26T10:23:59+0200] [ALPM] transaction completed
[2020-06-26T10:23:59+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-26T10:23:59+0200] [ALPM] running 'update-desktop-database.hook'...
[2020-06-26T10:35:08+0200] [PACMAN] Running 'pacman -Syu'
[2020-06-26T10:35:08+0200] [PACMAN] synchronizing package lists
[2020-06-26T10:35:09+0200] [PACMAN] starting full system upgrade
[2020-06-26T10:35:22+0200] [ALPM] transaction started
[2020-06-26T10:35:22+0200] [ALPM] upgraded gnutls (3.6.14-1 -> 3.6.14-2)
[2020-06-26T10:35:22+0200] [ALPM] transaction completed
[2020-06-26T10:35:22+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-26T10:35:22+0200] [ALPM] running 'texinfo-install.hook'...
[2020-06-26T10:35:28+0200] [PACMAN] Running 'pacman -Syyu'
[2020-06-26T10:35:28+0200] [PACMAN] synchronizing package lists
[2020-06-26T10:35:28+0200] [PACMAN] starting full system upgrade

Thank you for your time.

Offline

#4 2020-06-26 09:55:47

loqs
Member
Registered: 2014-03-06
Posts: 11,599

Re: [SOLVED] Nvidia 440.100 API mismatch

What is the output of the following please

modinfo nvidia
systool -vm nvidia

Online

#5 2020-06-26 10:02:58

muhlinux
Member
Registered: 2019-11-19
Posts: 5

Re: [SOLVED] Nvidia 440.100 API mismatch

loqs wrote:

What is the output of the following please

modinfo nvidia
systool -vm nvidia

modinfo

filename:       /lib/modules/5.7.5-arch1-1/extramodules/nvidia.ko.xz
alias:          char-major-195-*
version:        440.100
supported:      external
license:        NVIDIA
srcversion:     79812FEC91C545B3F516DF2
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        ipmi_msghandler
retpoline:      Y
name:           nvidia
vermagic:       5.7.5-arch1-1 SMP preempt mod_unload 
parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_EnableBacklightHandler:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_AssignGpus:charp

systool

Module = "nvidia"

  Attributes:
    coresize            = "20512768"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "175"
    srcversion          = "058C3165C621D73A1F7436F"
    taint               = "POE"
    uevent              = <store method only>
    version             = "440.82"

  Sections:

Offline

#6 2020-06-26 10:06:01

loqs
Member
Registered: 2014-03-06
Posts: 11,599

Re: [SOLVED] Nvidia 440.100 API mismatch

Did you restart X without having rebooted?

Online

#7 2020-06-26 10:12:13

muhlinux
Member
Registered: 2019-11-19
Posts: 5

Re: [SOLVED] Nvidia 440.100 API mismatch

loqs wrote:

Did you restart X without having rebooted?

I've done nothing other than updating. I wanted to seek help before proceeding, and I'd rather roll back than fail a reboot...

Offline

#8 2020-06-26 10:13:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,434

Re: [SOLVED] Nvidia 440.100 API mismatch

That's the problem, you need to reboot, or at least reload the nvidia module. The nvidia kernel module is tightly coupled with the correct userspace version, when a new nvidia update happens you need to get the kernel version and the userspace libs back in sync, which is easiest done by rebooting, or completely stopping X and reloading the new nvidia module.

Last edited by V1del (2020-06-26 10:15:17)

Offline

#9 2020-06-26 10:21:22

kubasz
Member
Registered: 2020-06-26
Posts: 1

Re: [SOLVED] Nvidia 440.100 API mismatch

I just had a similar problem and rebooting didn't fix it - I realised I had the nvidia modules in my initrd, and I didn't rebuild it after updating just the nvidia module. If that's the case for you, run

sudo mkinitcpio -p linux

and reboot to fix the wrong module version in initrd.

Offline

#10 2020-06-26 11:25:47

muhlinux
Member
Registered: 2019-11-19
Posts: 5

Re: [SOLVED] Nvidia 440.100 API mismatch

V1del wrote:

That's the problem, you need to reboot, or at least reload the nvidia module. The nvidia kernel module is tightly coupled with the correct userspace version, when a new nvidia update happens you need to get the kernel version and the userspace libs back in sync, which is easiest done by rebooting, or completely stopping X and reloading the new nvidia module.


Huh. I've never had Alacritty fail starting after an update like that before, which was how I noticed the error and hence why I thought something was up. Other GUI programs could open up fine... Time to switch to urxvt i guess.

Solved by rebooting.

Appreciate the help. Thank you.

Last edited by muhlinux (2020-06-26 11:42:46)

Offline

#11 2020-06-26 11:39:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,434

Re: [SOLVED] Nvidia 440.100 API mismatch

Anything that requires a working OpenGL/acceleration context will fail or at least fall back to slow software rendering, technically it's rather when a new nvidia-utils version get's released, normal nvidia package updates that are due to a kernel resync aren't that much of an issue as the actual nvidia versions between the two will still match.

Rule of thumb, if the version before the "-"  changes you are likely going to have to reboot. If it's just the pkgrel which comes after the dash you likely don't need to actively do much, which denotes a potentially harmless packaging adjustment or rebuilds of the same version against new kernels

Last edited by V1del (2020-06-26 11:39:55)

Offline

Board footer

Powered by FluxBB