You are not logged in.

#1 2020-06-26 17:03:00

clidx
Member
Registered: 2015-04-26
Posts: 20

Strange issue with refind

I'm using refind to boot Win 10, Arch main and lts kernels.
When I try and boot the main kernel, I either get the error that vmlinuz-linux was not found but I have also seen it complain that grubx64.efi wasn't found. With the lts kernel, it's that Windows 7 was not found? I'm not sure why refind is looking for GRUB or Windows 7 to begin with. This machine has never had Windows 7 or GRUB installed.
When I hit F2 and select Boot with default options, which is what it should be doing anyway, it works perfectly fine on both entries/kernels.

Here are the entries in my refind.conf:

menuentry "Arch Linux" {
    icon     /EFI/refind/icons/os_arch.png
    volume   4e3e786d-c894-3d4f-a9be-47c80ac892ab
    loader   vmlinuz-linux
    initrd   initramfs-linux.img
    options  "root=/dev/mapper/root cryptdevice=PARTUUID=df313142-7b0b-064b-ad46-732ff7c59c60:root:allow-discards rootflags=subvol=system rw"
    submenuentry "Boot using fallback initramfs" {
        initrd initramfs-linux-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "systemd.unit=multi-user.target"
    }
}

menuentry "Arch Linux LTS" {
    icon     /EFI/os_arch_bw.png
    volume   4e3e786d-c894-3d4f-a9be-47c80ac892ab
    loader   vmlinuz-linux-lts
    initrd   initramfs-linux-lts.img
    options  "root=/dev/mapper/root cryptdevice=PARTUUID=df313142-7b0b-064b-ad46-732ff7c59c60:root:allow-discards rootflags=subvol=system rw"
    submenuentry "Boot using fallback initramfs" {
        initrd initramfs-linux-lts-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "systemd.unit=multi-user.target"
    }
}

Before this, I had a weird problem where the luks volume couldn't be mounted. Back then I was using UUID, so cryptdevice=UUID=blah blah. Then that stopped working for no reason, the UUID didn't change. I changed it to cryptdevice=/dev/sda6 etc, then that worked for a while and stopped working but the drive mapping didn't change, it's still sda6. Then I changed it to use PARTUUID, now that works and is still working but I have this weird problem where I have to use F2 to boot using the same options it should be using anyway.

I don't use refind_linux.conf in /boot.

Also,

% lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda           8:0    0 119.2G  0 disk  
├─sda1        8:1    0   529M  0 part  
├─sda2        8:2    0   100M  0 part  /efi
├─sda3        8:3    0    16M  0 part  
├─sda4        8:4    0  50.9G  0 part  
├─sda5        8:5    0     1G  0 part  /boot
└─sda6        8:6    0    50G  0 part  
  └─root    254:0    0    50G  0 crypt /
% blkid | grep sda
/dev/sda1: LABEL="Recovery" BLOCK_SIZE="512" UUID="809AC01F9AC01416" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="cfc8b5a2-40c5-4058-86b0-cc6d08d3754d"
/dev/sda2: UUID="A4C2-7469" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="3be00de6-df88-47f5-b7bc-de78c75ca28a"
/dev/sda4: BLOCK_SIZE="512" UUID="48F0D507F0D4FC5E" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="1ad8d416-d51a-445f-9ea7-39117edcb745"
/dev/sda5: LABEL="refind" UUID="03a04ebd-9fd9-4806-811c-8315d27ce153" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="4e3e786d-c894-3d4f-a9be-47c80ac892ab"
/dev/sda6: UUID="67895ea2-089f-4f08-9100-178fcb1b2f60" TYPE="crypto_LUKS" PARTUUID="df313142-7b0b-064b-ad46-732ff7c59c60"

So the UUID and partition names clearly line up.

It just all seems a bit... random. What's tripping refind up?

Last edited by clidx (2020-06-26 17:04:50)

Offline

Board footer

Powered by FluxBB