You are not logged in.

#1 2020-06-26 17:07:12

millus
Member
Registered: 2019-07-21
Posts: 43

[SOLVED] OpenGL Renderer is software despite NVidia card+driver

OpenGL Renderer says LLVM instead of NV:

$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 10.0.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.1.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 20.1.2
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.1.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
$ pacman -Ss nvidia | grep installed
extra/egl-wayland 1.1.5-1 [installed]
extra/ffnvcodec-headers 9.1.23.1-2 [installed]
extra/libvdpau 1.4-1 [installed]
extra/libxnvctrl 440.100-1 [installed]
extra/nvidia 440.100-1 [installed]
extra/nvidia-settings 440.100-1 [installed]
extra/nvidia-utils 440.100-1 [installed]
extra/opencl-nvidia 440.100-1 [installed]
community/nvidia-cg-toolkit 3.1-5 [installed]
multilib/lib32-libvdpau 1.4-1 [installed]
multilib/lib32-nvidia-utils 440.100-1 [installed]
multilib/lib32-opencl-nvidia 440.100-1 [installed]
/etc/X11$ cat xorg.conf 
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.100

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc ROG PG279Q"
    HorizSync       34.0 - 222.0
    VertRefresh     30.0 - 144.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1080 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "2560x1440_144 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
$ lspci -k | grep -A 2 -E "(VGA|3D)"
01:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)
	Subsystem: ZOTAC International (MCO) Ltd. Device 1470
	Kernel driver in use: nvidia
$ lsmod | grep nvidia
nvidia_drm             53248  2
nvidia_modeset       1118208  2 nvidia_drm
nvidia              20721664  85 nvidia_modeset
drm_kms_helper        258048  1 nvidia_drm
ipmi_msghandler        73728  2 ipmi_devintf,nvidia
drm                   581632  5 drm_kms_helper,nvidia_drm
$ ls -lah /dev/nvidi*
crw-rw-rw- 1 root root 195,   0 Jun 26 19:11 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Jun 26 19:11 /dev/nvidiactl
crw-rw-rw- 1 root root 195, 254 Jun 26 19:11 /dev/nvidia-modeset
$ ls -l /dev/dri
total 0
drwxr-xr-x  2 root root         80 Jun 26 19:11 by-path
crw-rw----+ 1 root video  226,   0 Jun 26 19:11 card0
crw-rw-rw-  1 root render 226, 128 Jun 26 19:11 renderD128

I'm using XFCE and have compositor disabled to avoid any conflicts.

Here is some error-stuff finally, but how to solve it? Is it the actual problem? I have already (re-)installed the nvidia driver a few times:

$ cat /var/log/Xorg.0.log | grep EE
[     2.443] Current Operating System: Linux archlinux 5.7.5-arch1-1 #1 SMP PREEMPT Mon, 22 Jun 2020 08:10:02 +0000 x86_64
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     3.130] (EE) NVIDIA: Failed to load module "glxserver_nvidia" (module does not exist, 0)
[     3.130] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[     3.130] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[     3.130] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[     3.130] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[     3.130] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
[     4.083] (II) Initializing extension MIT-SCREEN-SAVER

Solved: https://bbs.archlinux.org/viewtopic.php … 9#p1912429

Last edited by millus (2020-06-26 21:49:00)

Offline

#2 2020-06-26 18:21:11

Ropid
Member
Registered: 2015-03-09
Posts: 884

Re: [SOLVED] OpenGL Renderer is software despite NVidia card+driver

I'd try to reboot and see what happens.

I would remove the xorg.conf file. Using one was sometimes the cause of problems for me, and it never did actually help with anything.

The "glxserver_nvidia" module is part of the "nvidia-utils" package. You have installed that package already, so I don't understand the error message about a missing module.

Last edited by Ropid (2020-06-26 18:21:48)

Offline

#3 2020-06-26 20:18:58

seth
Member
Registered: 2012-09-03
Posts: 16,266

Re: [SOLVED] OpenGL Renderer is software despite NVidia card+driver

If the reboot doesn't cut it, please remove the xorg.conf (it's useless and full of cruft, don't use nvidia-xsettings to generate a config and ideally don't use a static config at all) and post your complete Xorg log and the output of "pacman -Qkk nvidia-utils".

Offline

#4 2020-06-26 21:48:26

millus
Member
Registered: 2019-07-21
Posts: 43

Re: [SOLVED] OpenGL Renderer is software despite NVidia card+driver

Ok, I fixed it! Lol. And so suddenly now after actually searching for quite some time on the webz (forum was last resort after I hit a wall).

I did:
- remove xorg.conf file as you suggested
- reinstalled "nvidia-utils" package as you noted that the module thing was odd
- installed "nvidia-dkms" package just because it was literallly the only nvidia thing that I did NOT have installed :-p
- rebooted ->

gl-renderer is finally nvidia again!:

$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1080 Ti/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 440.100
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 440.100
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 440.100
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

As per your request now (but I guess _before_ would have been more interesting, sorry..):

$ pacman -Qkk nvidia-utils
nvidia-utils: 178 total files, 0 altered files

And just for the record: I do not have any particular kernel options or such stuff. Just mentioning this since on the webs it was often suggested to add some nvidia-dri blabla options to the kernel line. Those didn't help in my case.

I'm just not sure about the xorg.conf. The reason I generated one by running nvidia-settings was that my screen was running on 60Hz instead of using its 144Hz capabilities, and this changed when I generated that xorg.conf.
So I'm not sure if my monitor won't now be running in a "downgraded" (60 hz again) state in certain games again now that I removed it hmm
Edit:
I just tried out a game and the result is that it is running in 144 Hz fine, but.. not in G-Sync anymore! sad arrgh

Edit 2:
Um, now suddenly G-Sync works again. I didn't change anything at all. It just randomly decided to be ok. I didn't even reboot, but just woke the pc up from sleep ("suspend") since yesterday.

Last edited by millus (2020-06-27 09:35:01)

Offline

#5 2020-06-27 10:13:14

seth
Member
Registered: 2012-09-03
Posts: 16,266

Re: [SOLVED] OpenGL Renderer is software despite NVidia card+driver

You can activate g-sync in nvidia settings for incompliant outputs, but I don't see anything in your xorg.conf that would impact that.
You could check whether the driver allows you to cli-configure this - try "nvidia-settings -q all | grep -i sync" (but idk whether this is exported as variable nor its actual name)

Offline

Board footer

Powered by FluxBB