You are not logged in.

#1 2020-06-27 18:12:11

Sanjeev K Sharma
Member
Registered: 2013-08-14
Posts: 71

[SOLVED] RTC going insane - changing the battery did not help -

Hello all

I have an old system I'm trying to resurrect.  It's an NVIDIA nf4 chipset, the old dfi LANPARTY boards

The date changes by itself completely randomly every few seconds - back to 2005, up to 2020, and back to 2010.

I used the date command to set a new time, and looped that in bash every second.  even within the time it takes between these commands, the time changes.

This wreck networking on this system, at a minimum.  I can't tell what other, pernicious effects it could be having.

I changed the button cell (CR2032 type) but it didn't help.

Anything else I can try, or is this motherboard stuffed & fit only for garbage?

Last edited by Sanjeev K Sharma (2020-06-27 19:41:29)

Offline

#2 2020-06-27 18:29:44

loqs
Member
Registered: 2014-03-06
Posts: 11,699

Re: [SOLVED] RTC going insane - changing the battery did not help -

What clock source options are available?

cat /sys/devices/system/clocksource/*/available_clocksource

Offline

#3 2020-06-27 18:37:09

Sanjeev K Sharma
Member
Registered: 2013-08-14
Posts: 71

Re: [SOLVED] RTC going insane - changing the battery did not help -

acpi_pm

loqs wrote:

What clock source options are available?

cat /sys/devices/system/clocksource/*/available_clocksource

Offline

#4 2020-06-27 18:51:50

loqs
Member
Registered: 2014-03-06
Posts: 11,699

Re: [SOLVED] RTC going insane - changing the battery did not help -

acpm_pm should be the broken rtc.  I was hoping for an alternative such as hpet or tsc.
Please try booting with the kernel paramater clocksource=jiffies
Edit:
Then set the clock once and see if it maintains the time.

Last edited by loqs (2020-06-27 18:54:13)

Offline

#5 2020-06-27 19:21:46

Sanjeev K Sharma
Member
Registered: 2013-08-14
Posts: 71

Re: [SOLVED] RTC going insane - changing the battery did not help -

great, thanks

OK, with the jiffies it's maintaining the time.  got networking working (but still no dhcp, it must be static for some reason).

Now I'll find a way to set it so I need not set the time manually at every boot

what I'm still noticing is that ping will do 10 or 30 lines, then I get a report
ping: warning - time of day goes back (-239852986293us) taking countermeasures


loqs wrote:

acpm_pm should be the broken rtc.  I was hoping for an alternative such as hpet or tsc.
Please try booting with the kernel paramater clocksource=jiffies
Edit:
Then set the clock once and see if it maintains the time.

Last edited by Sanjeev K Sharma (2020-06-27 19:24:21)

Offline

#6 2020-06-27 20:21:53

loqs
Member
Registered: 2014-03-06
Posts: 11,699

Re: [SOLVED] RTC going insane - changing the battery did not help -

See https://wiki.archlinux.org/index.php/Sy … ronization to automate setting the correct time.

Offline

Board footer

Powered by FluxBB