You are not logged in.

#1 2020-06-28 15:33:42

From: The Netherlands
Registered: 2020-01-08
Posts: 20

[SOLVED] Steam suddenly can't detect XBox One Controller (usb)?

--- somehow after tweaking with modprobe xpad I got it working again ---
Forget the question, thx!

Hi, somehow Steam can't detect my XBox One Controller anymore. It's connected via usb (shows up via lsusb) and every button works just fine if I check it out via Used it in Big Picture mode, now nothing. Also tried installing beta version of Steam, still nothing. Where should I try to look further?

dmesg no issues, last message (no errors):
[12010.032218] input: Microsoft X-Box One pad as /devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:06:00.1/usb1/1-4/1-4:1.0/input/input39

(If I connect this controller to my laptop - almost same setup Arch/Steam) it runs like a charm! Although one thing I can't figure out yet and that is that on my laptop dmesg gives an extra last message, being:
[14033.424302] usbcore: registered new interface driver xpad

This "usbcore" message doesn't show up on my "main" computer, could this have anything to do with Steam not finding this controller anymore?

Thx, regards, Zach

Last edited by zachalexy (2020-06-28 16:06:08)


Board footer

Powered by FluxBB