You are not logged in.

#1 2020-06-28 17:47:09

Registered: 2018-02-16
Posts: 5

Virt-manager can't find bootable device after restart

Recently I have tried to set up virtual machines with qemu/kvm, libvirt and virt-manager. Everything went fine till I restarted my virtual machine.

At first, the 'raw' archiso image was converted to 'qcow2' format and it booted. Then, I shut it down and tried to open it again. This time I was greeted with

Booting from hard disk
Boot failed: not a bootable disk
No bootable device

I searched about it and found this. Apparently, virt-manager mixes up with 'raw' and 'qcow2' format. However, the posts and bugs I found are quite old. Nonetheless, I tried the process mentioned there. I imported, edited and exported the xml file. Still, the virtual machine won't boot from the 'qcow2' image.

I also tried to use the iso image directly as a boot option. If BIOS is set, the boot can happen from the iso image. It doesn't work in the case of UEFI.

PS: I have also tried gnome-boxes as a client. Gnome-boxes didn't cause such a problem. But, it didn't create a 'qcow2' image though.


Board footer

Powered by FluxBB