You are not logged in.

#1 2020-07-08 10:19:00

borgch
Member
Registered: 2017-10-10
Posts: 5

[SOLVED] Error while updating nvidia-390xx

I upgrade my system with

 $ yay -Syu 

This time I have got the following error

installing nvidia-390xx-utils (390.138-3) breaks dependency 'nvidia-390xx-utils=390.132' required by nvidia-390xx

There is four updating packages from AUR.

4  aur/libxnvctrl-390xx       390.132-2  -> 390.138-1
3  aur/nvidia-390xx           390.132-38 -> 390.138-3
2  aur/nvidia-390xx-settings  390.132-2  -> 390.138-1
1  aur/nvidia-390xx-utils     390.132-2  -> 390.138-3

How can I solve this issue?

Last edited by borgch (2020-07-14 19:15:03)

Offline

#2 2020-07-08 12:11:11

Awebb
Member
Registered: 2010-05-06
Posts: 5,523

Re: [SOLVED] Error while updating nvidia-390xx

It's yay's fault. It doesn't understand, that the right dependency will be i stalled later. Learn to use the AUR before you rely on crutches like yay.

Do it manually and everything will be fine.

Offline

#3 2020-07-10 02:40:25

quimkaos
Member
Registered: 2014-09-27
Posts: 42

Re: [SOLVED] Error while updating nvidia-390xx

i don't think it's only yay fault (i don't use yay btw).

first the nvidia-390xx-dkms AUR package  (https://aur.archlinux.org/packages/nvidia-390xx-dkms/) points to an empty git:

git clone https://aur.archlinux.org/nvidia-390xx-dkms 

is an empty git repository
I don't know if the package changed hands but this was the repository i originally downloaded and installed, and i had no problems until the last update.
now you have to use:

git clone https://aur.archlinux.org/nvidia-390xx

but first you have to update at least nvidia-390xx-utils (i had to also update lib32-nvidia-390xx-utils) before updating the driver.

Offline

#4 2020-07-10 03:20:07

Awebb
Member
Registered: 2010-05-06
Posts: 5,523

Re: [SOLVED] Error while updating nvidia-390xx

OP didn't use the DKMS package. The DKMS package now seems to be part of nvidia-390xx. Those problems are unrelated. Manually solving the dependencies (and not using yay this time) is still the way to go.

Offline

#5 2020-07-14 19:12:06

borgch
Member
Registered: 2017-10-10
Posts: 5

Re: [SOLVED] Error while updating nvidia-390xx

Awebb wrote:

OP didn't use the DKMS package. The DKMS package now seems to be part of nvidia-390xx. Those problems are unrelated. Manually solving the dependencies (and not using yay this time) is still the way to go.

Thanks you for the advice. Manual installation works.

Offline

#6 2020-07-27 13:49:31

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,614
Website

Re: [SOLVED] Error while updating nvidia-390xx

Interesting ... in my case the git repository mentioned by quimkaos (git clone https://aur.archlinux.org/nvidia-390xx) returns an error upon running makepkg:

Missing dependencies:
-> nvidia-390xx-utils=390.138
==> ERROR: Could not resolve all dependencies.

Last edited by ralvez (2020-07-27 13:50:29)

Offline

#7 2020-07-27 14:33:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,140

Re: [SOLVED] Error while updating nvidia-390xx

Which is entirely expected and the same solution as presented in this thread, install nvidia-390xx-utils first if you do it manually.

Offline

Board footer

Powered by FluxBB