You are not logged in.

#1 2020-07-08 19:52:38

knille
Member
Registered: 2014-02-24
Posts: 12

[SOLVED] alsa-lib (1.2.3.2-1) breaks dependency 'alsa-lib=1.2.3.1'

hi,

when doing

pacman -Syu

today, i got

error: failed to prepare transaction (could not satisfy dependencies)
:: installing alsa-lib (1.2.3.2-1) breaks dependency 'alsa-lib=1.2.3.1' required by lib32-alsa-lib

to make updates possible again i put

IgnorePkg = alsa-lib

into /etc/pacman.conf. but this is just a temporary workaround. does anyone know what's going on?

Last edited by knille (2020-07-09 16:08:45)

Offline

#2 2020-07-08 19:59:28

loqs
Member
Registered: 2014-03-06
Posts: 11,247

Re: [SOLVED] alsa-lib (1.2.3.2-1) breaks dependency 'alsa-lib=1.2.3.1'

The mirror you used had an updated extra repository but not an updated multilib so the update did not contain lib32-alsa-lib 1.2.3.2-1
Edit:
Another possibility is you disabled multilib without removing packages installed from it.  I can not tell as you only showed a part of the output from pacman.

Last edited by loqs (2020-07-08 20:09:47)

Offline

#3 2020-07-09 16:08:05

knille
Member
Registered: 2014-02-24
Posts: 12

Re: [SOLVED] alsa-lib (1.2.3.2-1) breaks dependency 'alsa-lib=1.2.3.1'

hey loqs, thanks for the hint.

yes, i think the mirror was not up-to-date. today the update didn't show any problems anymore.

Offline

Board footer

Powered by FluxBB