You are not logged in.

#1 2020-07-19 21:17:34

soylent_green_is_hamster
Member
Registered: 2006-11-15
Posts: 109

KMS with Nvidia card

Hey guys,

I'm trying to get Kernel mode setting on my fresh Arch install. It just doesn't work. Here is my systemd-boot entry

title Arch Linux
linux /vmlinuz-linux
initrd /initramfs-linux.img
options nvidia-drm.modeset=1 root=PARTUUID=7c4a9f15-4159-864f-868c-7fa970dc697b rw

I've also added the nvidia modules to my mkinitcpio modules (and rebuilt the images)

I'm not sure what else I can check, any suggestions?

I'm also seeing this on boot. Possibly related...

[    3.647020] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000

cheers!

Offline

#2 2020-07-19 22:15:13

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,816

Re: KMS with Nvidia card

What's your definition of "just doesn't work" ? If you expect a high res console that isn't inherently related to KMS and not expected to be fixed by that setting. What this should allow you is at the very least switching between a VT and a graphical session properly as well as using wayland sessions for things that support nvidia.

Offline

#3 2020-07-20 06:58:22

soylent_green_is_hamster
Member
Registered: 2006-11-15
Posts: 109

Re: KMS with Nvidia card

Yeah - I was expecting a high res terminal.

I realise now I'm not going to get this with nvidia and systemd-boot

cheers

Offline

#4 2020-07-24 00:52:03

virtualdxs
Member
Registered: 2017-02-06
Posts: 6

Re: KMS with Nvidia card

I'm having this issue, and it is related to KMS. Using systemd-boot, if the menu is displayed (i.e. timeout is set or a key is pressed in the brief interval when timeout is unset), I get a low-res terminal regardless of the modeset setting. If the menu was not displayed (i.e. timeout unset and no key hit), I get the high-res terminal if nvidia-drm.modeset=1 is present, low-res otherwise. Any ideas why the menu being displayed would affect this, and any ideas of a workaround?

Offline

#5 2020-07-24 06:51:03

seth
Member
Registered: 2012-09-03
Posts: 16,607

Re: KMS with Nvidia card

If you're booting the same initramfs, fix your bootmanager config.
https://wiki.archlinux.org/index.php/Sy … figuration

Otherwise you might require https://wiki.archlinux.org/index.php/Ke … _KMS_start

Offline

#6 2020-07-24 22:14:34

virtualdxs
Member
Registered: 2017-02-06
Posts: 6

Re: KMS with Nvidia card

This is my loader.conf:

timeout 3
console-mode max
default arch-mainline.conf

Same results with console-mode max and unset. I'll look into early KMS.

EDIT: Realized I pasted an entry and not the loader.conf.

Last edited by virtualdxs (2020-07-25 17:55:06)

Offline

Board footer

Powered by FluxBB