You are not logged in.

#1 2020-07-22 23:03:42

dmitresky
Member
Registered: 2020-07-22
Posts: 1

[Solved] pam 1.3.1-2 to 1.4.0-2

After upgraded pam 1.3.1-2 > 1.4.0-2 i can't log in as either  root no user.
Changed pass using ISO image, didn't  help.
After downgrade to 1.3.1-2 work  again.


Sorry didn't answer for a long  time.
"Merge /etc/pam.d/system-login with it's .pacnew." help me.
Thank you  all.

Last edited by dmitresky (2020-07-23 21:11:04)

Offline

#2 2020-07-23 06:56:33

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: [Solved] pam 1.3.1-2 to 1.4.0-2

Much more detail needed. I saw no issue with the upgrade, and if others experienced it, we would have heard by now...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2020-07-23 16:14:51

jmad980
Member
From: Califonia
Registered: 2010-03-11
Posts: 54

Re: [Solved] pam 1.3.1-2 to 1.4.0-2

Not certain this is the cause yet (have been too busy to look into it) but I've had the same issue after updating a day ago.

Neither my user account nor root will login from the main Linux prompt (not using a display manager)

In my journalctl I see "PAM unable to dlopen(/usr/lib/security/pam_tally2.so): /usr/lib/security/pam_tally2.so: cannot open shared object file: No such file or directory"

Prior to login failure,
Which indeed appears not to exist.

I'm not certain what would call that module but will note that there is documentation included in the pam package, but the module itself is absent.


Someone call a doctor, my awesome configuration broke again! || To err is human -- to blame it on a computer is even more so.

Offline

#4 2020-07-23 16:31:31

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

Re: [Solved] pam 1.3.1-2 to 1.4.0-2

Have you merged the pacnew files?

Offline

#5 2020-07-23 16:35:52

loqs
Member
Registered: 2014-03-06
Posts: 11,923

Re: [Solved] pam 1.3.1-2 to 1.4.0-2

https://bugs.archlinux.org/task/67347

Merge /etc/pam.d/system-login with it's .pacnew.

Offline

#6 2020-07-23 16:39:17

jmad980
Member
From: Califonia
Registered: 2010-03-11
Posts: 54

Re: [Solved] pam 1.3.1-2 to 1.4.0-2

Yeah that fixed it.

I know it's my responsibility to pay attention to such things (I just did an update and then went to sleep without paying attention), but that is a rather unfortunate failure mode. (Though I guess anything dealing with login is always risky)


Someone call a doctor, my awesome configuration broke again! || To err is human -- to blame it on a computer is even more so.

Offline

#7 2020-09-07 21:05:25

NewWorld
Member
Registered: 2010-02-15
Posts: 32

Re: [Solved] pam 1.3.1-2 to 1.4.0-2

For those who don't have the `.pacnew` file, check if you have an unmerged `/etc/pam.d/login.pacnew`. Bizarrely I received no warning from pacman about this .pacnew file (I checked my pacman logs to confirm this). Merging this file fixed the issue for me.
The `login` file I had was from 2011!

Offline

Board footer

Powered by FluxBB