You are not logged in.

#1 2020-07-25 15:04:20

kunver400
Member
Registered: 2020-02-25
Posts: 9

Unable to change the refreshrate to 60hz panel:LQ156M1JW09

I can't seem to change my laptop display's refreshrate to 60hz from 240hz, xrandr reports 60hz but it stays at 240hz,
resolution is changing perfectly.

glxgears displays 240hz, while i can clearly see that it isn't 60hz   yikes

I have tried the these modelines from the following sources

cvt:

cvt 1920 1080
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

modelines from xf86-video-intel log @ /var/log/Xorg.0.log

xf86-video-intel
[     9.095] (II) intel(0): Printing DDC gathered Modelines:
[     9.095] (II) intel(0): Modeline "1920x1080"x0.0  533.28  1920 1944 1984 2000  1080 1083 1088 1111 -hsync -vsync (266.6 kHz eP)
[     9.095] (II) intel(0): Modeline "1920x1080"x0.0  133.32  1920 1944 1984 2000  1080 1083 1088 1111 -hsync -vsync (66.7 kHz e)

by testing via xrandr and directly adding to xorg.conf
also tried modes from here https://github.com/linuxhw/EDID/blob/ma … 89A3F33AB5


initial xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    240.00*+  60.00  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
DP-1-0 disconnected
DP-1-1 disconnected
HDMI-1-0 disconnected

initial xorg.conf

Section "ServerLayout"
        Identifier "layout"
        Screen 0 "intel"
        Inactive "nvidia"
        Option "AllowNVIDIAGPUScreens"
EndSection

Section "Device"
        Identifier "intel"
        Driver "intel"
        BusID "PCI:0:2:0"
        Option "DRI" "3"
EndSection

Section "Screen"
        Identifier "intel"
        Device "intel"
EndSection

Section "Device"
        Identifier "nvidia"
        Driver "nvidia"
        BusID "PCI:1:0:0"
        Option "Coolbits" "28"
EndSection

Section "Screen"
        Identifier "nvidia"
        Device "nvidia"
EndSection

Last edited by kunver400 (2020-07-28 11:46:17)

Offline

#2 2020-07-26 10:53:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,474

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

Please use [ code ] rather than [ quote ] for posting outputs. Post the exact xrandr command you are using, maybe also try with the modesetting rather than the intel xorg driver.

Offline

#3 2020-07-28 11:51:23

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

I have tried with modesetting driver too but no luck.

i have tested the modelines using :

xrandr --newmode "INTEL1920x1080_60.00"  133.32  1920 1944 1984 2000  1080 1083 1088 1111 -hsync -vsync

xrandr --addmode eDP1 INTEL1920x1080_60.00

xrandr --output eDP1 --mode INTEL1920x1080_60.00

Last edited by kunver400 (2020-07-28 14:26:31)

Offline

#4 2020-07-28 11:55:50

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,381
Website

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

Well, this should have added add a mode with 133.32 MHz.
What's the output of

xrandr

after you ran the two commands above?
PS: You can also let the correct mode line be calculated by gtf:

gtf 1920 1080 60

Last edited by schard (2020-07-28 12:01:43)


Солідарність з Україною

Offline

#5 2020-07-28 14:31:09

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

gtf gives me this

gtf 1920 1080 60

  # 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

still no luck.

Offline

#6 2020-07-28 14:45:36

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

schard wrote:

Well, this should have added add a mode with 133.32 MHz.
What's the output of

xrandr

after you ran the two commands above?
PS: You can also let the correct mode line be calculated by gtf:

gtf 1920 1080 60

i have tried .. sad

$ xrandr --newmode "INTEL1920x1080_60.00"  133.32  1920 1944 1984 2000  1080 1083 1088 1111 -hsync -vsync
$ xrandr --newmode "INTEL1920x1080_240.00"  533.28  1920 1944 1984 2000  1080 1083 1088 1111 -hsync -vsync
$ xrandr --newmode "INTEL1366x768_60.00"  133.32  1366 1944 1984 2000  768 1083 1088 1111 -hsync -vsync
$ xrandr --newmode "INTEL1366x768_240.00"  533.28  1366 1944 1984 2000  768 1083 1088 1111 -hsync -vsync
$ xrandr --newmode "CVT1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
$ xrandr --newmode "GTF1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
$ xrandr

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    240.00*+  60.00  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
DP-1-0 disconnected
DP-1-1 disconnected
HDMI-1-0 disconnected
  INTEL1920x1080_60.00 (0x375) 133.320MHz -HSync -VSync
        h: width  1920 start 1944 end 1984 total 2000 skew    0 clock  66.66KHz
        v: height 1080 start 1083 end 1088 total 1111           clock  60.00Hz
  INTEL1920x1080_240.00 (0x376) 533.280MHz -HSync -VSync
        h: width  1920 start 1944 end 1984 total 2000 skew    0 clock 266.64KHz
        v: height 1080 start 1083 end 1088 total 1111           clock 240.00Hz
  INTEL1366x768_60.00 (0x377) 133.320MHz -HSync -VSync
        h: width  1366 start 1944 end 1984 total 2000 skew    0 clock  66.66KHz
        v: height  768 start 1083 end 1088 total 1111           clock  60.00Hz
  INTEL1366x768_240.00 (0x378) 533.280MHz -HSync -VSync
        h: width  1366 start 1944 end 1984 total 2000 skew    0 clock 266.64KHz
        v: height  768 start 1083 end 1088 total 1111           clock 240.00Hz
  CVT1920x1080_60.00 (0x37b) 173.000MHz -HSync +VSync
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.16KHz
        v: height 1080 start 1083 end 1088 total 1120           clock  59.96Hz
  GTF1920x1080_60.00 (0x37d) 172.800MHz -HSync +VSync
        h: width  1920 start 2040 end 2248 total 2576 skew    0 clock  67.08KHz
        v: height 1080 start 1081 end 1084 total 1118           clock  60.00Hz
$ xrandr --addmode eDP1 "INTEL1920x1080_60.00"
$ xrandr --addmode eDP1 "INTEL1920x1080_240.00"
$ xrandr --addmode eDP1 "INTEL1366x768_60.00"
$ xrandr --addmode eDP1 "INTEL1366x768_240.00"
$ xrandr --addmode eDP1 "CVT1920x1080_60.00"
$ xrandr --addmode eDP1 "GTF1920x1080_60.00"

$ xrandr --output eDP1 --mode INTEL1920x1080_60.00  // 240hz
$ xrandr --output eDP1 --mode INTEL1366x768_60.00   // just the resoultion changes still 240hz
$ xrandr --output eDP1 --mode INTEL1920x1080_60.00  // just the resoultion changes still 240hz
$ xrandr --output eDP1 --mode CVT1920x1080_60.00    // 240hz
$ xrandr --output eDP1 --mode GTF1920x1080_60.00    // still 240hz

Last edited by kunver400 (2020-07-28 14:47:30)

Offline

#7 2020-07-28 14:47:59

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,387

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

kunver400:  If you were wondering where your post went, I think you meant to reply rather than report.

kunver400 wrote:

gtf gives me this

gtf 1920 1080 60

# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

xrandr --newmode "GTF1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

xrandr --addmode eDP1 GTF1920x1080_60.00

xrandr --output eDP1 --mode GTF1920x1080_60.00

Last edited by ewaller (2020-07-28 14:49:44)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#8 2020-07-28 14:50:41

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

that's right,

ewaller wrote:

kunver400:  If you were wondering where your post went, I think you meant to reply rather than report.

kunver400 wrote:

gtf gives me this

gtf 1920 1080 60

# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

xrandr --newmode "GTF1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

xrandr --addmode eDP1 GTF1920x1080_60.00

xrandr --output eDP1 --mode GTF1920x1080_60.00

Offline

#9 2020-07-29 03:16:46

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

FYI,

I have tested the mentioned modelines with modesetting driver as well

Section "ServerLayout"
        Identifier "layout"
        Screen 0 "intel"
        Inactive "nvidia"
        Option "AllowNVIDIAGPUScreens"
EndSection

Section "Device"
        Identifier "intel"
        Driver "modesetting"
        BusID "PCI:0:2:0"
        Option "DRI" "3"
EndSection

Section "Screen"
        Identifier "intel"
        Device "intel"
EndSection

Section "Device"
        Identifier "nvidia"
        Driver "nvidia"
        BusID "PCI:1:0:0"
        Option "Coolbits" "28"
EndSection

Section "Screen"
        Identifier "nvidia"
        Device "nvidia"
EndSection

Offline

#10 2020-07-29 10:33:53

Ropid
Member
Registered: 2015-03-09
Posts: 1,068

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

@kunver400: Why are you trying to define new modes? According to your xrandr output and Xorg log file, there is already a 60Hz mode. Does that 60Hz mode not work for you? You should normally be able to switch to it with a command line like the following:

xrandr --output eDP1 --mode 1920x1080 --rate 60

About defining new modes, you could try to do that with an Xorg config file like this instead of "xrandr --newmode":

Section "Monitor"
    Identifier "eDP1"
    # 1920x1080 @ 60.000 Hz Reduced Blank (CVT) field rate 60.000 Hz; hsync: 66.660 kHz; pclk: 133.32 MHz
    Modeline "1920x1080_60"  133.32  1920 1928 1960 2000  1080 1097 1105 1111 +hsync -vsync
    #Option "PreferredMode" "1920x1080_60"
EndSection

The "Identifier" name is used to target a certain monitor output. You save this kind of file as for example "/etc/X11/xorg.conf.d/10-monitor.conf".

I created that with a tool "cvt12" from the AUR with this command line:

$ cvt12 1920 1080 60 -b
# 1920x1080 @ 60.000 Hz Reduced Blank (CVT) field rate 60.000 Hz; hsync: 66.660 kHz; pclk: 133.32 MHz
Modeline "1920x1080_60.00_rb2"  133.32  1920 1928 1960 2000  1080 1097 1105 1111 +hsync -vsync

Last edited by Ropid (2020-07-29 10:42:27)

Offline

#11 2020-07-29 14:20:40

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

@Ropid

yes, xrandr default modes are not working for me,just now tried modelines from cvt12 , can't seem to resolve this, i must be missing something.

Offline

#12 2020-07-30 16:02:27

kunver400
Member
Registered: 2020-02-25
Posts: 9

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

any ideas?

Offline

#13 2020-07-30 16:31:53

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,975

Re: Unable to change the refreshrate to 60hz panel:LQ156M1JW09

kunver400 wrote:

any ideas?

Please don't do that.


How to post. A sincere effort to use modest and proper language and grammar is a sign of respect toward the community.

Offline

Board footer

Powered by FluxBB