You are not logged in.

#1 2020-07-25 17:58:51

zpg443
Member
Registered: 2016-12-03
Posts: 90

Can't authenticate against AUR

It appears the new server is running, but now I am having trouble with using the old public key:

ssh -v zpg443@aur.archlinux.org
OpenSSH_8.3p1, OpenSSL 1.1.1g  21 Apr 2020
debug1: Reading configuration data /home/zpg443/.ssh/config
debug1: /home/zpg443/.ssh/config line 1: Applying options for aur.archlinux.org
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to aur.archlinux.org [95.216.144.15] port 22.
debug1: Connection established.
debug1: identity file /home/zpg443/.ssh/aur type 0
debug1: identity file /home/zpg443/.ssh/aur-cert type -1
debug1: identity file /home/zpg443/.ssh/id_rsa type 0
debug1: identity file /home/zpg443/.ssh/id_rsa-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.3
debug1: Remote protocol version 2.0, remote software version OpenSSH_8.3
debug1: match: OpenSSH_8.3 pat OpenSSH* compat 0x04000000
debug1: Authenticating to aur.archlinux.org:22 as 'zpg443'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:uTa/0PndEgPZTf76e1DFqXKJEXKsn7m9ivhLQtzGOCI
debug1: Host 'aur.archlinux.org' is known and matches the ECDSA host key.
debug1: Found key in /home/zpg443/.ssh/known_hosts:5
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey in after 134217728 blocks
debug1: Will attempt key: /home/zpg443/.ssh/aur RSA SHA256:U4/hqWZQhm61Qi/rHO/NwmjyIb4gMk+e4w2BPxBOmzE explicit
debug1: Will attempt key: /home/zpg443/.ssh/id_rsa RSA SHA256:/gv1CfgyH20jw4luXU+bV2fUHcbwKZwQfD1KN/Z+fmE
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,sk-ssh-ed25519@openssh.com,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /home/zpg443/.ssh/aur RSA SHA256:U4/hqWZQhm61Qi/rHO/NwmjyIb4gMk+e4w2BPxBOmzE explicit
debug1: Authentications that can continue: publickey
debug1: Offering public key: /home/zpg443/.ssh/id_rsa RSA SHA256:/gv1CfgyH20jw4luXU+bV2fUHcbwKZwQfD1KN/Z+fmE
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
zpg443@aur.archlinux.org: Permission denied (publickey).

.ssh/config:

Host aur.archlinux.org
  IdentityFile ~/.ssh/aur
  User zpg443 

I regenerated a public key aur.pub, and manually pasted the key on the webpage form. Still generating "permission denied"

Tried also copying via konsole, no go:

[zpg443@archmain aur_archsimian]$ ssh-copy-id -i ~/.ssh/aur.pub zpg443@aur.archlinux.org
/usr/bin/ssh-copy-id: INFO: Source of key(s) to be installed: "/home/zpg443/.ssh/aur.pub"
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys
zpg443@aur.archlinux.org: Permission denied (publickey).

Is this just me or is the transition just not completed yet? According to the wiki, it may be still too early...

https://gitlab.archlinux.org/archlinux/ … ations/aur

Edited to add /etc/ssh/sshd_config:

#	$OpenBSD: sshd_config,v 1.103 2018/04/09 20:41:22 tj Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/sbin:/usr/local/bin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
PermitRootLogin no
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#PubkeyAuthentication yes

# The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
# but this is overridden so installations will only check .ssh/authorized_keys
AuthorizedKeysFile	.ssh/authorized_keys

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no # pam does that
#PrintLastLog yes
#TCPKeepAlive yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# override default of no subsystems
Subsystem	sftp	/usr/lib/ssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User openhabian
#	X11Forwarding no
#	AllowTcpForwarding no
#	PermitTTY no
#	ForceCommand cvs server
#	PasswordAuthentication no
#	ForceCommand internal-sftp

Last edited by zpg443 (2020-07-25 18:17:45)

Offline

#2 2020-07-25 20:13:38

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,875
Website

Re: Can't authenticate against AUR

This isn't related to the the server's host keys. You're just not authenticating as the correct user.

https://wiki.archlinux.org/index.php/AU … entication

Mod note: splitting from https://bbs.archlinux.org/viewtopic.php?id=257629

Last edited by WorMzy (2020-07-25 20:14:45)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

#3 2020-07-25 20:25:20

zpg443
Member
Registered: 2016-12-03
Posts: 90

Re: Can't authenticate against AUR

Don't I feel stupid! All good now, thanks!

Offline

Board footer

Powered by FluxBB