You are not logged in.

#1 2020-07-25 22:32:17

k4iru
Member
Registered: 2018-01-07
Posts: 4

no audio when using headphones.

Hi, after I updated my system my headphones don't work anymore. Audio still plays from my speakers fine when headphones are unplugged. Also after the update I now have two audio mixer icons in my tray.
one from kmixer and one from plasma if that is helpful. I am on a dual boot windows 10 system. So far I have checked that fast boot is off in uefi settings and my windows boot settings. My headphones do seem to be detected when
I plug them in because my input device changes in the mixer. I've run alsamixer to make sure nothing is muted, though when I plug in my headphones the soundcard for alsamixer changes to 'pulseaudio' and I only have a master channel.

here are some logs

$ sudo fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  kyle       1020 F.... pulseaudio
$ pacmd list-cards
1 card(s) available.
    index: 0
        name: <alsa_card.pci-0000_00_1f.3>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xef228000 irq 129"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "9d71"
                device.product.name = "Sunrise Point-LP HD Audio"
                device.form_factor = "internal"
                device.string = "0"
                device.description = "Built-in Audio"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
                output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5965, available: no)
                output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 865, available: no)
                output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) Output + Analog Stereo Input (priority 865, available: no)
                output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
                output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
                output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
                output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
                output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input (priority 665, available: no)
                off: Off (priority 0, available: unknown)
        active profile: <output:analog-stereo+input:analog-stereo>
        sinks:
                alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
        sources:
                alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
                alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Built-in Audio Analog Stereo
        ports:
                analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "audio-headphones"
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
$ pacmd list-sinks
1 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 9039
        volume: front-left: 22935 /  35% / -27.36 dB,   front-right: 22935 /  35% / -27.36 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 0
        sample spec: s16le 2ch 48000Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 1
        configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
        card: 0 <alsa_card.pci-0000_00_1f.3>
        module: 6
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC295 Analog"
                alsa.id = "ALC295 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xef228000 irq 129"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "9d71"
                device.product.name = "Sunrise Point-LP HD Audio"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "384000"
                device.buffering.fragment_size = "192000"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Realtek ALC295"
                alsa.components = "HDA:10ec0295,10431740,00100002 HDA:8086280b,80860101,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "audio-headphones"
        active port: <analog-output-headphones>
$ pacmd list-sink-inputs
1 sink input(s) available.
    index: 0
        driver: <protocol-native.c>
        flags: START_CORKED 
        state: CORKED
        sink: 0 <alsa_output.pci-0000_00_1f.3.analog-stereo>
        volume: front-left: 61439 /  94% / -1.68 dB,   front-right: 61439 /  94% / -1.68 dB
                balance 0.00
        muted: no
        current latency: 1600.59 ms
        requested latency: 980.00 ms
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        resample method: speex-float-1
        module: 8
        client: 12 <Spotify>
        properties:
                media.role = "music"
                media.name = "Spotify"
                application.name = "Spotify"
                native-protocol.peer = "UNIX socket client"
                native-protocol.version = "33"
                application.process.id = "1436"
                application.process.user = "kyle"
                application.process.host = "kybox"
                application.process.binary = "spotify"
                window.x11.display = ":0"
                application.language = "C"
                application.process.machine_id = "7b8f72337c3c44e894afe607312b3bf5"
                application.process.session_id = "1"
                application.icon_name = "spotify-client"
                module-stream-restore.id = "sink-input-by-media-role:music"

thanks for any help!

Last edited by k4iru (2020-07-25 22:33:51)

Offline

#2 2020-07-26 10:49:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,528

Re: no audio when using headphones.

Looks generally alright, but your spotify is corked and thus not actively playing back. Corking happens with voice applications if they're configured to do so like skype or teamspeak or so and will lead to muting non voice streams. Are any of these running? In any case, while this can be cool in theory it's often quite annoying in practice so you should check whether disabling corking can fix this: Go through your /etc/pulse/default.pa and find and remove/comment the line

load-module module-role-cork

and restart pulse and your audio streams

systemctl --user restart pulseaudio

Offline

#3 2020-07-26 18:30:15

k4iru
Member
Registered: 2018-01-07
Posts: 4

Re: no audio when using headphones.

I don't use any voice applications when on Arch Linux. I commented out the line and restarted my computer, still no audio from headphones. I also don't get any audio from my headphones using sites like youtube etc.

Offline

#4 2020-07-27 06:15:22

viper1411
Member
Registered: 2020-07-27
Posts: 8

Re: no audio when using headphones.

I am having the same problem. I updated my system day after yesterday and then my headphone audio stopped working. My headphone is recognized by the system but there is no sound. I am also dual booting arch along with windows 10.

And here are my logs:

$  sudo fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  gdm         587 F.... pulseaudio
                     viper       849 F.... pulseaudio
/dev/snd/pcmC0D0p:   viper       849 F...m pulseaudio
$ pacmd list-cards
1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa4518000 irq 152"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.product.name = "Cannon Lake PCH cAVS"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
		output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
		output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5965, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 865, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) Output + Analog Stereo Input (priority 865, available: no)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
		output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) Output + Analog Stereo Input (priority 5765, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
		output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) Output + Analog Stereo Input (priority 5765, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
		output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) Output + Analog Stereo Input (priority 5765, available: no)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
		output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
		output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) Output + Analog Stereo Input (priority 5765, available: no)
		output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
		output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input (priority 665, available: no)
		output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
		output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input (priority 665, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
	sources:
		alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
		alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Built-in Audio Analog Stereo
	ports:
		analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
$ pacmd list-sinks
1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9039
	volume: front-left: 40797 /  62% / -12.35 dB,   front-right: 40797 /  62% / -12.35 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 0
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 1
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC295 Analog"
		alsa.id = "ALC295 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa4518000 irq 152"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.product.name = "Cannon Lake PCH cAVS"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "384000"
		device.buffering.fragment_size = "192000"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "Realtek ALC295"
		alsa.components = "HDA:10ec0295,10431bb0,00100002 HDA:8086280b,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-headphones>
$ pacmd list-sink-inputs
1 sink input(s) available.
    index: 15
	driver: <protocol-native.c>
	flags: START_CORKED 
	state: RUNNING
	sink: 0 <alsa_output.pci-0000_00_1f.3.analog-stereo>
	volume: front-left: 0 /   0% / -inf dB,   front-right: 0 /   0% / -inf dB
	        balance 0.00
	muted: no
	current latency: 57.83 ms
	requested latency: 75.00 ms
	sample spec: float32le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	resample method: copy
	module: 11
	client: 8 <Firefox>
	properties:
		media.name = "AudioStream"
		application.name = "Firefox"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.process.id = "2042"
		application.process.user = "viper"
		application.process.host = "arch"
		application.process.binary = "firefox"
		application.language = "en_US.UTF-8"
		window.x11.display = ":1"
		application.process.machine_id = "88e3d25711394261b3b007a77f0d529d"
		application.icon_name = "firefox"
		module-stream-restore.id = "sink-input-by-application-name:Firefox"

Offline

#5 2020-07-27 09:31:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,528

Re: no audio when using headphones.

@viper1411 Your firefox is muted... unmute/up the volume.

If this only happened on a reboot from Windows ensure fastboot is disabled (... and I mean ensure, Windows has a tendency to reenable this on updates) and maybe run

sudo alsactl init

from the linux system.

@k4iru
That you randomly get two mixers sounds to me like something accidentally occupies the correct cards first, but this shouldn't matter that much as it seems to be able to regrab the card correctly, what do you get for

uname -a
dmesg | grep -E 'snd|sof'

. I assume this happened on a kernel upgrade, can you check which, and does reverting to the previous kernel help here?

Offline

#6 2020-07-27 10:17:44

viper1411
Member
Registered: 2020-07-27
Posts: 8

Re: no audio when using headphones.

Thanks V1del for your support.

Sorry my firefox was muted. I unmuted it but its not only with firefox, I cannot get audio from any source. Both in Windows and the bios I have disabled fastboot. I had an older manjaro iso, and the sound was fine in the live system. I also noticed that if I reboot into  windows from the arch system then my  headphones also do not work in windows.

I also tried 

$ sudo alsactl init
alsa-lib main.c:983:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2
Found hardware: "HDA-Intel" "Realtek ALC295" "HDA:10ec0295,10431bb0,00100002 HDA:8086280b,80860101,00100000" "0x1043" "0x1bb0"
Hardware is initialized using a generic method

But it did not work.

Offline

#7 2020-07-27 10:59:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,528

Re: no audio when using headphones.

Then post/check the other part of my post, it's likely this was introduced by a kernel update you need to identify which, and whether a downgrade helps, in which case we can identify the problematic commit

Offline

#8 2020-07-27 18:53:48

k4iru
Member
Registered: 2018-01-07
Posts: 4

Re: no audio when using headphones.

$ uname -a
Linux kybox 5.4.53-1-lts #1 SMP Wed, 22 Jul 2020 20:16:09 +0000 x86_64 GNU/Linux
[kyle@kybox ~]$ dmesg | grep -E 'snd|sof'
[    0.638732] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.638733] software IO TLB: mapped [mem 0x7b6a2000-0x7f6a2000] (64MB)
[    4.011405] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    4.209838] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.426135] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC295: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    4.426138] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.426139] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    4.426140] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    4.426141] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    4.426143] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
[    4.426144] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12

Checking the logs it looks like the kernel did upgrade, I'll try downgrading it report back.

[2020-07-25T16:31:59-0400] [ALPM] upgraded archlinux-appstream-data (20200612-1 -> 20200720-1)
[2020-07-25T16:31:59-0400] [ALPM] upgraded iana-etc (20200707-1 -> 20200720-1)
[2020-07-25T16:32:00-0400] [ALPM] upgraded llvm-libs (10.0.0-2 -> 10.0.1-1)
[2020-07-25T16:32:01-0400] [ALPM] upgraded compiler-rt (10.0.0-1 -> 10.0.1-1)
[2020-07-25T16:32:01-0400] [ALPM] upgraded libutil-linux (2.35.2-1 -> 2.36-1)
[2020-07-25T16:32:01-0400] [ALPM] upgraded clang (10.0.0-3 -> 10.0.1-1)
[2020-07-25T16:32:01-0400] [ALPM] upgraded freecell-solver (5.24.0-1 -> 6.0.1-1)
[2020-07-25T16:32:03-0400] [ALPM] upgraded go (2:1.14.5-1 -> 2:1.14.6-1)
[2020-07-25T16:32:03-0400] [ALPM] upgraded harfbuzz (2.6.8-2 -> 2.7.0-1)
[2020-07-25T16:32:03-0400] [ALPM] upgraded harfbuzz-icu (2.6.8-2 -> 2.7.0-1)
[2020-07-25T16:32:03-0400] [ALPM] upgraded imagemagick (7.0.10.24-1 -> 7.0.10.24-2)
[2020-07-25T16:32:04-0400] [ALPM] upgraded intel-mkl (2020.1.217-6 -> 2020.2.254-1)
[2020-07-25T16:32:04-0400] [ALPM] upgraded jasper (2.0.16-2 -> 2.0.17-1)
[2020-07-25T16:32:05-0400] [ALPM] upgraded util-linux (2.35.2-1 -> 2.36-1)
[2020-07-25T16:32:05-0400] [ALPM] upgraded ndctl (68-2 -> 69-1)
[2020-07-25T16:32:06-0400] [ALPM] upgraded kdevelop (5.5.2-2 -> 5.5.2-3)
[2020-07-25T16:32:06-0400] [ALPM] upgraded libraw (0.19.5-3 -> 0.20.0-1)
[2020-07-25T16:32:06-0400] [ALPM] upgraded kstars (1:3.4.3-1 -> 1:3.4.3-2)
[2020-07-25T16:32:06-0400] [ALPM] upgraded libidn (1.35-3 -> 1.36-1)
[2020-07-25T16:32:06-0400] [ALPM] upgraded libkdcraw (20.04.3-1 -> 20.04.3-2)
[2020-07-25T16:32:08-0400] [ALPM] upgraded linux-firmware (20200519.8ba6fa6-1 -> 20200619.e96c121-1)
[2020-07-25T16:32:09-0400] [ALPM] upgraded linux-lts (5.4.52-1 -> 5.4.53-1)
[2020-07-25T16:32:13-0400] [ALPM] upgraded linux-lts-headers (5.4.52-1 -> 5.4.53-1)
[2020-07-25T16:32:13-0400] [ALPM] upgraded logrotate (3.16.0-1 -> 3.17.0-1)
[2020-07-25T16:32:13-0400] [ALPM] upgraded nodejs (14.5.0-1 -> 14.6.0-1)
[2020-07-25T16:32:14-0400] [ALPM] upgraded npm (6.14.6-1 -> 6.14.7-1)
[2020-07-25T16:32:14-0400] [ALPM] upgraded python-flask-compress (1.4.0-2 -> 1.5.0-1)
[2020-07-25T16:32:14-0400] [ALPM] upgraded python-urllib3 (1.25.9-1 -> 1.25.10-1)
[2020-07-25T16:32:14-0400] [ALPM] upgraded qt5-tools (5.15.0-2 -> 5.15.0-3)
[2020-07-25T16:32:14-0400] [ALPM] upgraded redis (6.0.5-1 -> 6.0.6-1)
[2020-07-25T16:32:14-0400] [ALPM] upgraded rubygems (3.1.3-1 -> 3.1.4-1)
[2020-07-25T16:32:14-0400] [ALPM] upgraded sudo (1.9.1-1 -> 1.9.2-1)
[2020-07-25T16:32:15-0400] [ALPM] upgraded tensorflow (2.2.0-1 -> 2.3.0rc2-2)
[2020-07-25T16:32:15-0400] [ALPM] upgraded virtualbox-host-dkms (6.1.12-2 -> 6.1.12-3)

Offline

#9 2020-07-27 19:10:36

k4iru
Member
Registered: 2018-01-07
Posts: 4

Re: no audio when using headphones.

Just finished downgrading the kernel using

pacman -U /var/cache/pacman/pkg/linux-lts-5.4.52-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/linux-lts-headers-5.4.52-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/virtualbox-host-dkms-6.1.12-2-x86_64.pkg.tar.zst

headphone audio is working again now.

Thank you!

Offline

#10 2020-07-28 08:19:29

viper1411
Member
Registered: 2020-07-27
Posts: 8

Re: no audio when using headphones.

I do not have the old linux packages in the cache as I did a fresh install recently. Is there any way that I can download the old linux and linux-headers package and install it manualy.

Offline

#11 2020-07-28 08:29:39

viper1411
Member
Registered: 2020-07-27
Posts: 8

Re: no audio when using headphones.

I downgraded my kernal , from the arch linux archive and finally got my sound back.


Thank you very much guys.

Offline

#12 2020-08-18 17:09:37

viper1411
Member
Registered: 2020-07-27
Posts: 8

Re: no audio when using headphones.

I am using linux-5.7.9 and I get sound from my headphone. But if I update it I lose the sound. Pavucontrol shows that the headphone is plugged in and sound is being played but I hear no audio. Please can you help me solve this problem.

Offline

Board footer

Powered by FluxBB