You are not logged in.

#1 2020-07-27 03:45:22

nticompass
Member
From: /home/nticompass/
Registered: 2009-12-08
Posts: 55
Website

[SOLVED] Solid Blue Screen When Shutting Down or Rebooting

I have a really strange issue.  Whenever I shutdown (or reboot), the screen (well, 2 screens) turn a solid blue then the computer restarts.
I do not know how to debug this or what logs would be helpful.

Here is a video I took (sorry, I recorded it using my phone) of the issue: https://www.youtube.com/watch?v=0F7VdDkrG6A

I'm not sure what info would be helpful here, but he's some specs of my system:
CPU: Ryzen 7 2700
Motherboard: ASRock B450M PRO4
GPU: AMD Radeon RX 580
WM: Enlightenment
Kernel: 5.7.7-arch1-1
Kernel command line: ro root=/dev/mapper/MyVG-root initrd=/amd-ucode.img initrd=/initramfs-linux.img audit=0 amd_iommu=on iommu=pt quiet splash loglevel=3 rd.udev.log_priority=3

What could be the issue here and how can I debug it/what logs should I look at?
I am running Plymouth (as you can see in the video), could that be the issue here?

Last edited by nticompass (2020-07-28 23:43:29)

Offline

#2 2020-07-27 14:03:37

ondoho
Member
Registered: 2013-04-30
Posts: 677
Website

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

Are you saying your computer reboots when it should just shut down?

The short blue flicker (as seen in your video) is meaningless IMHO.

Please provide some troubleshooting information.


However studied and stilted your rant, it can never hide the base and primitve emotion that inspired it.
There's no objectivity.

Offline

#3 2020-07-27 15:17:52

nticompass
Member
From: /home/nticompass/
Registered: 2009-12-08
Posts: 55
Website

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

Sorry, the video was the only way I could think of to describe the issue.  The problem is, yeah, that when I tell the system to shut down it reboots instead (after the blue screen which shouldn't be happening).

What troubleshooting info would be helpful here?  I wasn't really sure how to get a log of system shutdown.  Which log file can I look at, or what can I do to help get some useful debug information here?

Offline

#4 2020-07-27 15:46:01

seth
Member
Registered: 2012-09-03
Posts: 16,691

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

Is there a parallel OS installation (ie windows)?
The difference between a power off and a reboot (did you try "systemctl poweroff" to rule out a simple UI bug) is an ACPI hint - if there's an ongoing hibernation, this might throw the BIOS off.

Online

#5 2020-07-28 23:43:19

nticompass
Member
From: /home/nticompass/
Registered: 2009-12-08
Posts: 55
Website

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

Well, I feel silly... the whole issue here is just with Plymouth.  Removing Plymouth makes everything work correctly.

Offline

#6 2020-07-29 05:42:17

seth
Member
Registered: 2012-09-03
Posts: 16,691

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

Plymouth changes the behavior from shutdown to reboot??

Online

#7 2020-07-29 11:14:08

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 487

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

seth wrote:

Plymouth changes the behavior from shutdown to reboot??

It did a few years ago, haven't played with it since.


MSI B550 Bazooka, Ryzen 7 3800X, RTX 2070 SUPER, Arctis 5 usb audio, 16GB 3800 cl15 (1900 inf fab) memory, 1 nvme, 3 ssd, 1 hhd (8TB tot.)

Offline

#8 2020-07-29 21:38:08

nticompass
Member
From: /home/nticompass/
Registered: 2009-12-08
Posts: 55
Website

Re: [SOLVED] Solid Blue Screen When Shutting Down or Rebooting

seth wrote:

Plymouth changes the behavior from shutdown to reboot??

I think Plymouth crashes during shutdown and makes the system reboot for some reason.  This is a bug, not a feature :-P

Offline

Board footer

Powered by FluxBB