You are not logged in.

#1 2020-07-27 07:16:15

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

[Solved] Unresolvable dependancy when installing base package

Hello, I am installing Arch on a virtual machine following the installation guide on the wiki (https://wiki.archlinux.org/index.php/installation_guide). After partitioning the hard drives and mounting the file system, when I try to install the base package using

pacstrap /mnt base

I get the following output:

==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
resolving dependencies
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)
warning: cannot resolve "libcroco", a dependency of "gettext"
warning: cannot resolve "gettext", a dependency of "base"
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)
:: The following package cannot be upgraded due to unresolvable depencies:
    base

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcroco' required by gettext
:: unable to satisfy 'gettext' required by base
==> ERROR: Failed to install packages to new root

Last edited by GeorgFLPCantor` (2020-08-04 07:12:13)

Offline

#2 2020-07-27 08:51:55

Awebb
Member
Registered: 2010-05-06
Posts: 5,634

Re: [Solved] Unresolvable dependancy when installing base package

The dependency is unresolved, because the database files cannot be read:

error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)

Looks like you don't have a connection to the default mirror. What mirror are you using?

Offline

#3 2020-07-27 10:11:12

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Awebb wrote:

The dependency is unresolved, because the database files cannot be read:

error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'community' (Damaged tar archive)

Looks like you don't have a connection to the default mirror. What mirror are you using?

Originally, when I got the error above, I was using the default mirrorlist generated by reflector when I first connected to the internet. Since then I've used reflector to generate the 5 closest mirrors based on rate:

https://arch.mirror.square.r00t.net/$repo/os/$arch
http://arch.mirror.square.r00t.net/$repo/os/$arch
http://archlinux.mailtunnel.eu/$repo/os/$arch
https://mirror.dkm.cz/archlinux/$repo/os/$arch
rsync://arch.mirror,square-r00t.net/arch/$repo/os/$arch

and then based on score:

http://mirror.chaoticum.net/arch
https://archlinux.mailtunnel.eu/$repo/os/$arch
http://archlinux.mailtunnel.eu/$repo/os/$arch
http://arch.mirror.square.r00t.net/$repo/os/$arch
https://arch.mirror.square.r00t.net/$repo/os/$arch
rsync://arch.mirror.square.r00t.net/arch/$repo/os/$arch

In both cases the output when running

pacstrap /mnt base

was identical to the output in my original post.

Offline

#4 2020-07-27 13:56:11

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

Because it's not redownloading the databases. Delete /mnt/var/lib/pacman/sync/* and try again.

Offline

#5 2020-07-27 14:10:42

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,768

Re: [Solved] Unresolvable dependancy when installing base package

Since pacstrap uses --root, not --sysroot, the databases should be in /var/lib/pacman/sync/*.db, not in the /mnt.

What's the output of

file /var/lib/pacman/sync/*.db

Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#6 2020-07-27 14:39:38

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

No, the databases *do* go to the new root. Try it.

Offline

#7 2020-07-27 14:43:08

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,768

Re: [Solved] Unresolvable dependancy when installing base package

Err, right, that will just be based on dbpath which --root overrides, but the *list* of repos still comes from the host. Not sure what I was thinking...

I'm still rather curious what the contents of those files are, though.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#8 2020-07-27 18:08:12

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

eschwartz wrote:

Err, right, that will just be based on dbpath which --root overrides, but the *list* of repos still comes from the host. Not sure what I was thinking...

I'm still rather curious what the contents of those files are, though.

Well, running

file /mnt/var/lib/pacman/sync/*.db

returns

/mnt/var/lib/pacman/sync/community.db: gzip compressed data, last modified: Sat Jul 25 03:02:01 2020, from Unix, original size modulo 2^32 18610688
/mnt/var/lib/pacman/sync/core.db: gzip compressed data, last modified: Fri Jul 24 17:45:40 2020, from Unix, original size modulo 2^32 532480
/mnt/var/lib/pacman/sync/extra.db: gzip compressed data, last modified: Fri Jul 24 21:46:42 2020, from Unix, original size modulo 2^32 6876160

Offline

#9 2020-07-27 18:15:26

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Scimmia wrote:

Because it's not redownloading the databases. Delete /mnt/var/lib/pacman/sync/* and try again.

I did this. Upon running

pacstrap /mnt base

the databases were redownloaded:

:: Synchronizing package databases
 core                  132.9 KiB    525 KiB/s 00:00 [########################################] 100%
 extra                 1666.0 KiB  2.94 MiB/s 00:01 [########################################] 100%
 community             5.1 MiB     20.3 MiB/s 00:00 [########################################] 100%

but then it returned the same error as before.

Offline

#10 2020-07-27 18:21:38

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

With what mirror at the top of your mirrorlist?

Offline

#11 2020-07-27 18:27:22

Awebb
Member
Registered: 2010-05-06
Posts: 5,634

Re: [Solved] Unresolvable dependancy when installing base package

And what filesystem?

Offline

#12 2020-07-27 18:54:48

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Scimmia wrote:

With what mirror at the top of your mirrorlist?

https://arch.mirror.square-r00t.net/$repo/os/$arch

Offline

#13 2020-07-27 18:56:39

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Awebb wrote:

And what filesystem?

I have a root and a home partition formatted as ext4, a swap partition formatted as linux swap and an efi boot partition formatted as fat32.

Offline

#14 2020-07-27 20:32:59

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,768

Re: [Solved] Unresolvable dependancy when installing base package

I stopped using arch.mirror.square-r00t.net due to it being a couple of days out of date.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#15 2020-07-28 01:17:22

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

It's out of date, but the databases seem valid. You got exactly the same errors, where core is valid but extra and community are not?

Offline

#16 2020-07-28 02:00:16

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Scimmia wrote:

It's out of date, but the databases seem valid. You got exactly the same errors, where core is valid but extra and community are not?

I switched back to using the default mirrorlist generated by reflector on startup. I get the same output as before, but also now that the community database is inconsistent:

error: community database is inconsistent: version mismatch on package gitea

Also,

[url]https://mirror.osbeck.com/archlinux/$repo/os/$arch[/url]

is at the top of my mirrorlist if that's useful.

Last edited by GeorgFLPCantor` (2020-07-28 02:03:54)

Offline

#17 2020-07-28 03:20:29

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

There's no way you got the same output plus that message. Start posting complete output every single time.

Offline

#18 2020-07-28 03:33:27

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

My bad, here's the output:

==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
 core is up to date
 extra is up to date
error: failed retrieving file 'community.db' from mirror.osbeck.com : 00:00 [---------------------------------------------]
 community is up to date
resolving dependencies
error: could not read db 'extra' (Damaged tar archive)
error: community database is inconsistent: version mismatch on package gitea
error: could not read db 'community' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: community database is inconsistent: version mismatch on package gitea
error: could not read db 'community' (Damaged tar archive)
warning: cannot resolve "libcroco", a dependency of "gettext"
warning: cannot resolve "gettext", a dependency of "base"
error: could not read db 'extra' (Damaged tar archive)
error: community database is inconsistent: version mismatch on package gitea
error: could not read db 'community' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: community database is inconsistent: version mismatch on package gitea
error: could not read db 'community' (Damaged tar archive)
:: The following package cannot be upgraded due to unresolvable depencies:
    base

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libcroco' required by gettext
:: unable to satisfy 'gettext' required by base
==> ERROR: Failed to install packages to new root

Offline

#19 2020-07-28 03:39:18

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

error: failed retrieving file 'community.db' from mirror.osbeck.com

Are you sure you've got a good internet connection?

Offline

#20 2020-07-28 03:48:12

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

There's no problems with my internet connection.

Offline

#21 2020-07-28 03:50:10

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

Everything you've posted so far says otherwise.

Offline

#22 2020-07-28 05:32:53

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Well, when I ping google.com:

ping -c 5 google.com

I get

PING google.com (216.58.217.46) 56(84) bytes of data.
64 bytes from sea15s08-in-f14.1e100.net (216.58.217.46): icmp_seq=1 ttl=118 time=19.5 ms
64 bytes from sea15s08-in-f14.1e100.net (216.58.217.46): icmp_seq=1 ttl=118 time=20.8 ms
64 bytes from sea15s08-in-f14.1e100.net (216.58.217.46): icmp_seq=1 ttl=118 time=17.4 ms
64 bytes from sea15s08-in-f14.1e100.net (216.58.217.46): icmp_seq=1 ttl=118 time=15.1 ms
64 bytes from sea15s08-in-f14.1e100.net (216.58.217.46): icmp_seq=1 ttl=118 time=18.1 ms

Offline

#23 2020-07-28 06:12:32

seth
Member
Registered: 2012-09-03
Posts: 17,190

Re: [Solved] Unresolvable dependancy when installing base package

https://mirror.osbeck.com/archlinux/com … os/x86_64/ is kinda non-responsive for me right now (same goes for extra, didn't try to other repos)

Try to pick one of the top of this  list: https://www.archlinux.org/mirrors/status/#successful

Online

#24 2020-08-04 07:11:52

GeorgFLPCantor`
Member
Registered: 2020-07-27
Posts: 11

Re: [Solved] Unresolvable dependancy when installing base package

Using the latest installation media iso (updated August 1st), installation was successful. I did not run into the same issue.

Offline

#25 2020-08-04 13:26:25

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] Unresolvable dependancy when installing base package

The installation ISO would have nothing to do with this. It's all about your mirror and connection.

Last edited by Scimmia (2020-08-04 13:26:36)

Offline

Board footer

Powered by FluxBB