You are not logged in.

#1 2020-07-28 19:38:24

Vash63
Member
Registered: 2012-09-22
Posts: 28

Displays freeze when HDMI device plugged in on Intel graphics

Hey all,

I'm using an Intel/Nvidia laptop but currently debugging an issue when using just the Intel graphics on Wayland in Gnome. It works great on the laptop's display, super smooth and responsive... but the instant I plug in my TV the display locks up and I can't even switch to a TTY with ctrl+alt+f3 or anything.

https://gist.github.com/Vash63/8c2b5adb … 656eff3f98

In the above log I'm connecting the display at 20:49:38 and it immediately crashes I think somewhere within DRM. I'm using the stock Arch 5.7.10-arch1-1 kernel. I'm not really sure where the next step to go from here is.

Complicating matters, if I use X11 and setup an Nvidia-only setup it works fine, but for media center usage I'd rather just disable the Nvidia graphics and use Intel+Wayland for tearfree and the better touchpad and scrolling and such.

Offline

#2 2020-07-29 09:28:00

johnjohnlys
Member
Registered: 2020-04-28
Posts: 7

Re: Displays freeze when HDMI device plugged in on Intel graphics

I encountered the same issue at 5.7.10 as well, while I am using a totally different system: KDE+X11+AMD Renoir. I would guess 5.7.10 has some bugs and suggest that downgrade to 5.7.9 first. This version works smoothly for my laptop.

Offline

#3 2020-07-29 12:51:42

Vash63
Member
Registered: 2012-09-22
Posts: 28

Re: Displays freeze when HDMI device plugged in on Intel graphics

johnjohnlys wrote:

I encountered the same issue at 5.7.10 as well, while I am using a totally different system: KDE+X11+AMD Renoir. I would guess 5.7.10 has some bugs and suggest that downgrade to 5.7.9 first. This version works smoothly for my laptop.

Same issue on 5.7.9 unfortunately. Plugging in an HDMI cable while in Wayland causes it to crash instantly. Same kernel errors as before showing drm_gem_map_dma_buf.

Offline

Board footer

Powered by FluxBB