You are not logged in.

#1 2020-07-29 18:17:59

maboleth
Member
Registered: 2020-01-03
Posts: 88

OpenCl being disabled after suspend if apps using it weren't closed

I'm having an issue with darktable program and suspend.

I'm using Nvidia card 1060, latest proprietary drivers, AMD cpu, Arch Linux with Gnome. Everything is latest.

To reproduce it goes like this.

- System reboot, login everything works.
- Starting Darktable 3.0.2 - OpenCL enabled, working.
- Pressing sleep button, system is going to sleep mode.
- After wake, checking Darktable it still says OpenCL enabled.
- Closing down Darktable and starting it again and the message displayed in Core settings is - not available.

It won't be available until next machine restart.

Can anyone help here, DT guys say it's nvidia related.

However I do have OpenCl enabled after suspend. No issues there. It's just when DT is suspended while being on and restarting it afterwards, it won't be available. Any suggestion would be appreciated.

Last edited by maboleth (2020-08-07 00:01:03)

Offline

#2 2020-07-29 19:21:49

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,137

Re: OpenCl being disabled after suspend if apps using it weren't closed

Configuring the systemd nvidia hooks for suspension has been reported to help at least once with blender (can't find the thread right now). Follow https://download.nvidia.com/XFree86/Lin … ement.html closely, pay attention to the kernel parameters you have to set and enable the relevant services (unlike these instructions they are already at the correct location and you can just enable them)

Offline

#3 2020-07-29 22:09:20

maboleth
Member
Registered: 2020-01-03
Posts: 88

Re: OpenCl being disabled after suspend if apps using it weren't closed

@V1del , thanks! But before I go and do those experimental features as Nvidia guys say, I need to be clear on this.

My OpenCL support remains even after suspend. I don't lose OpenCL support after numerous suspends/wakes by itself. The problem arises if I suspend while having Darktable on. THEN, if I close and restart Darktable I will lose OpenCL support for that session (either complete restart or modprobe that module again).

I'm still not sure if it's kernel related or program related.

Offline

#4 2020-08-06 23:56:30

maboleth
Member
Registered: 2020-01-03
Posts: 88

Re: OpenCl being disabled after suspend if apps using it weren't closed

Okay, so I tested it further.

The real issue here is NOT OpenCL being disabled after suspend on its own.

It needs to be 'taken' by program that uses it when the system suspends. Then, after wake, Opencl will be disabled.

It's like this:

- Open Darktable or GIMP with opencl enabled, notice everything working, clinfo showing good values.
- Suspend
- Wake, notice Opencl is disabled system wide, clinfo showing 0.

If suspend happens without any of these programs running and 'taking' OpenCL during suspend, OpenCL will be enabled on the next wake.

I'm not sure if this can be avoided somehow. What V1del said, doesn't help (mainly because Opencl is available on its own after suspend, or if these programs are closed before suspend).

Last edited by maboleth (2020-08-06 23:57:25)

Offline

Board footer

Powered by FluxBB