You are not logged in.

#1 2020-07-31 19:42:14

bladesonfire
Member
From: California, USA
Registered: 2007-05-23
Posts: 43
Website

Slow performance in Civ6

I'm trying to play Civilization 6, but it's a bit slower in Linux than Windows. At minimal settings, I'll get 25 fps, compared to WIndows where I'll get 80 fps. What can I do to improve performance?

Fresh install on a Dell 9575. This laptop has hybrid graphics:

Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
           Device-2: Advanced Micro Devices [AMD/ATI] Polaris 22 XL [Radeon RX Vega M GL] driver: amdgpu v: kernel
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,modesetting resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.3

Currently have `mesa` and `xf86-video-amdgpu` installed. I do not have `xf86-video-intel` installed, but having it installed doesn't make a difference in performance.

I have PRIME setup: 

➜  ~ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x46 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 4 associated providers: 1 name:modesetting
Provider 1: id: 0xcd cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 0 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:01:00.0

➜  ~ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa Intel(R) HD Graphics 630 (KBL GT2)

➜  ~ DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: AMD VEGAM (DRM 3.37.0, 5.7.10-arch1-1, LLVM 10.0.0)

On Steam, I set launch options for Civ6 to include `DRI_PRIME=1 %command%` and in the game, the "GPU" is "Unknown device" (whether I use DRI_PRIME or not).

Last edited by bladesonfire (2020-08-01 20:07:57)

Offline

Board footer

Powered by FluxBB