You are not logged in.

#1 2020-08-01 05:26:44

Dudefoxlive
Member
Registered: 2020-08-01
Posts: 1

Fonts are showing as squares

So I had the amazing idea of installing the japanese fonts so that I can see them on the web instead of squares. Thing were good and I had no problems. I loaded a program and it was nothing but squares. I have removed all the japanese fonts packages and removed the locale for it but my issue still persists. What do I need to do to fix this? https://imgur.com/a/gBgnxdM I normally use I3 but I thought I may have broken I3 but when I loaded into mate it was the same problem.

Offline

#2 2020-08-10 13:49:12

Petfrogg
Member
Registered: 2020-08-10
Posts: 2

Re: Fonts are showing as squares

Got similar problem here but with all characters on a clean install.

This is probably related to:
grep /fonts .local/share/xorg/Xorg.0.log
[  3904.581] (WW) The directory "/usr/share/fonts/misc" does not exist.
[  3904.581] (WW) The directory "/usr/share/fonts/TTF" does not exist.
[  3904.581] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[  3904.581] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[  3904.581] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[  3904.581] (WW) The directory "/usr/share/fonts/75dpi" does not exist.

but what packages do i miss?

Offline

#3 2020-08-10 13:57:48

Petfrogg
Member
Registered: 2020-08-10
Posts: 2

Re: Fonts are showing as squares

This solved it for me:
pacman -S ttf-freefont ttf-dejavu ttf-sazanami

still got:
grep /fonts .local/share/xorg/Xorg.0.log
[  5113.850] (WW) The directory "/usr/share/fonts/misc" does not exist.
[  5113.850] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[  5113.850]    (Run 'mkfontdir' on "/usr/share/fonts/TTF").
[  5113.850] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[  5113.850] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[  5113.850] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[  5113.850] (WW) The directory "/usr/share/fonts/75dpi" does not exist.

Offline

#4 2020-08-10 14:14:34

seth
Member
Registered: 2012-09-03
Posts: 15,750

Re: Fonts are showing as squares

You likely (image is 404) hit https://bbs.archlinux.org/viewtopic.php?id=248032
The warnings are harmless, the one about /usr/share/fonts/TTF should probably go away in subsequent boots (otherwise just run mkfontdir on it as told)

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

Board footer

Powered by FluxBB