You are not logged in.

#1 2004-02-13 16:36:19

xirus
Member
Registered: 2002-12-01
Posts: 113

unable to mount devfs with 2.6

After I configured my 2.6 kernel on this box (did it on another box too where it's working perfectly fine - doing about the same things I've done for this box) I get this error while booting:

mount_devfs_fs(): unable to mount devfs, err: -2

after that he sais he can't open an initial console
I have no idea what error -2 is

[xirus@a1300 linux]$ cat /usr/src/linux-2.6.2/.config|grep DEVFS
CONFIG_DEVFS_FS=y
CONFIG_DEVFS_MOUNT=y
# CONFIG_DEVFS_DEBUG is not set

and for the record, I'm using module-init-tools, I've also compiled the unix pts things into it, I've set the pts line in fstab and I've copied System.map to /boot (as proposed on irc)

Offline

#2 2004-03-09 17:20:59

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,441

Re: unable to mount devfs with 2.6

no idea, but me 2 having a problem with devfs, although i use arch's common kernel26 and fstab entries are ok: devfs-daemon fails to start during booting.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#3 2004-03-10 01:31:13

alcattle
Member
Registered: 2004-03-08
Posts: 32

Re: unable to mount devfs with 2.6

maybe you need to check if you have the pseudo file systems built in.

http://www.easylinuxguide.com/modules.p … =18&page=1

Sounds like you have the fstab entry correct


Big Al in Seattle

http://www.easylinuxguide.com

Very N00b Friendly Group of people

Offline

#4 2004-03-12 21:54:48

punkrockguy318
Member
From: New Jersey
Registered: 2004-02-15
Posts: 705
Website

Re: unable to mount devfs with 2.6

Why doesn't Arch switch to uDev?  Isn't it much better than devfs?


If I have the gift of prophecy and can fathom all mysteries and all knowledge, and if I have a faith that can move mountains, but have not love, I am nothing.   1 Corinthians 13:2

Offline

#5 2004-03-13 01:25:40

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: unable to mount devfs with 2.6

Not yet it isn't and because 2.4 doesn't have it.  We can't leave the 2.4 people behind!


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#6 2004-03-13 15:52:21

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: unable to mount devfs with 2.6

udev is just not ready yet. while many folks report success with it is does not support as wide a set of devices as devfs. documantation is still very weak on it as well (which i really don't see improving as many  kernel related project seem to be getting weaker in the documentation department, such as libusb sad )


AKA uknowme

I am not your friend

Offline

#7 2004-03-13 19:05:56

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: unable to mount devfs with 2.6

I don't think it's support for devices that's a problem... that's handled by the kernel drivers.. maybe device types though.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#8 2004-03-14 00:03:12

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: unable to mount devfs with 2.6

sarah31 wrote:

udev is just not ready yet. while many folks report success with it is does not support as wide a set of devices as devfs. documantation is still very weak on it as well (which i really don't see improving as many  kernel related project seem to be getting weaker in the documentation department, such as libusb sad )

Hi sarah,

lately I read a note that devfs even is maintained again and that  it will
probably live longer than it was supposed to be. Was somewhere at a
summarizing of the kernel mailing list about 3 weeks ago.

bye neri

Offline

#9 2004-03-14 02:54:30

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: unable to mount devfs with 2.6

cool i like devfs.

until i know udev is solid and stable and account for more device types (or whatever) i won't even test it. udev is the future and i hope that they can move it along a bit faster (so i can see what they are using to replace devfs)


AKA uknowme

I am not your friend

Offline

#10 2004-04-07 21:02:49

xirus
Member
Registered: 2002-12-01
Posts: 113

Re: unable to mount devfs with 2.6

well, we're at 2.6.5 now and it's still not working :?

from that article in the link a few posts above:
[*] /dev/pts file system for Unix98 PTYs  -> I don't even get this option, maybe this has been lef out in the new kernels

#pts /dev/pts devpts gid=4,mode=620 0 0
none /dev/pts devpts defaults 0 0
and I tried fstab with both these options, but neither work

does anyone have a clue what's going on?

Offline

Board footer

Powered by FluxBB