You are not logged in.

#26 2020-08-18 00:51:01

timothy.lee
Member
Registered: 2013-06-28
Posts: 2

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

In my case, I also had to change the network device to NAT instead of Bridged mode.  Otherwise, the VM hangs when it performs DHCP.

Last edited by timothy.lee (2020-08-18 00:52:08)

Offline

#27 2020-08-18 05:47:55

d_fajardo
Member
Registered: 2017-07-28
Posts: 916

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

TheVulpecula wrote:

Are those logs accessible from outside the VM

Yes. They are in the directory where the VM files reside. There should be a Logs directory in your VM directory.

Offline

#28 2020-08-18 06:14:40

tomz12
Member
Registered: 2019-08-02
Posts: 19

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

timothy.lee wrote:

In my case, I also had to change the network device to NAT instead of Bridged mode.  Otherwise, the VM hangs when it performs DHCP.

That was it for me as well! Thanks a lot for the hint, I had almost given up on my VM.

Offline

#29 2020-08-18 08:20:28

ogghi
Member
Registered: 2013-09-05
Posts: 12

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Looking at this: https://www.virtualbox.org/ticket/19644
I think some people are already aware of it and looking into it!

Offline

#30 2020-08-18 08:49:55

d_fajardo
Member
Registered: 2017-07-28
Posts: 916

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

What is surprising is there seems to be different issues. I for one, cross fingers, am not having any troubles at all. Others with USB and others with Network modules.
I would still raise a ticket if having trouble since the troubles seem to be specific use-case scenario.
https://bugs.archlinux.org/

Last edited by d_fajardo (2020-08-18 08:51:00)

Offline

#31 2020-08-18 21:37:26

jcsanyi
Member
Registered: 2013-01-08
Posts: 5

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

My VM is also hanging on boot (after the recent upgrades). I've entirely disabled USB, and removed all extension packs.

[jcsanyi@salem ~]$ vboxmanage list extpacks
Extension Packs: 0
[jcsanyi@salem ~]$ pacman -Q | grep 'virtualbox\|^linux '
linux 5.8.1.arch1-1
virtualbox 6.1.12-4
virtualbox-guest-iso 6.1.12-1
virtualbox-host-dkms 6.1.12-4
[jcsanyi@salem ~]$ tail -100 ~/VirtualBox\ VMs/Sidon/Logs/VBox.log 
00:00:00.878478 VMEmt: Halt method global1 (5)
00:00:00.878562 VMEmt: HaltedGlobal1 config: cNsSpinBlockThresholdCfg=2000
00:00:00.878648 Changing the VM state from 'CREATING' to 'CREATED'
00:00:00.881433 SharedFolders host service: Adding host mapping
00:00:00.881440     Host path '/home/jcsanyi/common', map name 'common', writable, automount=false, automntpnt=, create_symlinks=false, missing=false
00:00:00.881531 SharedFolders host service: Adding host mapping
00:00:00.881534     Host path '/home/jcsanyi/Documents/Meeting/Recent/Docs - Unprocessed', map name 'newdocs', writable, automount=false, automntpnt=, create_symlinks=false, missing=false
00:00:00.881634 SharedFolders host service: Adding host mapping
00:00:00.881638     Host path '/home/jcsanyi/Documents/Meeting/Quickbooks', map name 'quickbooks', writable, automount=false, automntpnt=, create_symlinks=false, missing=false
00:00:00.882145 Changing the VM state from 'CREATED' to 'POWERING_ON'
00:00:00.882207 AIOMgr: Endpoints without assigned bandwidth groups:
00:00:00.882212 AIOMgr:     /home/jcsanyi/VirtualBox VMs/Sidon/Snapshots/{451979e7-42b7-4324-a43c-0ce6f6ce62eb}.vdi
00:00:00.882214 AIOMgr:     /home/jcsanyi/VirtualBox VMs/Sidon/Sidon.vdi
00:00:00.882294 Changing the VM state from 'POWERING_ON' to 'RUNNING'
00:00:00.882298 Console: Machine state changed to 'Running'
00:00:00.888126 VMMDev: Guest Log: BIOS: VirtualBox 6.1.11
00:00:00.888170 PCI: Setting up resources and interrupts
00:00:00.890321 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:00.909966 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0 flags=0x0 origin=0,0
00:00:00.910175 VMMDev: Guest Log: CPUID EDX: 0x178bfbff
00:00:00.910269 PIIX3 ATA: Ctl#1: RESET, DevSel=0 AIOIf=0 CmdIf0=0x00 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)
00:00:00.910312 PIIX3 ATA: Ctl#1: finished processing RESET
00:00:00.910999 AHCI#0: Reset the HBA
00:00:00.911017 VD#0: Cancelling all active requests
00:00:00.911041 AHCI#0: Port 0 reset
00:00:00.911082 VD#0: Cancelling all active requests
00:00:00.911436 VMMDev: Guest Log: BIOS: AHCI 0-P#0: PCHS=16383/16/63 LCHS=1024/255/63 0x00000000575466f0 sectors
00:00:00.911467 AHCI#0: Port 1 reset
00:00:01.055787 PIT: mode=2 count=0x48d3 (18643) - 64.00 Hz (ch=0)
00:00:01.110202 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=00007fdcbc000000 w=640 h=480 bpp=32 cbLine=0xA00 flags=0x0 origin=0,0
00:00:01.383154 GUI: UIMachineViewNormal::resendSizeHint: Restoring guest size-hint for screen 0 to 1796x886
00:00:01.390552 GUI: 2D video acceleration is disabled
00:00:01.390921 GUI: HID LEDs sync is not supported on this platform
00:00:01.428439 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5
00:00:03.559709 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0 flags=0x0 origin=0,0
00:00:03.570417 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:03.571104 VMMDev: Guest Log: BIOS: Boot : bseqnr=1, bootseq=0231
00:00:03.571683 VMMDev: Guest Log: BIOS: Boot from Floppy 0 failed
00:00:03.572301 VMMDev: Guest Log: BIOS: Boot : bseqnr=2, bootseq=0023
00:00:03.573487 VMMDev: Guest Log: BIOS: CDROM boot failure code : 0003
00:00:03.573981 VMMDev: Guest Log: BIOS: Boot from CD-ROM failed
00:00:03.574588 VMMDev: Guest Log: BIOS: Boot : bseqnr=3, bootseq=0002
00:00:03.582635 VMMDev: Guest Log: BIOS: Booting from Hard Disk...
00:00:03.845367 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=00007fdcbc000000 w=1024 h=768 bpp=24 cbLine=0xC00 flags=0x0 origin=0,0
00:00:04.501751 GIM: HyperV: Guest OS reported ID 0x1040a0000271b
00:00:04.501768 GIM: HyperV: Open-source=false Vendor=0x1 OS=0x4 (Windows NT or derivative) Major=10 Minor=0 ServicePack=0 Build=10011
00:00:04.501782 GIM: HyperV: Enabled hypercall page at 0x0000000000210000
00:00:04.502035 GIM: HyperV: Queried extended hypercall capabilities 0x1 at 0x0000000000007000
00:00:04.502052 GIM: HyperV: Enabled TSC page at 0x000000000000c000 - u64TscScale=0xfcd70900000000 u64TscKHz=0x278cfb (2 591 995) Seq=1
00:00:04.502120 TM: Switching TSC mode from 'VirtTscEmulated' to 'RealTscOffset'
00:00:04.502234 GIM0: HyperV: Enabled APIC-assist page at 0x000000000000d000
00:00:04.632435 RTC: period=0x10 (16) 2048 Hz
00:00:04.837816 GIM1: HyperV: Enabled APIC-assist page at 0x000000003ffff000
00:00:04.838837 GIM2: HyperV: Enabled APIC-assist page at 0x000000003fffe000
00:00:04.839880 GIM3: HyperV: Enabled APIC-assist page at 0x000000003fffd000
00:00:08.862647 AHCI#0: Reset the HBA
00:00:08.862670 VD#0: Cancelling all active requests
00:00:08.955234 VMMDev: Guest Log: VBoxGuest: Windows version 10.0, build 18363
00:00:08.970446 VMMDev: Guest Additions information report: Version 6.1.6 r137129 '6.1.6'
00:00:08.970510 VMMDev: Guest Additions information report: Interface = 0x00010004 osType = 0x0003B100 (Windows 10, 64-bit)
00:00:08.970645 VMMDev: Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:08.970743 VMMDev: vmmDevReqHandler_HeartbeatConfigure: No change (fHeartbeatActive=false)
00:00:08.970772 VMMDev: Heartbeat flatline timer set to trigger after 4 000 000 000 ns
00:00:08.970790 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners
00:00:08.970815 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5
00:00:08.970837 GUI: UISession::sltAdditionsChange: GA state really changed, notifying listeners
00:00:08.970849 GUI: UIMachineViewNormal::adjustGuestScreenSize: Adjust guest-screen size if necessary
00:00:08.970878 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners
00:00:08.970885 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5
00:00:08.970952 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners
00:00:08.970962 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5
00:00:08.972810 VMMDev: Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:08.973073 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners
00:00:08.973096 GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Requested-state=0, Machine-state=5
00:00:24.476560 VMMDev: Guest Log: VBoxSF: g_fHostFeatures=0x8000000f g_fSfFeatures=0x1 g_uSfLastFunction=29
00:00:24.814610 VMMDev: Guest Log: VBoxMouse::DriverEntry: DriverEntry:
00:00:24.823893 VMMDev: Guest Log: VBoxMP::DriverEntry: VBox WDDM Driver for Windows 8+ version 6.1.6r137129 rel, 64 bit; Built Apr  9 2020 18:55:12
00:00:24.823995 VMMDev: Guest Log: VBoxMP::DriverEntry: OsVersion(10, 0, 18363)
00:00:24.824279 VMMDev: Guest Log: VBoxMP::DriverEntry: WDDM: VGA configuration version 1
00:00:24.824348 VMMDev: Guest Log: VBoxMP::DriverEntry: WDDM: VGA configuration: 3D 0, hardware type 1
00:00:24.824403 VMMDev: Guest Log: VBoxMP::DriverEntry: WDDM: 3D is not supported, hardware type 1
00:00:24.824439 VMMDev: Guest Log: VBoxMP::DriverEntry: 3D is NOT supported by the host, falling back to display-only mode..
00:00:25.517889 HDA: Codec reset
00:00:25.517911 HDA: Reset
00:00:25.559361 HDA: Codec reset
00:00:25.559382 HDA: Reset
00:00:25.698276 HDA: Codec reset
00:00:31.239306 VMMDev: Guest Log: VBoxMP::vboxWddmPickResources: found the VBE card
00:00:31.239360 VMMDev: Guest Log: VBoxMP::DxgkDdiStartDevice: Handling complex topologies enabled
00:00:31.241367 VMMDev: Guest Log: VBoxMP::DxgkDdiStartDevice: using HGSMI
00:00:31.241519 VMMDev: Guest Log: VBoxMP::vboxWddmVModesAdd: WARNING! :resolution 1280x1024 not accepted by the frontend
00:00:31.241608 VMMDev: Guest Log: VBoxMP::vboxWddmVModesAdd: WARNING! :resolution 1400x1050 not accepted by the frontend
00:00:31.241661 VMMDev: Guest Log: VBoxMP::vboxWddmVModesAdd: WARNING! :resolution 1600x1200 not accepted by the frontend
00:00:31.241713 VMMDev: Guest Log: VBoxMP::vboxWddmVModesAdd: WARNING! :resolution 1920x1440 not accepted by the frontend
00:00:31.241799 VMMDev: Guest Log: VBoxMP::vboxWddmVModesAdd: WARNING! :resolution 1920x1080 not accepted by the frontend
00:00:31.241892 VMMDev: Guest Log: VBoxMP::DxgkDdiStartDevice: WDDM: VRAM 0xe0000000/0x10000000, FIFO 0xfde00000/0x200000, IO 0xfff0/0x10
00:00:31.241999 Enabling different vbva mode
00:00:31.242202 Enabling different vbva mode
00:00:32.213130 Display::i_handleDisplayResize: uScreenId=0 pvVRAM=00007fdcbc000000 w=1280 h=960 bpp=32 cbLine=0x1400 flags=0x1 origin=0,0
00:00:35.203166 VMMDev: vmmDevHeartbeatFlatlinedTimer: Guest seems to be unresponsive. Last heartbeat received 4 seconds ago

Offline

#32 2020-08-18 21:45:23

jcsanyi
Member
Registered: 2013-01-08
Posts: 5

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

timothy.lee wrote:

In my case, I also had to change the network device to NAT instead of Bridged mode.  Otherwise, the VM hangs when it performs DHCP.

This fixed it for me as well - thanks! ...although I still don't see how (or if) there's any clues to that in the logs I posted above.

Offline

#33 2020-08-18 22:02:18

jcsanyi
Member
Registered: 2013-01-08
Posts: 5

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

In fact... after switching the network to NAT, I was able to reinstall the oracle extensions (6.1.13) and re-enable USB (3.0) with no problems - so on my fully-upgraded system, the only workaround I currently need is switching the network from Bridged to NAT.

Offline

#34 2020-08-19 01:13:33

pvn
Member
Registered: 2017-09-06
Posts: 24

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

For me none of the work-arounds worked. I tried USB 1.1, 2.0, 3.0 and disabling the USB controller altogether. It makes no difference. I have a single network adapter attached to NAT. Tried starting a VM without any network adapters - same thing. The whole OS freezes. My Arch linux is fully updated.

Last edited by pvn (2020-08-19 01:14:17)

Offline

#35 2020-08-19 08:33:06

brainfucksec
Member
Registered: 2017-03-01
Posts: 40
Website

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

I solved the problem by setting the chipset to ICH9 and eliminating the extension pack.

Last edited by brainfucksec (2020-08-19 08:44:41)


--= [ |<!55 ]=--

Offline

#36 2020-08-19 09:43:12

pavlosdec
Member
Registered: 2019-03-10
Posts: 10

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Kernel 5.8.2 just released.
Let's wait for it to drop to the core repo and update, and see if it is a kernel issue...

Offline

#37 2020-08-21 15:43:00

wopfel
Member
Registered: 2013-11-13
Posts: 10

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

I've encountered the same errors today and I'm glad there's already a busy thread. Thank you all!

Same experience as @pvn: USB 1.1 is active, single network adapter set to NAT --> host OS freezes. Arch Linux is fully updated (no testing repos).
Setting the chipset to ICH9 (as suggested by @brainfucksec) didn't change anything for me. Host OS still freezes.
(no extension pack installed here)

I've enabled the testing repos now and updated to Linux 5.8.2.arch1-1, etc.
The bad news: still no luck. Host OS freezes...

Offline

#38 2020-08-21 16:02:20

pavlosdec
Member
Registered: 2019-03-10
Posts: 10

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

In a virtualbox forum thread, they tested 5.8.2 kernel with VB-6.1.13-139989 and Extensions-6.1.13-139990 (test builds) on a Slackware host with no problems.
Maybe there is a conflict with kernels 5.8.x and the current VB version that the Arch repos have, so I'm still waiting (and hoping).
There is already a new stable 5.8.3 kernel... (perhaps the lucky one?)

Offline

#39 2020-08-22 09:09:24

wopfel
Member
Registered: 2013-11-13
Posts: 10

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

I've updated to linux-5.8.3.arch1-1 now. Again, host OS freezes.

Offline

#40 2020-08-22 09:33:37

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 1,424

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Not sure if this is the fault of Linux as I have the same  problem on linux-lts which is v5.4.58-1

Offline

#41 2020-08-22 15:44:17

loqs
Member
Registered: 2014-03-06
Posts: 11,633

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Has anyone tried https://aur.archlinux.org/packages/virtualbox-svn/ which will contain all the publicly released commits from upstream to see if there is one Arch is missing.
Note the svn is 2GB in size and the build can take a long time.

Offline

#42 2020-08-23 10:53:35

Akrai
Member
Registered: 2014-06-20
Posts: 8

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

I have tried everything: uninstalling virtualbox-ext-oracle, using the oracle extension from the web to use the 6.1.12 one, not using any extension at all, using USB 1.1, 2.0, 3.0 or not using USB at all, using ICH9 chip, PIIX3... nothing works
I have the virtualbox, virtualbox-guest-iso, virtualbox-host-dkms, linux-zen, linux-zen-headers installed, and my system crash happens when i launch the virtualbox machine (kubuntu) and it works fine except i open a program or a dialog or notification appears in my host system (kde plasma). So I can run the virtual machine fine but i must not touch my host system, and i must avoid receiving any notifications at all costs or the system freezes... Weird

Operating System: Arch Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.8.3-zen1-1-zen
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-3570K CPU @ 3.40GHz
Memory: 15.6 GiB of RAM
Graphics Processor: Radeon RX 590 Series


maybe AMD related?

Last edited by Akrai (2020-08-23 10:54:12)

Offline

#43 2020-08-23 14:04:50

brainfucksec
Member
Registered: 2017-03-01
Posts: 40
Website

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

wopfel wrote:

I've updated to linux-5.8.3.arch1-1 now. Again, host OS freezes.

Same for me, from kernel linux-5.8.2.arch1-1, host freezes again, even trying the different recommended workarounds.

Last edited by brainfucksec (2020-08-23 14:06:31)


--= [ |<!55 ]=--

Offline

#44 2020-08-23 18:31:11

pvn
Member
Registered: 2017-09-06
Posts: 24

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Akrai wrote:

maybe AMD related?

Definitely not. I am running Xeon E5. Changing the VM's chipset does not help either. I have not discovered any Virtualbox or VM setting that gives me anything other than complete OS freeze. At this point I believe the next release of Virtualbox is our best hope.

Offline

#45 2020-08-23 21:08:49

alfredo.ardito
Member
Registered: 2018-01-05
Posts: 3

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Same issue. Tried whatever workarounds suggested, host freezes always.

Offline

#46 2020-08-23 22:05:26

loqs
Member
Registered: 2014-03-06
Posts: 11,633

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

alfredo.ardito wrote:

Same issue. Tried whatever workarounds suggested, host freezes always.

That includes using a linux 5.7 host,  using the virtualbox-svn packages from AUR and https://www.virtualbox.org/wiki/Testbuilds
https://www.virtualbox.org/ticket/19644#comment:42?

Last edited by loqs (2020-08-23 23:38:05)

Offline

#47 2020-08-24 06:29:51

alfredo.ardito
Member
Registered: 2018-01-05
Posts: 3

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

Host freezes starting from kernel linux-5.8.X.arch1-1. Based on https://www.virtualbox.org/ticket/19644#comment:42 is this a kernel issue? How can we solve this?

Offline

#48 2020-08-24 07:01:11

pavlosdec
Member
Registered: 2019-03-10
Posts: 10

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

I guess we are waiting for new Virtualbox version (6.1.13)

Offline

#49 2020-08-24 08:01:10

d_fajardo
Member
Registered: 2017-07-28
Posts: 916

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

alfredo.ardito wrote:

is this a kernel issue?

It does look like a kernel issue but again I just wonder why I'm not affected by it. I have everything upgraded and all my VMs run fine.
I think it's a kernel issue together with the hardware in your machine. That's  probably why certain hardware causes the workaround to work and others don't.
It's my wild guess anyway.

Offline

#50 2020-08-24 08:33:07

nplatis
Member
From: Greece
Registered: 2011-02-22
Posts: 22

Re: [SOLVED] Virtualbox (6.1.12-4) when starting VM freezes and locks-up

To be more precise, it looks like a kernel issue which will be solved in the next version of Virtualbox. So we must wait for the next version of Virtualbox, which, fortunately, seems to be imminent.

Offline

Board footer

Powered by FluxBB