You are not logged in.

#1 2020-08-22 19:02:23

Registered: 2017-08-10
Posts: 7

Keyboard no longer working in X following system upgrade


Following a system update on Aug 20, after reboot, my keyboard does not work anymore after starting a X session with xorg.

It's an Asus laptop and I'm referring to the laptop's keyboard.
By non working I mean pressing the keys does nothing. I can't switch tty. The Fn keys (e.g. keyboard backlights) work though. Touchpad doesn't work but to be honest I don't remember if it's usually activated or not.
The (USB) mouse works.
Plugging in a bluetooth keyboard works too.

I log in fine and can use the keyboard and switch tty. So it doesn't look like a hardware problem.
I start xorg with startx.
I initially had i3 starting. At first I thought there might be an issue with the hotkeys or i3. So I removed the i3 config file in order to get the menu. This is when I realized my keyboard wasn't responsive at all.
I changed to a simple .xinitrc that only starts a terminal. The behaviour is the same. So it's not i3.

Then I went to look at xorg conf.
Here are the contents of /etc/X11/xorg.conf.d/ and /usr/share/xorg/xorg.conf.d/ respectively (files are attached)

total 16K
drwxr-xr-x 4 root root 4.0K Aug  9  2017 ..
-rw-r--r-- 1 root root  251 Aug 29  2017 10-monitor.conf
-rw-r--r-- 1 root root  399 Aug 21 12:15 00-keyboard.conf
drwxr-xr-x 2 root root 4.0K Aug 22 14:24 .
total 16K
-rw-r--r-- 1 root root 1.4K May 19 11:45 40-libinput.conf
-rw-r--r-- 1 root root 1.4K Jul 31 18:00 10-quirks.conf.bak
drwxr-xr-x 7 root root 4.0K Aug 21 13:39 ..
drwxr-xr-x 2 root root 4.0K Aug 22 19:40 .

I reconfigured the keyboard.conf automatically (by removing it) to no avail. I looked at the xorg log and compared it with older ones, without finding any good clues. There are those lines:

[  1071.405] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1071.407] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

But they already existed in prior logs. So I'm not sure what to make of them.

The rows corresponding to the keyboard are the same compared to the old log. The rows corresponding to the keyboard as well as the bluetooth mini keyboard match as well.
The device seems to be properly recognized and the libinput driver is selected. So I don't believe it's xorg either but without being 100% sure.

[  1071.788] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'

I thought then it might be due to the driver updates. I downgraded one by one the following packages using pacman -U

[2020-08-21T13:13:45+0200] [ALPM] downgraded libinput (1.15.6-1 -> 1.15.5-1)
[2020-08-21T13:15:54+0200] [ALPM] downgraded xorg-server (1.20.8-3 -> 1.20.8-2)
[2020-08-21T13:16:02+0200] [ALPM] downgraded xorg-server-common (1.20.8-3 -> 1.20.8-2)
[2020-08-21T13:17:46+0200] [ALPM] downgraded xorg-twm (1.0.11-1 -> 1.0.10-2)
[2020-08-21T13:23:37+0200] [ALPM] downgraded libx11 (1.6.11-1 -> 1.6.9-7)
[2020-08-21T13:24:29+0200] [ALPM] downgraded libevdev (1.9.1-1 -> 1.9.0-1)
[2020-08-21T13:25:40+0200] [ALPM] downgraded xkeyboard-config (2.30-2 -> 2.30-1)
[2020-08-21T13:30:13+0200] [ALPM] downgraded kbd (2.3.0-2 -> 2.2.0-5)
[2020-08-21T19:07:00+0200] [ALPM] downgraded libinput (1.15.6-1 -> 1.15.4-1)
[2020-08-21T19:08:15+0200] [ALPM] downgraded xf86-input-libinput (0.30.0-1 -> 0.29.0-2)

Then reboot after each downgrade (except xorg-server and xorg-server-common which seemed to go together), but it didn't change anything (I really suspected rollbacking libinput would be the solution here and even tried a version further back in time).
Unfortunately, as I've been in vacations a long time there are many candidates in the pacman log...
I also tried to remove the libinput.conf file and what it did is that the mouse wasn't usable in X either (which I guess indicates the file is properly loaded). Stripping it to only keep keyboard and pointer didn't change anything either.

I'm out of clues now. What should I look at next? reinstall completely xorg? should I file a bug report? or maybe I didn't rollback properly?

I'm attaching xorg log, dmesg, lspci output, configuration files, pacman log, xinput
* xorg log:
* dmesg:
* lscpi:
* xinput:
* 00-keyboard.conf:
* 40-libinput.conf:
* pacman:

Thanks for helping out!


#2 2020-08-23 22:02:37

Registered: 2015-10-20
Posts: 27

Re: Keyboard no longer working in X following system upgrade

same problem here on an Asus Zenbook. My last upgrade was on August 18. After booting again today, the integrated keyboard and trackpad are unresponsive except for the function keys. USB mouse works.
I don't have an external keyboard right now so navigating is kind of painful but I'm happy to post specific logs if it might help.


#3 2020-08-24 13:46:13

Registered: 2012-09-26
Posts: 17

Re: Keyboard no longer working in X following system upgrade

same here with a 3 year old asus zenbook UX410UAK. I suppose the problem lies in the kernel. It started, when I upgraded to linux 5.8. Downgrading to the  latest 5.7 kernel worked around the issue for me. I've been able to reproduce this with both the vanilla and zen kernels.
Cheers, Marcus


#4 2020-08-25 05:59:57

Registered: 2020-08-25
Posts: 2

Re: Keyboard no longer working in X following system upgrade

I just had a similar problem, the keyboard stopped working. I suspect the kernel is to blame, on the 5.7, 5.8 eggs the problem was more common with the keyboard and xhci pci.
Unless you want to downgrade to stock only then download from here:
Just remember to regenerate the configuration file after installing from GRUB ( sudo grub-mkconfig -o /boot/grub/grub.cfg )

Why I downgraded linux linux-5.7.4.arch1-1

sudo pacman -U Downloads/linux-5.7.4.arch1-1-x86_64.pkg.tar.zst

after installing

sudo grub-mkconfig -o /boot/grub/grub.cfg

This option allows you to ignore individual programs during the update process.
To do this, you need to edit the Pacman configuration file:

sudo nano /etc/pacman.conf 

Uncomment it and type linux

IgnorePkg = linux

Now when you try to update

Pacman -Syu

will not be updated.
the keyboard works fine  smile


#5 2020-08-25 21:44:37

Registered: 2015-10-20
Posts: 27

Re: Keyboard no longer working in X following system upgrade

After downgrading the kernel to 5.7, the issue disappeared for me too.
I also found this other thread about the same issue:


Board footer

Powered by FluxBB