You are not logged in.

#1 2020-08-25 01:51:47

Registered: 2020-08-11
Posts: 17

No sound on new Lenovo T14 - SOLVED!

Hi, I have a fresh install on a Lenovo T14.  It has integrated Intel sound hardware. Everything works except I cannot get any sound. 
I've tried the following:

- Added myself to group "audio"
- Used alsamixer to make sure sound is unmuted
- Installed pulseaudio
- Added a line in modprobe.conf to blacklist snd-intel8x0m  as some have suggested (see upload link below)

When I use aplay to play an xxx.wav file, it seems to work fine... I can see the amplitude display jumping around as the file plays.
Looking at /dev/snd it seems like there should be other devices ?  (See link below)
Here is some info I've collected:

Output from
Listing  of /dev/snd:
Example of things I tried in modprobe.conf


I finally found the solution to this, as posted by another user (link below).

Add this line to /etc/default/grub to disable the snd_hda_intel.dmic_detct feature:


Then run grub-mkconfig to regenerate the grub.cfg file, and reboot.

Last edited by archuser6 (2020-08-27 03:46:28)


#2 2023-01-19 02:53:14

Registered: 2012-04-20
Posts: 11

Re: No sound on new Lenovo T14 - SOLVED!

I have a T14 Gen2 Intel work laptop and while the solution above worked as a workaround for having some sound, but the laptop internal microphone did not work. (If I connected a headset with microphone to the jack, it worked fully, also its microphone).

$ sudo lshw -c multimedia
       description: Video
       product: Integrated Camera
       vendor: Chicony Electronics Co.,Ltd.
       physical id: 4
       bus info: usb@3:4
       version: 61.18
       serial: 0001
       capabilities: usb-2.01
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
       description: Audio device
       product: Tiger Lake-LP Smart Sound Technology Audio Controller
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 20
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=sof-audio-pci-intel-tgl latency=64
       resources: iomemory:600-5ff iomemory:600-5ff irq:186 memory:603dbc0000-603dbc3fff memory:603da00000-603dafffff

After some searching around, I found the solution here: … udio/93628
So basically you need to undo this workaround, reboot (not sure if needed), install the sof-firmware package, reboot, and everything should work after that. Everything works for me now, including the internal mic.
Just for the record, I am using the current version, so 2.2.4-1 of the sof-firmware package.

Last edited by attila123 (2023-01-19 02:55:34)


Board footer

Powered by FluxBB