You are not logged in.

#1 2020-09-03 15:27:36

oz
Member
Registered: 2004-05-20
Posts: 97

[SOLVED] pacman won't run: invalid option '--ignore'

I'm working on an old system, it has been about a year since this machine had any updates though I did try upgrading just pacman but the error persists.

pacman -Sy works but anything else gives an error:

# pacman
error: invalid option '--ignore'
# pacman -Ql package
error: invalid option '--ignore'
# pacman -R package
error: invalid option '--ignore'

I don't understand, I'm not using any "--ignore" option. My pacman.conf does have a couple IgnorePkg entries but commenting those out had no effect.

Last edited by oz (2020-09-03 15:30:29)

Offline

#2 2020-09-03 15:28:39

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,800

Re: [SOLVED] pacman won't run: invalid option '--ignore'

You probably have an alias...

type -a pacman

Last edited by V1del (2020-09-03 15:29:19)

Offline

#3 2020-09-03 15:30:14

oz
Member
Registered: 2004-05-20
Posts: 97

Re: [SOLVED] pacman won't run: invalid option '--ignore'

V1del wrote:

You probably have an alias...

type -a pacman

Good catch, thanks!

Offline

#4 2020-09-03 15:33:44

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,864

Re: [SOLVED] pacman won't run: invalid option '--ignore'

I have to ask... why do you have both IgnorePkg entries and a command-line ignore alias?


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#5 2020-09-03 16:02:38

oz
Member
Registered: 2004-05-20
Posts: 97

Re: [SOLVED] pacman won't run: invalid option '--ignore'

eschwartz wrote:

I have to ask... why do you have both IgnorePkg entries and a command-line ignore alias?

A very old legacy .bashrc file when I (apparently) didn't know about IgnorePkg.

Offline

Board footer

Powered by FluxBB