You are not logged in.

#1 2020-09-07 04:19:32

mcduling
Member
Registered: 2011-12-16
Posts: 67

(SOLVED) Problem installing i3

HI, It is always with a great deal of trepidation that I resort to seeking assistance from the Forum and I don't do so lightly: I always ensure I have exhausted all options first by trial and error, reading, or researching an issue first. But I do love this learning experience ...
I have been an avid Arch user for many years now and it never ceases to amaze me how much my knowledge base needs to increase. I don't know if much has changed recently because I have never had this problem before.
I am using XFCE as a DE and want to add i3 once more. But try as I may, I can't get it to work. I have changed my xinit and ~/.xinitrc files to the point of even taking out exec startxfce4 altogether but still I reboot into xfce. I have tried adding exec i3 and exec starti3 but can't get the option to switch into i3 through GDM. What have I missed?

Last edited by mcduling (2020-09-20 10:36:32)

Offline

#2 2020-09-07 04:24:07

GaKu999
Member
From: US/Eastern
Registered: 2020-06-21
Posts: 373

Re: (SOLVED) Problem installing i3

What?
Do you use startx or GDM?
The one that cares for .xinitrc is startx, xinit, or any custom one you make.

AFAIK GDM only cares about session.desktop files, that can be found inside /etc/xdg or a subdir IIRC...

Or a system dir inside /usr, shipped thru packages...

Last edited by GaKu999 (2020-09-07 04:24:51)


My reposSome snippets

Heisenberg might have been here.

Online

#3 2020-09-07 06:11:50

mcduling
Member
Registered: 2011-12-16
Posts: 67

Re: (SOLVED) Problem installing i3

I have disabled gdm and use X. I have also tried lightdm but still XFCE reboots each time. Tried reinstalling i3 but still get the same result.

Offline

#4 2020-09-07 06:30:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,774

Re: (SOLVED) Problem installing i3

The only way this can magically happen is if you set up auto start of Xorg and are not using your .xinitrc file but directly execute startxfce4 or so.  Does something like: https://wiki.archlinux.org/index.php/Xi … X_at_login ring a bell?

Post those files you've talked about adjusting including the paths where you've changed them. To be extra sure from the started xfce4 session post

journalctl -b
systemctl status

wrapped in [ code ] [ /code ] tags without the spaces.

Quite frankly - and I know that this might add to your trepidation but I hope it doesn't and you take this the  helpful way it is intended - very seldom things in Arch just "happen" without it happening through configuration from your side, if you have as much trouble to recall   which configurations you changed where that would lead to a persistent start of xfce, make a text file, write what you changed where into it each time you make a change that could have a big impact in how you perceive it's behaviour, store that somewhere you can always look into.

Offline

Board footer

Powered by FluxBB