You are not logged in.

#1 2020-09-12 13:44:06

latgarf
Member
Registered: 2012-12-14
Posts: 30

[SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

2020-09-12T10:26:05  I encountered this:

$ sudo gparted
Unit \xe2\x97\x8f.service does not exist, proceeding anyway.
GParted 1.1.0
configuration --enable-libparted-dmraid --enable-online-resize
libparted 3.3
Partition(s) 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64 on /dev/nvme0n1 have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.

I suspect that it might be related to this upgrade:

[2020-09-11T23:02:26+0000] [ALPM] removed libutil-linux (2.36-3)
[2020-09-11T23:02:26+0000] [ALPM] installed util-linux-libs (2.36-4)

because of the dependency chain:
gparted < parted < libutil-linux

How do I revert this upgrade?

Last edited by latgarf (2020-09-16 01:37:05)

Offline

#2 2020-09-12 16:30:55

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,508

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

Unlikely, that was literally just a package rename with no functional change whatsoever. But if you think it is the cause, check your pacman cache for the old package, and maybe heed that warning and do a reboot.

Last edited by V1del (2020-09-12 16:32:04)

Offline

#3 2020-09-12 19:10:10

merlock
Member
Registered: 2018-10-30
Posts: 114

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

I have the exact same error as OP, except my listed partitions number 7-256 (1-6 in use).


It's a big club...and you ain't in it -- George Carlin
Eenie meenie, chili beanie, the spirits are about to speak -- Bullwinkle J. Moose
Registered Linux user #149839
perl -e 'print$i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10); '

Offline

#4 2020-09-12 19:23:20

void03
Member
Registered: 2019-06-09
Posts: 1

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

I am experiencing the exact same issue and same partitions listed as the OP.

Offline

#5 2020-09-12 19:58:14

andrewclive
Member
Registered: 2019-05-19
Posts: 23

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

Offline

#6 2020-09-12 19:59:28

loqs
Member
Registered: 2014-03-06
Posts: 11,703

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

Offline

#7 2020-09-12 20:29:02

merlock
Member
Registered: 2018-10-30
Posts: 114

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

@loqs...no RAID here.


It's a big club...and you ain't in it -- George Carlin
Eenie meenie, chili beanie, the spirits are about to speak -- Bullwinkle J. Moose
Registered Linux user #149839
perl -e 'print$i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10); '

Offline

#8 2020-09-12 20:44:58

loqs
Member
Registered: 2014-03-06
Posts: 11,703

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

merlock can you reproduce the issue after downgrading linux to 5.8.7?
Edit:
The cause should is https://git.kernel.org/pub/scm/linux/ke … 4b612d0289
Fixed by https://git.kernel.org/pub/scm/linux/ke … 5957a60e1a
See https://gitlab.gnome.org/GNOME/gparted/ … ote_910950
Edit2:
https://bugs.archlinux.org/task/67891
Fixed in linux 5.8.9.arch2-1

Last edited by loqs (2020-09-14 02:09:55)

Offline

#9 2020-09-15 22:25:57

latgarf
Member
Registered: 2012-12-14
Posts: 30

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

[2020-09-15T22:15:28+0000] [ALPM] upgraded linux (5.8.8.arch1-1 -> 5.8.9.arch2-1)

kernel upgrade did not solve the original gparted issue sad

Offline

#10 2020-09-15 23:02:38

loqs
Member
Registered: 2014-03-06
Posts: 11,703

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

The running kernel was  5.8.9.arch2 when you tried gparted again? (uname -r)

Offline

#11 2020-09-16 01:36:06

latgarf
Member
Registered: 2012-12-14
Posts: 30

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

Problem seems to be solved by the kernel upgrade.  Sorry, forgot to reboot.  Now only this is left:

$ sudo gparted
Unit \xe2\x97\x8f.service does not exist, proceeding anyway.
GParted 1.1.0
configuration --enable-libparted-dmraid --enable-online-resize
libparted 3.3

Hopefully this is innocuous.  Marking thread solved.

Last edited by latgarf (2020-09-16 01:38:16)

Offline

#12 2020-09-16 02:25:59

merlock
Member
Registered: 2018-10-30
Posts: 114

Re: [SOLVED] libutil-linux -> util-linux-libs causes gparted issue?

@loqs...Sorry, I didn't get back to this soon enough.

5.8.9.arch2-1 fixes the issue; and I still have the same terminal output as @latgarf.

Strange...this "\xe2\x97\x8f" string seems to represent a UTF-8 character, corresponding to unicode U+258F. [1]

[1] https://www.utf8-chartable.de/unicode-u … ng-literal


It's a big club...and you ain't in it -- George Carlin
Eenie meenie, chili beanie, the spirits are about to speak -- Bullwinkle J. Moose
Registered Linux user #149839
perl -e 'print$i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10); '

Offline

Board footer

Powered by FluxBB