You are not logged in.

#1 2020-09-14 17:48:26

dbrief
Member
Registered: 2020-01-21
Posts: 8

Plasma doesn't finish starting, missing virtual desktops (solved)

This happens periodically where everything except the final stage of plasma starting up where my desktop, taskbar, start menu and widgets do not appear.

Usually a reboot will fix it ... until today. Logging out using my desktop manager and logging back in does not work. Rebooting does not work.

I am getting window frames, so plasma is running. Killing and restarting plasmashell does NOT fix it.

When this has happened in the past I've resigned myself to nuking .config and tediously reassembling my plasma desktop from scratch. Yet I've yet to figure out the cause of which plasma component is causing this freeze up from processing the final stage of giving me my desktop on boot.

Can someone more familiar with this process tell me what specifically its doing that could cause it to hang on this last step?

So everything else works fine, but I've got windows from my six virtual desktops all scrunched into one screen when this happens.

Thanks for any suggestions.

Last edited by dbrief (2020-09-17 05:58:25)

Offline

#2 2020-09-14 18:38:14

kokoko3k
Member
Registered: 2008-11-14
Posts: 2,014

Re: Plasma doesn't finish starting, missing virtual desktops (solved)

Could you post a screenshot?
I fail to understand what you mean here:

I am getting window frames, so plasma is running. Killing and restarting plasmashell does NOT fix it.

Offline

#3 2020-09-14 20:29:08

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,717

Re: Plasma doesn't finish starting, missing virtual desktops (solved)

dbrief wrote:

This happens periodically where everything except the final stage of plasma starting up where my desktop, taskbar, start menu and widgets do not appear.

Usually a reboot will fix it ... until today. Logging out using my desktop manager and logging back in does not work. Rebooting does not work.

I am getting window frames, so plasma is running. Killing and restarting plasmashell does NOT fix it.

Plasma doesn't draw window frames. That's kwin.

If you are using the event plugin calendar, remove it.

Offline

#4 2020-09-17 05:57:52

dbrief
Member
Registered: 2020-01-21
Posts: 8

Re: Plasma doesn't finish starting, missing virtual desktops (solved)

arojas wrote:

If you are using the event plugin calendar, remove it.

You are the MAN! This is exactly what it was. I gracefully removed the vestigial plasmoid with plasmapkg2.

It's just so wrong how a poorly written plasmoid can literally prevent your desktop from even firing up. This is supposed to be modular code.

And thanks for the tip on kwin. I just assumed frames were a function of plasma because back when plasmashell was crashing and needing restarting all the time it appeared the frames would disappear and reappear based on whether plasmashell was dead or alive.

Offline

Board footer

Powered by FluxBB