You are not logged in.

#1 2020-09-15 00:01:58

shoelesshunter
Member
Registered: 2014-05-18
Posts: 51

[SOLVED] setting a terminal's default open location

I use termite and urxvt.

Both open in a location other than ~/

How do I fix this behavior?

I am using i3. No DM.

Last edited by shoelesshunter (2020-09-15 03:01:50)

Offline

#2 2020-09-15 00:37:40

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,239
Website

Re: [SOLVED] setting a terminal's default open location

By default they'll open to the current working directory of the parent process - which would generally be your home directory if you start X from your home directory.

How do you start X (and what's in your xinitrc or other relevant startup files)?

If you really just want to force the directory, most terminals have a flag for that - for urxvt it's -cd.  Check the man page.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2020-09-15 03:01:22

shoelesshunter
Member
Registered: 2014-05-18
Posts: 51

Re: [SOLVED] setting a terminal's default open location

After restarting X, everything goes as expected, opening in the directory of the parent process.

Offline

Board footer

Powered by FluxBB