You are not logged in.

#1 2020-09-17 22:12:52

Registered: 2020-06-19
Posts: 4

[solved] failed to mount /boot on startup

I have a problem. I migrated my /home folder to a secondary ssd. Since then, it isn't mounted upon sartup.
When i boot into arch, I already get the error message on the initial boot screen and am redirected to the root user's emergency shell.
looking into the error, I get the following:

● home.mount - /home
     Loaded: loaded (/etc/fstab; generated)
     Active: failed (Result: exit-code) since Thu 2020-09-17 23:24:44 CEST; 54s ago
      Where: /home
       What: /dev/sda1
       Docs: man:fstab(5)

Sep 17 23:24:43 DAVIDArch systemd[1]: Mounting /home...
Sep 17 23:24:44 DAVIDArch mount[358]: mount: /home: mount(2)-Systemaufruf ist fehlgeschlagen: Datei oder Verzeichnis nicht gefunden.
Sep 17 23:24:44 DAVIDArch systemd[1]: home.mount: Mount process exited, code=exited, status=32/n/a
Sep 17 23:24:44 DAVIDArch systemd[1]: home.mount: Failed with result 'exit-code'.
Sep 17 23:24:44 DAVIDArch systemd[1]: Failed to mount /home.

(yes, my secondary drive is sda1)

my etc/fstab looks like this.

# snapshots
LABEL=ARCH_ROOT         /.snapshots     btrfs           rw,relatime,compress=lzo,ssd,space_cache,subvol=@snapshots  0 0

# home
/dev/sda1       /home           btrfs           auto,rw,relatime,compress=lzo,ssd,space_cache,subvol=@home      0 0

# srv
LABEL=ARCH_ROOT         /srv            btrfs           rw,relatime,compress=lzo,ssd,space_cache,subvol=@srv    0 0

# pkg
LABEL=ARCH_ROOT         /var/cache/pacman/pkg   btrfs           rw,relatime,compress=lzo,ssd,space_cache,subvol=@pkg0 0

# /boot
LABEL=ARCH_BOOT         /boot           vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro    0 2

# root subvol
LABEL=ARCH_ROOT         /.btrfs         btrfs           rw,relatime,compress=lzo,ssd,space_cache,subvolid=5     0 0

I've tried using the Label and teh UUId instead of the device name for /dev/sda1 but all produce the same result.

!After manually mounting /home, everything works fine.

I haven't found any useful help by now, so I'm asking you, if you could help me.
I'm sure I just made a silly noob's mistake but I have no idea where to find it.
Happy for every response! smile

Last edited by David_Tirol (2020-09-18 08:04:15)


#2 2020-09-18 05:15:50

Registered: 2020-09-05
Posts: 248

Re: [solved] failed to mount /boot on startup


Was the /home a btrfs subvolume? What if you remove mount option subvol@home and try again?

Last edited by solskog (2020-09-18 05:29:32)


#3 2020-09-18 08:03:56

Registered: 2020-06-19
Posts: 4

Re: [solved] failed to mount /boot on startup

Yes, that was the problem, thank you!!!


Board footer

Powered by FluxBB