You are not logged in.

#1 2020-10-06 08:13:30

Jason P.
Member
Registered: 2015-02-26
Posts: 130

[solved] Pulseaudio warning about module-rescue-streams

Hi,

After last Pulseaudio update module-rescue-streams became deprecated and for this reason I'm seeing the following message in my logs when booting:

pulseaudio[775]: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.

However,  I cannot find that line in my configuration.

➜  $ ~ cat /etc/pulse/default.pa
#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
#.ifexists module-bluetooth-policy.so
#load-module module-bluetooth-policy
#.endif

#.ifexists module-bluetooth-discover.so
#load-module module-bluetooth-discover
#.endif

### Load several protocols
load-module module-dbus-protocol
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GSettings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gsettings.so
.nofail
load-module module-gsettings
.fail
.endif


### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input
➜  $ ~ cat /etc/pulse/daemon.conf
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; enable-memfd = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; avoid-resampling = false
; enable-remixing = yes
; remixing-use-all-sink-channels = yes
; remixing-produce-lfe = no
; remixing-consume-lfe = no
; lfe-crossover-freq = 0

; flat-volumes = no

; rescue-streams = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0
➜  $ ~ cat .config/pulse/daemon.conf
default-sample-format = s24le
resample-method = speex-float-5
➜  $ ~ cat .config/pulse/default.pa
.include /etc/pulse/default.pa

set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo 0

Could it be related to alsa-restore service?

➜  $ ~ systemctl cat alsa-restore.service
# /usr/lib/systemd/system/alsa-restore.service
#
# Note that two different ALSA card state management schemes exist and they
# can be switched using a file exist check - /etc/alsa/state-daemon.conf .
#

[Unit]
Description=Save/Restore Sound Card State
ConditionPathExists=!/etc/alsa/state-daemon.conf
ConditionPathExistsGlob=/dev/snd/control*
ConditionPathExists=/var/lib/alsa/asound.state

[Service]
Type=oneshot
RemainAfterExit=true
ExecStart=-/usr/bin/alsactl restore
ExecStop=-/usr/bin/alsactl store

Another possbility would be to delete all .tdb files and cookie in ~/.config/pulse because maybe some previous state is messing up things...

Last edited by Jason P. (2020-10-11 16:04:03)

Offline

#2 2020-10-06 08:20:03

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,831

Re: [solved] Pulseaudio warning about module-rescue-streams

I'd say old tdb file config is more likely to be the issue here. alsa-restore is irrelevant to this.

Do you use anything that might implicitly try to make use of this? E.g. a specific volume mixer application/paprefs or so?

Last edited by V1del (2020-10-06 08:25:23)

Offline

#3 2020-10-06 08:32:14

Jason P.
Member
Registered: 2015-02-26
Posts: 130

Re: [solved] Pulseaudio warning about module-rescue-streams

Not that I can remember besides having pavucontrol-qt installed. As far as I know it's only a frontend and I don't think it's loaded on boot or something. Anyway I haven't used it for a while.

I'm going to delete all tdb files and cookie and see. Didn't change anything...

Last edited by Jason P. (2020-10-06 09:47:30)

Offline

#4 2020-10-06 15:15:29

mndpo
Member
Registered: 2016-12-13
Posts: 3

Re: [solved] Pulseaudio warning about module-rescue-streams

I have the same error in my logs, I also can't figure out how to remove it.

Last edited by mndpo (2020-10-06 15:15:49)

Offline

#5 2020-10-07 21:37:48

t0mab
Member
Registered: 2020-10-07
Posts: 1

Re: [solved] Pulseaudio warning about module-rescue-streams

Don't know if I could help but I have the option in my old config /etc/pulseaudio :

diff default.pa default.pa.pacnew
105,108d104
< ### Automatically move streams to the default sink if the sink they are
< ### connected to dies, similar for sources
< load-module module-rescue-streams
< 
143,146d138
< 
< ### Switch on connect
< load-module module-switch-on-connect
< 

and here as well :

diff daemon.conf daemon.conf.pacnew
57c57,58
< ; enable-lfe-remixing = no
---
> ; remixing-produce-lfe = no
> ; remixing-consume-lfe = no
60,61c61,63
< flat-volumes = yes 
< ; flat-volumes = yes
---
> ; flat-volumes = no
> 
> ; rescue-streams = yes

Offline

#6 2020-10-08 09:21:21

Jason P.
Member
Registered: 2015-02-26
Posts: 130

Re: [solved] Pulseaudio warning about module-rescue-streams

t0mab wrote:

Don't know if I could help but I have the option in my old config /etc/pulseaudio:

diff default.pa default.pa.pacnew
105,108d104
< ### Automatically move streams to the default sink if the sink they are
< ### connected to dies, similar for sources
< load-module module-rescue-streams
< 
143,146d138
< 
< ### Switch on connect
< load-module module-switch-on-connect
< 

As you can see for yourself I don't have that specific line in my default.pa neither module-switch-on-connect. According to Pulseaudio docs, latter module is way too agressive so it's not usually enabled by default.

I do have in daemon.conf:

; rescue-streams = yes

To my knowledge this is just the default value, which makes sense because from now on stream rescue feature has been moved to Pulseaudio core.

Offline

#7 2020-10-10 17:47:20

shihjay2
Member
Registered: 2017-07-05
Posts: 16

Re: [solved] Pulseaudio warning about module-rescue-streams

Check the contents of /var/lib/gdm/.config/pulse/default.pa if you use gdm - removing the load-module module-rescue-streams there fixes the error message.

Offline

#8 2020-10-11 15:20:05

cluster
Member
Registered: 2020-10-11
Posts: 1

Re: [solved] Pulseaudio warning about module-rescue-streams

same here:

pulseaudio[1496]: module-rescue-stream is obsolete and should no longer be loaded. Please remove it from your configuration.

using cadence & jack2 ... it seems to be an issue w/ the cadence package which still includes the load-module module-rescue-streams:

/usr/share/cadence/pulse2loopback/play+rec.pa
/usr/share/cadence/pulse2jack/play+rec.pa
/usr/share/cadence/pulse2loopback/play.pa
/usr/share/cadence/pulse2jack/play.pa

Last edited by cluster (2020-10-11 15:31:41)

Offline

#9 2020-10-11 16:03:40

Jason P.
Member
Registered: 2015-02-26
Posts: 130

Re: [solved] Pulseaudio warning about module-rescue-streams

You've hit the nail @cluster. Problem solved smile

Thanks!

Offline

#10 2020-10-13 07:25:01

apaz
Member
Registered: 2018-07-23
Posts: 48

Re: [solved] Pulseaudio warning about module-rescue-streams

I do not know if it is right to intervene in a [Solved] thread. I have the same error but I don't have Cadence.
I solved it by commenting the "load module-rescue-streams" entry in:

/home/USER/.config/pulse/default.pa
/home/USER/.config/pulse/system.pa

Offline

#11 2020-10-14 03:33:39

EdK
Member
Registered: 2020-09-24
Posts: 5

Re: [solved] Pulseaudio warning about module-rescue-streams

apaz wrote:

I do not know if it is right to intervene in a [Solved] thread. I have the same error but I don't have Cadence.
I solved it by commenting the "load module-rescue-streams" entry in:

/home/USER/.config/pulse/default.pa
/home/USER/.config/pulse/system.pa

I followed the suggestion of shihjay2 and the error messages ceased!  Like you, I don't have Cadence.  I actually don't have default.pa nor system.pa in the user .config/pulse/ folder.  Try the recommendation of shihjay2 if you haven't already done so.

Offline

#12 2020-10-14 07:20:03

apaz
Member
Registered: 2018-07-23
Posts: 48

Re: [solved] Pulseaudio warning about module-rescue-streams

Yes, I tried the shihjay2 solution, but I don't have the /var/lib/gdm folder.

Offline

#13 2020-10-14 13:06:20

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 266

Re: [solved] Pulseaudio warning about module-rescue-streams

pulse audio 14.0 release notes wrote:

module-rescue-streams is deprecated, functionality moved to the core

module-rescue-stream doesn't do anything any more, and is deprecated. When a device is removed, the module used to move streams on that device to some other device, but that is now handled by the core, so the module has nothing to do. If you have custom configuration that loads module-rescue-streams, you should remove the module from the configuration. Having it in the configuration doesn't do harm, but there will be warnings in the PulseAudio log.

Wonder if this needs to be reported upstream to GDM? Based on the release notes from PulseAudio quoted above, doesn't look like it will do any harm really.

Edit: Actually, nvm, ninjaed already by GDM 3.38.1-2

Last edited by CarbonChauvinist (2020-10-14 15:51:05)


"the wind-blown way, wanna win? don't play"

Offline

#14 2020-10-14 20:34:19

HippieCat
Member
Registered: 2020-09-23
Posts: 1

Re: [solved] Pulseaudio warning about module-rescue-streams

I updated to pulseaudio 13.99.2+13+g7f4d7fcf5-1 today from [extra] upstream and the issue has disappeared from my machine.

Offline

Board footer

Powered by FluxBB