You are not logged in.

#1 2020-10-12 04:47:18

Registered: 2020-10-12
Posts: 1

[SOLVED] TigerVNC error: xinit connection to X server lost


I'm having trouble starting the vncserver for virtual sessions. I followed the section here: … tial_setup. I have the xfce4 group installed (with /usr/share/xsessions/xfce.desktop existing). I set up the vncpasswd and added my username to the vncserver.users file. My ~/.vnc/config looks like this:


Then I called "systemctl start vncserver@:1", authenticated my password, and then no other messages appeared. When I checked the log file under ~/.vnc I saw the following:

Using desktop session xfce

New 'nuc5:1 (koku)' desktop is nuc5:1

Starting desktop session xfce

Xvnc TigerVNC 1.11.0 - built Sep 19 2020 16:42:42
Copyright (C) 1999-2020 TigerVNC Team and many others (see README.rst)
See for information on TigerVNC.
Underlying X server release 12008000, The X.Org Foundation

Sun Oct 11 23:34:03 2020
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on local interface(s), port 5901
 vncext:      created VNC server for screen 0
xinit: XFree86_VT property unexpectedly has 0 items instead of 1
xinit: connection to X server lost

waiting for X server to shut down 
Sun Oct 11 23:34:04 2020
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)

I think the culprit is the "xinit: connection to X server lost" line. But I don't have enough information from this to troubleshoot the problem. I'm using the tigervnc 1.11.0-5 package. Any help would be appreciated. Thanks!

Edit: There was apparently a file called Xsession under the /etc/X11/ directory with the content "#!/bin/sh". After deleting this file, vncserver works. Not sure how that file got there, but deleting it from that location solved the problem.

Last edited by koku100 (2020-10-15 00:25:56)


Board footer

Powered by FluxBB