You are not logged in.

#1 2020-10-13 18:09:27

asmitir
Member
Registered: 2020-09-24
Posts: 14

Emojis not working as intended.

hello, i'm facing problems with OpenMoji, it appears as normal unicode characters instead of the proper emoji pack. I installed it normally using yay.

I used to have JoyPixels installed, don't know if it helps.
im in XFCE.

Offline

#2 2020-10-13 18:46:47

doom_phd
Member
From: US
Registered: 2009-08-11
Posts: 25

Re: Emojis not working as intended.

I suggest looking at the AUR comments.

And the wiki page on font configurtion


Don't you worry about blank. Let me worry about blank
I did do the nasty in the past-y.
Pizza delivery for... I. C. Weiner. Aww... I always thought by this stage in my life I'd be the one making the crank calls.

Offline

#3 2020-10-13 19:00:05

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

doom_phd wrote:

I suggest looking at the AUR comments.

And the wiki page on font configurtion

yes i checked it out, i tried deleting the black font, which should have similar results but nothing from there.

Offline

#4 2020-10-13 19:04:12

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,394

Re: Emojis not working as intended.

Moving to AUR issues.

Offline

#5 2020-10-13 19:39:00

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

2ManyDogs wrote:

Moving to AUR issues.

ok

Offline

#6 2020-10-13 22:11:08

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

doom_phd wrote:

I suggest looking at the AUR comments.

And the wiki page on font configurtion

i did it anyway, still... nothing here
How it is looking like:
how it looks like
what i've done:

https://imgur.com/U1Avj6d.png

NOTE: It works normal with any other font, as JoyPixels or Noto

moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by 2ManyDogs (2020-10-13 22:15:49)

Offline

#7 2020-10-13 23:06:34

doom_phd
Member
From: US
Registered: 2009-08-11
Posts: 25

Re: Emojis not working as intended.

What program are you expecting the emojis to display in?

What is the output of fc-match

Depending on the output this wiki entry might help.


Don't you worry about blank. Let me worry about blank
I did do the nasty in the past-y.
Pizza delivery for... I. C. Weiner. Aww... I always thought by this stage in my life I'd be the one making the crank calls.

Offline

#8 2020-10-13 23:12:14

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

doom_phd wrote:

What program are you expecting the emojis to display in?

What is the output of fc-match

Depending on the output this wiki entry might help.

i expect to use them on the Firefox and systemwide


Here is the output of fc-match --verbose:

Pattern has 39 elts (size 48)
	family: "OpenMoji"(s)
	familylang: "en"(s)
	style: "Color"(s)
	stylelang: "en"(s)
	fullname: "OpenMoji Color"(s)
	fullnamelang: "en"(s)
	slant: 0(i)(s)
	weight: 80(f)(s)
	width: 100(f)(s)
	size: 12(f)(s)
	pixelsize: 12.5(f)(s)
	foundry: "PfEd"(w)
	hintstyle: 1(i)(w)
	hinting: True(s)
	verticallayout: False(s)
	autohint: False(s)
	globaladvance: True(s)
	file: "/usr/share/fonts/openmoji/OpenMoji-Color.ttf"(w)
	index: 0(i)(w)
	outline: True(w)
	scalable: True(w)
	dpi: 75(f)(s)
	rgba: 1(i)(w)
	scale: 1(f)(s)
	charset: 
	0000: 00000000 03ff0409 00000000 00000000 00000000 00004200 00000000 00000000
	0020: 00002000 10000000 00000200 00000000 00000000 00000000 00000000 00000008
	0021: 00800000 02000005 00000000 00000000 03f00000 00000600 00000000 00000000
	0022: 00000000 00000000 00000000 00000000 10000000 00000000 00000000 00000000
	0023: 0c000000 00000100 00000000 00000000 00000000 00000000 00008000 7f0ffe00
	0024: 00000000 00000000 00000000 00000000 00000000 00000000 00000004 00000000
	0025: 00000000 00000000 00000000 00000000 00000000 00403c02 00030001 78006780
	0026: 2132403f 0700c44d 800fff05 c8000169 1afe0000 60030c83 001ac130 27bf0600
	0027: 2054bf24 00180102 00b85090 00000018 00e00000 80010002 00000000 00000000
	0029: 00000000 00300000 00000000 00000000 00000000 00000000 00000000 00000000
	002b: 980030e0 0000c01f 01210000 00000000 00008000 1c000000 00000018 00000000
	0030: 00000000 20010000 00000000 00000000 00000000 00000000 00000000 00000000
	0032: 00000000 00000000 00000000 00000000 02800000 00000000 00000000 00000000
	00e0: 000303ff 00000000 000000ff 00000000 ffffffff 00000fff 0000007f 80000000
	00e1: 00003fff 00000000 007f03df 00000000 000001fe 00000000 00ffffff 00000000
	00e2: 00001fff 00000000 ffffffff 000003ff 00000007 00000000 07ffffdf 00000000
	00e3: ff7cffff 00000bf7 000001ff 00000000 00000003 00000000 00000000 00000000
	00f0: 00000001 00000000 00000000 00000000 00000000 00000000 00000000 00000000
	00f8: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 80000000
	00fe: 00008000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
	01f0: 00000010 00000000 00000000 00000000 00000000 00000000 00008000 00000000
	01f1: 0000e000 00008000 00000000 c003e000 07fe4000 00000000 00000000 ffffffc0
	01f2: 04000006 07fc8000 00030000 00000000 00000000 00000000 00000000 00000000
	01f3: ffffffff fffffff3 ffffffff ffffffff cecfffff ffffffff ffffffff ffb9ffff
	01f4: ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff ffffffff bfffffff
	01f5: ffffffff 3fffffff ffff7e00 07f980ff 00613c80 10060130 700e001c fc08810a
	01f6: ffffffff ffffffff 0000ffff 00000000 ffffffff ffffffff 0027f83f 1ff91a3f
	01f7: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000fff
	01f9: ffffe000 f7ffffff ffffffbf fd7fffff ffffffff ffffc7e7 ffffefff ffffffff
	01fa: 00000000 00000000 00000000 071f0000 efbf007f 005300fb 007f0007 00000000
	0e00: 00000000 00000000 00000000 83b850be 00000000 00000000 00000000 00000000
(w)
	lang: und-zsye(s)
	fontversion: 65536(i)(s)
	capability: "otlayout:latn"(w)
	fontformat: "TrueType"(w)
	embeddedbitmap: True(s)
	decorative: False(s)
	namelang: "en"(s)
	prgname: "fc-match"(s)
	postscriptname: "OpenMojiColor"(w)
	color: False(w)
	symbol: False(s)
	variable: False(s)
	fonthashint: False(w)
	order: 0(i)(s)

Last edited by asmitir (2020-10-13 23:25:53)

Offline

#9 2020-10-13 23:25:27

doom_phd
Member
From: US
Registered: 2009-08-11
Posts: 25

Re: Emojis not working as intended.

How about the output of fc-match -s

I think the wiki entry posted above might apply in your situation.


Don't you worry about blank. Let me worry about blank
I did do the nasty in the past-y.
Pizza delivery for... I. C. Weiner. Aww... I always thought by this stage in my life I'd be the one making the crank calls.

Offline

#10 2020-10-13 23:27:51

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

doom_phd wrote:

How about the output of fc-match -s

I think the wiki entry posted above might apply in your situation.

i edited the last message so it says the right output...

fc-match -s says:

NimbusSans-Regular.otf: "Nimbus Sans" "Regular"
FreeSans.otf: "FreeSans" "Regular"
FreeSansBold.otf: "FreeSans" "Bold"
FreeMono.otf: "FreeMono" "Regular"
FreeSerif.otf: "FreeSerif" "Regular"
SourceCodePro-Regular.otf: "Source Code Pro" "Regular"
D050000L.otf: "D050000L" "Regular"
OpenMoji-Color.ttf: "OpenMoji" "Color"
Cantarell-Regular.otf: "Cantarell" "Regular"
TerminusTTF.ttf: "Terminus (TTF)" "Medium"
scientifica.ttf: "scientifica" "Medium"
scientificaItalic.ttf: "scientifica" "Medium"
scientificaBold.ttf: "scientifica" "Bold"
euphon.bdf: "euphon" "Regular"
hy.bdf: "hy" "SemiCondensed"
vanilla.bdf: "vanilla" "Regular"

Offline

#11 2020-10-14 01:32:53

doom_phd
Member
From: US
Registered: 2009-08-11
Posts: 25

Re: Emojis not working as intended.

Maybe something like this will help in your fonts.conf

<match target="pattern">
  <test name="family"><string>sans-serif</string></test>
  <edit name="family" mode="prepend" binding="same"><string>OpenMoji</string></edit>
</match>

Don't you worry about blank. Let me worry about blank
I did do the nasty in the past-y.
Pizza delivery for... I. C. Weiner. Aww... I always thought by this stage in my life I'd be the one making the crank calls.

Offline

#12 2020-10-14 17:53:21

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

doom_phd wrote:

Maybe something like this will help in your fonts.conf

<match target="pattern">
  <test name="family"><string>sans-serif</string></test>
  <edit name="family" mode="prepend" binding="same"><string>OpenMoji</string></edit>
</match>

nothing here too... im close to giving up, tried everything, any other emoji pack work but not OpenMoji. I would give more info about it if i knew what to say.

NOTE: it appears on the font selection, again, dont know if it adds to something.
https://imgur.com/XHxdVlB.png

EDIT: Ok, its working on Firefox, but not on Vivaldi or any other desktop applications such as discord. and numbers are gone too now...
https://imgur.com/azWc2F2.png

EDIT2: Here you can see how it appears in different aplications:
Discord Desktop:
https://imgur.com/Q5jHgr0.png
Discord Firefox:
https://imgur.com/Q5jHgr0.png
Discord Vivaldi:
https://imgur.com/AWYPw3M.png
This is how numbers appear on firefox:
https://imgur.com/DiK5PPi.png

Last edited by asmitir (2020-10-14 18:37:08)

Offline

#13 2020-10-14 18:47:15

asmitir
Member
Registered: 2020-09-24
Posts: 14

Re: Emojis not working as intended.

doom_phd wrote:

Maybe something like this will help in your fonts.conf

<match target="pattern">
  <test name="family"><string>sans-serif</string></test>
  <edit name="family" mode="prepend" binding="same"><string>OpenMoji</string></edit>
</match>

after deleting what you sent here the numbers are back and the emojis are behaving normal... on Firefox. not on any other application doe not even on the system itself

Offline

#14 2020-10-18 10:34:31

Nocifer
Member
Registered: 2019-05-23
Posts: 6

Re: Emojis not working as intended.

What's the output of:

- fc-match emoji
- first 10 lines of fc-match emoji --all
- first 20 lines of fc-match sans-serif -all

Also, if you visit https://www.fileformat.info/info/emoji/browsertest.htm in each of your browsers, and inspect the fonts used for e.g. "watch" or "hourglass" via the dev tools, what font does it show is in use?

Please keep in mind that Firefox uses its own internal logic and font for emojis, so even if they're properly working there, they might be totally borked in the rest of your system.

Offline

Board footer

Powered by FluxBB