You are not logged in.

#1 2020-10-17 01:49:22

Snow-Sudo
Member
Registered: 2020-09-13
Posts: 12

[SOLVED] Unable to display Unicode arrow for the bar in Qtile

I'm trying to customize my bar in Qtile and used some of Distrotube's configuration that contains a Unicode arrow that gives the bar a Powerline affect. My bar displays it as a box with some text instead of the arrow.

I thought it might be some fonts that I didn't install, so I went over to the Fonts page to find some fonts that contain includes Unicode. I installed bdf-unifont to see if that solves the issue, but that no luck.

This is how the arrow looks for my bar compared to Distrotube's bar
https://imgur.com/a/EUXDK6v

Could there be another font package that properly displays the arrow?

Last edited by Snow-Sudo (2020-10-18 21:15:48)

Offline

#2 2020-10-17 07:11:36

seth
Member
Registered: 2012-09-03
Posts: 16,644

Re: [SOLVED] Unable to display Unicode arrow for the bar in Qtile

FontAwesome (what the hipptsatube likely uses) - f0d9 is in the private use range, ie. not all supporting fonts will even use the same/similar glyph there.
There're various packages in the AUR.

You'll consistently be more lucky w/ ◀ ◂ or ◄ (0x25c{0,2,4}) for leftward pointing triangles, otherwise you'll have to use the same (maybe a powerline patched) font.

Offline

#3 2020-10-18 21:15:22

Snow-Sudo
Member
Registered: 2020-09-13
Posts: 12

Re: [SOLVED] Unable to display Unicode arrow for the bar in Qtile

Thanks, the FontAwesome package displays the arrow properly.

Offline

Board footer

Powered by FluxBB