You are not logged in.

#1 2020-10-21 14:40:36

leshyleshy
Member
Registered: 2020-02-04
Posts: 14

Bluetooth problems (headset) LTS 5.4.72-1 [SOLVED]

Hey guys, migrating this post to its own subject since there doesn't seem to be a thread on LTS bluetooth issues.

I'm on 5.4.72-1-lts just updated yesterday so everything is up to date, right now I am experiencing some weird bluetooth problems. Basically my newer bose 700 headset wont pair or connect properly. I am also seeing this "Key file" message in the systemd status. I initially thought my problem might be related to group permissions with the LP group so i followed these instructions; https://gist.github.com/yejun/2c1a070a8 … 8a998b5495 and edited some configs  Weirdly enough the headphones paired briefly but then the sound quality was muddy and then it just got disconnected immediately. I actually dont know what i did but for one reason or another the bluetooth randomly pairs then disconnects, at least it was yesterday, when i tried again today it didnt pair at all. The weird part was that the headphones paired the first time I tried them out but disconnected right away, and also the first time I tried connecting as root with bluetoothctl same behavior. Its like it trusts new devices then untrusts them, at least thats what I observed.

PS. someone smart please lemme know if I should change my settings back I think i may have I think i may have overdone it trying to fix this. Another user in this thread said that it could be related to link layer security https://bbs.archlinux.org/viewtopic.php?id=259954 wondering if the same is true for LTS or if my problem is totally different.

bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2020-10-21 11:12:15 PST; 9min ago
       Docs: man:bluetoothd(8)
   Main PID: 632 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19134)
     Memory: 3.5M
     CGroup: /system.slice/bluetooth.service
             └─632 /usr/lib/bluetooth/bluetoothd

Oct 21 11:12:15 archPC bluetoothd[632]: src/main.c:parse_controller_config() Key file does not have key “LEConnectionSupervisionTimeout” in group “Controller”
Oct 21 11:12:15 archPC bluetoothd[632]: src/main.c:parse_controller_config() Key file does not have key “LEAutoconnecttimeout” in group “Controller”
Oct 21 11:12:15 archPC bluetoothd[632]: Starting SDP server
Oct 21 11:12:15 archPC bluetoothd[632]: Bluetooth management interface 1.14 initialized
Oct 21 11:12:16 archPC bluetoothd[632]: Endpoint registered: sender=:1.3 path=/MediaEndpoint/A2DPSink/sbc
Oct 21 11:12:16 archPC bluetoothd[632]: Endpoint registered: sender=:1.3 path=/MediaEndpoint/A2DPSource/sbc
Oct 21 11:18:48 archPC bluetoothd[632]: Endpoint registered: sender=:1.55 path=/MediaEndpoint/A2DPSink/sbc
Oct 21 11:18:48 archPC bluetoothd[632]: Endpoint registered: sender=:1.55 path=/MediaEndpoint/A2DPSource/sbc
Oct 21 11:18:48 archPC bluetoothd[632]: src/profile.c:ext_start_servers() RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Oct 21 11:18:48 archPC bluetoothd[632]: src/profile.c:ext_start_servers() RFCOMM server failed for Headset unit: rfcomm_bind: Address already in use (98)

I tried connecting from bluetoothctl while I checked out btmon and I see this "Host is down error" when I try and connect.

Bluetoothctl console

[bluetooth]# connect 4C:87:5D:A0:BC:45
Attempting to connect to 4C:87:5D:A0:BC:45
Failed to pair: org.bluez.Error.ConnectionAttemptFailed
Failed to connect: org.bluez.Error.Failed

BTMON

< HCI Command: Create Connection (0x01|0x0005) plen 13                                                                                               #7 [hci0] 88.133593
        Address: XX:XX:XX:XX:XX:XX (Bose Corporation)
        Packet type: 0xcc18
          DM1 may be used
          DH1 may be used
          DM3 may be used
          DH3 may be used
          DM5 may be used
          DH5 may be used
        Page scan repetition mode: R2 (0x02)
        Page scan mode: Mandatory (0x00)
        Clock offset: 0x0000
        Role switch: Allow slave (0x01)
> HCI Event: Command Status (0x0f) plen 4                                                                                                            #8 [hci0] 88.286587
      Create Connection (0x01|0x0005) ncmd 1
        Status: Success (0x00)
> HCI Event: Connect Complete (0x03) plen 11                                                                                                         #9 [hci0] 93.492383
        Status: Page Timeout (0x04)
        Handle: 65535
        Address: 4C:87:5D:A0:BC:45 (Bose Corporation)
        Link type: ACL (0x01)
        Encryption: Disabled (0x00)
@ MGMT Event: Connect Failed (0x000d) plen 8                                                                                                   {0x0001} [hci0] 93.492413
        BR/EDR Address: XX:XX:XX:XX:XX:XX (Bose Corporation)
        Status: Connect Failed (0x04)
= bluetoothd: src/profile.c:record_cb() Unable to get Headset Voice gateway SDP record: Host is down                                                           93.492932

rfkill is off

rfkill list
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no

Bluetooth stack is installed along with all other bluetooth tools

warning: pulseaudio-13.99.2+13+g7f4d7fcf5-1 is up to date -- reinstalling
warning: pulseaudio-bluetooth-13.99.2+13+g7f4d7fcf5-1 is up to date -- reinstalling
warning: bluez-5.55-1 is up to date -- reinstalling
warning: bluez-utils-5.55-1 is up to date -- reinstalling

All the bluetooth modules are loaded as well

lsmod | grep btusb
btusb                  65536  0
btrtl                  24576  1 btusb
btbcm                  16384  1 btusb
btintel                28672  1 btusb
bluetooth             679936  43 btrtl,btintel,btbcm,bnep,btusb,rfcomm

Let me know if you guys need anymore info that you think will be helpful.

Thanks in advance

Last edited by leshyleshy (2020-10-29 04:37:02)

Offline

#2 2020-10-29 04:38:08

leshyleshy
Member
Registered: 2020-02-04
Posts: 14

Re: Bluetooth problems (headset) LTS 5.4.72-1 [SOLVED]

just an update

I "solved" this problem by just using the regular arch kernel, still cant figure out how to get the mic to work though, if you guys have any ideas let me know.

Offline

#3 2020-10-30 02:03:45

SoundWaveX
Member
Registered: 2020-10-30
Posts: 1

Re: Bluetooth problems (headset) LTS 5.4.72-1 [SOLVED]

I have the same problem with usb bluetooth device. Works about a month in Arch but then suddenly stop working. (In windows goes fine).

I have the kernel  5.9.1-arch1-1

lsmod | grep usb

btusb                  69632  0
btrtl                  24576  1 btusb
btbcm                  20480  1 btusb
btintel                32768  1 btusb
bluetooth             741376  19 btrtl,btintel,btbcm,bnep,btusb,rfcomm
rfkill list all   
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Last edited by SoundWaveX (2020-10-30 02:04:32)

Offline

#4 2020-10-31 06:56:20

leshyleshy
Member
Registered: 2020-02-04
Posts: 14

Re: Bluetooth problems (headset) LTS 5.4.72-1 [SOLVED]

Not sure how relevant this is but since I am troubleshooting on the main arch kernel

5.9.1-arch1-1

but I think the issue may have to do with audio profiles. Initially I couldn't get my headset to work in a2dp they were stuck in
HSP changing the controller mode in /etc/bluetooth/main.conf to

ControllerMode = bredr

and restarting pulseaudio allowed me to use the a2dp profile, only problem is the mic doesnt work in this mode which is weird. I havent tested it out in LTS but its an idea you can try out.

Offline

Board footer

Powered by FluxBB