You are not logged in.

#1 2020-10-22 03:08:08

diogobaeder
Member
Registered: 2012-01-02
Posts: 43

Unable to downgrade nvidia packages from 455 to 450

Hi guys,

I'm using kernel 5.9.1 and I want to downgrade my nvidia packages (the driver package and nvidia-utils, in my case) from 455.x to 450.x, but as soon as I do this and reboot the OS just doesn't load the "nvidia" module, and if try to modprobe it I get an error stating that the module doesn't exist under /lib/modules/5.9.1-arch1-1/ . I tried two approaches, both with the "downgrade" tool and with "pacman -U" on the package files directly, and neither of them work.

Am I doing something wrong? Why is the driver module not being found after I downgrade? Is that driver family just incompatible with kernel 5.9.1, and maybe therefore not supported?

Just to give a better explanation of why I'm doing that, the reason I'm downgrading it is because like many other users I've been having freeze issues with 455.x and kernel 5.9.1 - and I certainly don't want to downgrade my kernel, it's more important than an up-to-date nvidia driver for me. (I also tried switching to nouveau and failed miserably, but this is a whole other story.)

Thanks,
Diogo

Offline

#2 2020-10-22 03:12:03

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,038

Re: Unable to downgrade nvidia packages from 455 to 450

You think that a previous driver is going to be compatible with the 5.9 kernel when not even the latest is? Think again.

The solution, for now, is to use the -lts kernel just as the news on the front page says.

Offline

#3 2020-10-22 03:19:19

diogobaeder
Member
Registered: 2012-01-02
Posts: 43

Re: Unable to downgrade nvidia packages from 455 to 450

OK, I tried installing nvidia-dkms and then downgrade it too, and I get this:

==> dkms install --no-depmod -m nvidia -v 450.66 -k 5.9.1-arch1-1
Error! Bad return status for module build on kernel: 5.9.1-arch1-1 (x86_64)
Consult /var/lib/dkms/nvidia/450.66/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m nvidia -v 450.66 -k 5.9.1-arch1-1' returned 10
==> depmod 5.9.1-arch1-1

I'm suspecting that their 455.x driver family just isn't compatible with kernels < 5.9. If that's the case, I'm not even sure why 455.x was added to the repositories at the first place.

Offline

#4 2020-10-22 03:21:37

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,038

Re: Unable to downgrade nvidia packages from 455 to 450

You've got it backwards. nVidia has no drivers compatible with the 5.9 kernel, period.

Offline

#5 2020-10-22 03:30:00

loqs
Member
Registered: 2014-03-06
Posts: 12,084

Re: Unable to downgrade nvidia packages from 455 to 450

https://bbs.archlinux.org/viewtopic.php?id=259936 the nvidia-uvm will not load without patching either the nvidia module or the kernel,  the nvidia module itself loads fine.
There are patches for 440xx and 390xx for 5.9 compatibility issues allowing the nvidia module to work.

Offline

#6 2020-10-22 03:31:53

diogobaeder
Member
Registered: 2012-01-02
Posts: 43

Re: Unable to downgrade nvidia packages from 455 to 450

Oh, I didn't know about this: https://www.phoronix.com/scan.php?page= … .9-Delayed - seems I was right, but uninformed.

From one point of view, I should pay more attention to news about drivers, but I'm also a bit sad that there was no notification from pacman or similar about this kind of incompatibility (I'm not even sure if it could have been avoided, to be honest).

Anyway, if anyone wants me to "solve" the thread, let me know, or if you have some magical solution to allow me to have any kind of nvidia driver working with kernel 5.9.x, please let me know too. Intensive usage of my video card is totally secondary, so if anyone knows how to cleanly transition from nvidia to nouveau (but still keeping kernel on 5.9), that would be fine too.

Thanks!
Diogo

Offline

#7 2020-10-22 03:33:15

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,038

Re: Unable to downgrade nvidia packages from 455 to 450

diogobaeder wrote:

From one point of view, I should pay more attention to news about drivers, but I'm also a bit sad that there was no notification from pacman or similar about this kind of incompatibility (I'm not even sure if it could have been avoided, to be honest).

https://www.archlinux.org/

There's also a mailing list for it, an RSS feed, and probably other methods.

Offline

#8 2020-10-22 03:43:37

loqs
Member
Registered: 2014-03-06
Posts: 12,084

Re: Unable to downgrade nvidia packages from 455 to 450

https://bbs.archlinux.org/viewtopic.php … 6#p1933086

diogobaeder wrote:

I already upgraded my kernel here to 5.9, and older drivers don't seem to be compatible with it at all. Since I don't want to downgrade my kernel (it's primarily a work computer and I don't want to screw anything up), I'm stuck with linux 5.9+ and nvidia 455+.

See the link in post #5.  Specifically the users running 340xx and 440xx on linux 9.1 after patching.

Offline

#9 2020-10-22 20:44:33

Mikko_H
Member
Registered: 2020-06-23
Posts: 1

Re: Unable to downgrade nvidia packages from 455 to 450

Hi, I had the freezing issues with lts kernel and nvidia-lts 455 driver. What worked for me was to use nvidia-390xx from AUR with non-LTS kernel.

No more freezing. Card is GTX 660.

Offline

Board footer

Powered by FluxBB