You are not logged in.

#1 2020-10-30 18:46:48

Registered: 2018-10-08
Posts: 4

Firejail cannot access profile file: /etc/firejail/globals.locals

Hi everyone,
I started using firejail for sandboxing with apparmor integration some months ago and it worked very well.
One month ago I had to send my laptop away for maintenance, I've got it back yesterday and the first thing I did was to update arch.

In order to enable Apparmor globally I've set the following kernel parameter:

apparmor=1 lsm=lockdown,yama,apparmor

and after the configuration:

$ aa-enabled

In order to enable Apparmor integration globally as mentioned here: Enable_AppArmor_support I edited the content of the file /etc/firejail/globals.local like this:


One month ago this configuration worked perfectly but now firejail seems to be working only if I delete (or rename) globals.local, and xpdf only doesn't work either way.
The error that pops up when the file is present is "cannot access profile file: /etc/firejail/globals.locals"

If it can help firejail and apparmor went from to 0.9.64-2 and form 2.13.4-6 to 3.0.0-2 respectively, linux kernel version 5.9.2

Thanks in advance.


Board footer

Powered by FluxBB