You are not logged in.

#1 2020-11-06 16:29:50

jfabernathy
Member
From: North Carolina
Registered: 2019-01-03
Posts: 36

[SOLVED] Dual booting

I have Archlinux installed using the boot manager Grub. The drive setup for this is:
sda1   EFI boot
sda2   EXT4 /
sda3   swap

I recently install Linux Mint 20 on a partition on sdb and it also uses Grub.

If I just do a default boot, grub comes up for Archlinux and there is only one choice and it's Archlinux

If I hit F10 during boot I see all the available drives plus 2 Boot IDs; GRUB and ubuntu.

If I select GRUB I get Archlinux and if I select ubuntu I get Mint 20

Is there a way to combine the 2 Grubs so the default boot shows both Archlinux and Mint 20 as choices with Archlinux being the default??

Last edited by jfabernathy (2020-11-07 11:19:02)

Offline

#2 2020-11-07 10:26:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: [SOLVED] Dual booting

Install os-prober mount the mint partition's root somewhere and rerun grub-mkconfig or follow one of the multiple options outlined in https://wiki.archlinux.org/index.php/GRUB#GNU/Linux or to the reverse and do any of that from the mint boot loader.

Last edited by V1del (2020-11-07 10:27:33)

Offline

#3 2020-11-07 11:18:26

jfabernathy
Member
From: North Carolina
Registered: 2019-01-03
Posts: 36

Re: [SOLVED] Dual booting

V1del wrote:

Install os-prober mount the mint partition's root somewhere and rerun grub-mkconfig or follow one of the multiple options outlined in https://wiki.archlinux.org/index.php/GRUB#GNU/Linux or to the reverse and do any of that from the mint boot loader.

Thanks for the good references.

Offline

#4 2020-11-07 14:18:40

jfabernathy
Member
From: North Carolina
Registered: 2019-01-03
Posts: 36

Re: [SOLVED] Dual booting

For completeness this is what I did.

With a working Archlinux system on the 1st drive set up as:

/dev/sda1      EFI     /boot
/dev/sda2      ext4    /
/dev/sda3      swap

I installed Mint 20 on the 2nd drive without a boot loader.

That means booting the Mint 20 install USB key and, from the command line, run "ubiquity -b" and select "do something else" and setup the sdb1 ext4 partition to be formatted and mounted as /.

After the installation completes, boot back into Archlinux.

Install os-prober

mount the 2nd drive with Mint on it anywhere: i.e. sudo mount /dev/sdb1 /mnt

sudo grub-mkconfig -o /boot/grub/grub.cfg

Offline

#5 2020-11-08 19:09:49

jfabernathy
Member
From: North Carolina
Registered: 2019-01-03
Posts: 36

Re: [SOLVED] Dual booting

V1del wrote:

Install os-prober mount the mint partition's root somewhere and rerun grub-mkconfig or follow one of the multiple options outlined in https://wiki.archlinux.org/index.php/GRUB#GNU/Linux or to the reverse and do any of that from the mint boot loader.

To better understand all this I did another test case. I installed MInt 20 on /dev/sda and that included Grub.  Then I installed Archlinux on /dev/sdb per the Wiki on Installation except I didn't include an EFI partition or a boot loader.  Then with os-prober already installed on MInt I ran grub-mkconfig -o /boot/grub/grub.cfg

That created a workable system where I could boot either by selecting what I wanted in Grub.

However, grub-mkconfig didn't pickup the fact that on the Archlinux /boot directory I had not only the linux images, but also the intel-ucode.img

When I've installed intel-ucode on a standard one OS Archlinux system grub-mkconfig includes the intel-ucode.img in Grub.

So is there a way to solve this short of manually editing the grub.cfg file?

Offline

#6 2020-11-08 21:44:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: [SOLVED] Dual booting

The upstream defaults contain this via https://git.savannah.gnu.org/cgit/grub. … ig.in#n153 in grub-mkconfig. If this is configured differently for mint you'll have to ask on a mint forum/check through the default config files in mint on whether that variable is set to anything else

Offline

#7 2020-11-08 23:03:21

jfabernathy
Member
From: North Carolina
Registered: 2019-01-03
Posts: 36

Re: [SOLVED] Dual booting

V1del wrote:

The upstream defaults contain this via https://git.savannah.gnu.org/cgit/grub. … ig.in#n153 in grub-mkconfig. If this is configured differently for mint you'll have to ask on a mint forum/check through the default config files in mint on whether that variable is set to anything else

I sort of figured I might be looking at differences on how Mint handles microcode at boot time.  I noticed that Mint doesn't load any ucode type image for itself with grub at all.

Thanks

Offline

Board footer

Powered by FluxBB