You are not logged in.

#1 2020-11-09 11:50:20

Shinoby92
Member
Registered: 2020-11-09
Posts: 1

Need - Pulseaudio best CPU Performance config for dummy output

I need a configuration for the best cpu performance , doesn't care about audio quality.The Audio is in a docker container I don't need to hear it it uses a dummy output. Still Pulseaudio uses 15-20% CPU
my config now via

pulseaudio --dump-conf
daemonize = yes
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = no
flat-volumes = no
rescue-streams = yes
lock-memory = no
exit-idle-time = -1
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-13.99/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = 
log-level = notice
resample-method = speex-float-1
avoid-resampling = yes
enable-remixing = yes
remixing-use-all-sink-channels = yes
remixing-produce-lfe = no
remixing-consume-lfe = no
lfe-crossover-freq = 0
default-sample-format = s16le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 2
default-fragment-size-msec = 4
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 8000
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 200000

Offline

#2 2020-11-09 12:55:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: Need - Pulseaudio best CPU Performance config for dummy output

That's an XY question if I've ever seen one. If you don't care about the audio, why is pulseaudio even started/if you don't need audio at all, why  do you even have a sound card exposed in the docker container?

What are you actually doing? For the literal answer, disable module-udev-detect and load a null sink, set the resampler (... if it's necessary) to copy or trivial, disable realtime/high prio scheduling set the nice level to 20... but that all seems quite a lot of random config for something that is not supposed to be used. Maybe post

pacmd list-sinks
pacmd list-sink-inputs

so we have a general overview of what's actually happening.

Last edited by V1del (2020-11-09 13:24:47)

Offline

Board footer

Powered by FluxBB