You are not logged in.

#1 2020-11-11 17:39:25

radiobla
Member
Registered: 2020-02-19
Posts: 39

Retroarch: failed to resolve dependency libhidapi-hidraw.so on upgrade

The following error happened this afternoon:

$ pac upgrade 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: apparmor: ignoring package upgrade (2.13.4-6 => 3.0.0-2)
resolving dependencies...
warning: cannot resolve "libhidapi-hidraw.so", a dependency of "libretro-dolphin"
:: The following package cannot be upgraded due to unresolvable dependencies:
      libretro-dolphin

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libhidapi-hidraw.so' required by libretro-dolphin

* "pac" is just a shell script I made. Its backend is plain old pacman.

Might it be that the mirrors I'm using are not in sync yet or is this a real issue with the dependencies list of libretro?

Is it happening to you too?

Best regards.

Last edited by radiobla (2020-11-11 17:50:11)

Offline

#2 2020-11-11 17:53:02

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,038

Re: Retroarch: failed to resolve dependency libhidapi-hidraw.so on upgrade

Looks like it requires a package in community-testing. That's a packaging bug.

Offline

#3 2020-11-11 18:03:06

radiobla
Member
Registered: 2020-02-19
Posts: 39

Re: Retroarch: failed to resolve dependency libhidapi-hidraw.so on upgrade

The listed dependencies for libretro-dolphin on pacman are as follows:

...
Groups          : libretro
Provides        : libretro-dolphin
Depends On      : bluez-libs  bzip2  enet  gcc-libs  glibc  libevdev
                  libfmt.so  libgl  libglvnd  libhidapi-hidraw.so
                  libmbedcrypto.so  libmbedtls.so  libmbedx509.so  libpng
                  libretro-core-info  libudev.so  libusb-1.0.so  libx11  libxi
                  libxrandr  lzo  sfml  systemd-libs  xz  zlib  zstd
...

Offline

#4 2020-11-11 18:19:02

radiobla
Member
Registered: 2020-02-19
Posts: 39

Re: Retroarch: failed to resolve dependency libhidapi-hidraw.so on upgrade

I've submitted a Bug Report:

https://bugs.archlinux.org/task/68591

Last edited by radiobla (2020-11-11 18:19:24)

Offline

#5 2020-11-11 20:27:21

radiobla
Member
Registered: 2020-02-19
Posts: 39

Re: Retroarch: failed to resolve dependency libhidapi-hidraw.so on upgrade

I just upgraded libretro-dolphin and it's now fixed.

Thank you for the suggestion Scimmia.

Last edited by radiobla (2020-11-11 20:27:36)

Offline

Board footer

Powered by FluxBB