You are not logged in.

#1 2020-11-13 09:25:34

a_manthey
Member
Registered: 2017-08-21
Posts: 18

[Solved] FreeCAD issue after upgrade of opencascade to 7.5

since upgrade of opencascade to 7.5 i get this error on startup of FreeCAD:

During initialization the error /usr/lib/freecad/lib/Part.so: undefined symbol: _ZN18IGESControl_Writer8AddShapeERK12TopoDS_Shape occurred in /home/andreas/.FreeCAD/Mod/animation/InitGui.py
Please look into the log file for further information
Cannot create object 'Body': (/usr/lib/freecad/lib/Part.so: undefined symbol: _ZN18IGESControl_Writer8AddShapeERK12TopoDS_Shape)

Downgrade to opencascade 7.4 solves the problem.

Any suggestions?

Last edited by a_manthey (2020-11-19 17:44:23)

Offline

#2 2020-11-13 10:29:45

robt77
Member
From: Manchester
Registered: 2014-10-26
Posts: 18
Website

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

a_manthey wrote:

since upgrade of opencascade to 7.5 i get this error on startup of FreeCAD:

During initialization the error /usr/lib/freecad/lib/Part.so: undefined symbol: _ZN18IGESControl_Writer8AddShapeERK12TopoDS_Shape occurred in /home/andreas/.FreeCAD/Mod/animation/InitGui.py
Please look into the log file for further information
Cannot create object 'Body': (/usr/lib/freecad/lib/Part.so: undefined symbol: _ZN18IGESControl_Writer8AddShapeERK12TopoDS_Shape)

Downgrade to opencascade 7.4 solves the problem.

Any suggestions?

Opencascade is a dependency of  freecad and that will need updating, I see it has been flagged out of date today.https://www.archlinux.org/packages/comm … 4/freecad/

Last edited by robt77 (2020-11-13 10:31:41)

Offline

#3 2020-11-15 18:41:40

drfox
Member
Registered: 2020-11-15
Posts: 1

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

This helped me, thanks.

I downgraded with:

sudo pacman -U opencascade-7.4.0.1-1-x86_64.pkg.tar.zst

Should we be posting a bug report on freecad 0.18.4-4? Or just wait for them to up opencascade and recompile?

Offline

#4 2020-11-19 17:43:54

a_manthey
Member
Registered: 2017-08-21
Posts: 18

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

FeeCAD is updated to 7.45, now depends on opencascade74. After replacement of opencascade by opencascade74 and upgrading of FreeCAD to 7.45 its running again.

Offline

#5 2020-11-19 20:57:07

Batou
Member
Registered: 2017-01-03
Posts: 238

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

Current FreeCAD in the Arch Linux community repo has so many issues. After needing to learn some CAD package to 3D print a part, I decided to learn FreeCAD. The version in the repo (0.18) is ancient and extremely unstable. I've experienced crashes every 10-15 min. Some of the included example files don't even work and you get all kinds of errors. It's extremely frustrating to use. Most tutorials that you find online also assume you're using version 0.19. Many other distros have a "freecad-pre" or "freecad_pre" package that you could use. AUR does have an 0.19 but it's an appimage.

I'm not sure who this 0.18 version is for but if you plan on using FreeCAD, you should be using 0.19. Even though it's a pre-relase it's vastly more stable and has much fewer bugs too. Ideally, 0.19-pre should be in the "community" repo and no one should be using 0.18.


Please vote for all the AUR packages you're using. You can mass-vote for all of them by doing: "pacman -Qqm | xargs aurvote -v" (make sure to run "aurvote --configure"  first)

Offline

#6 2020-11-20 15:32:14

dviktor
Member
From: Moscow
Registered: 2015-10-18
Posts: 156

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

opencascade74 breaks kicad dependency. it seems like both packages need to specify PROVIDES directive. at least kicad should work fine with opencascade74

EDIT: filed a bug

Last edited by dviktor (2020-11-20 15:39:31)

Offline

#7 2020-11-21 19:51:44

lmat
Member
Registered: 2015-08-10
Posts: 11

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

I did

sudo pacman -Rsu freecad;
sudo pacman -Syu opencascade74;
sudo pacman -Syu freecad;

And when I open my STEP file, the process receives SIGSEGV. Stack trace from terminal:

Program received signal SIGSEGV, Segmentation fault.                                                                                   
#0  /usr/lib/libc.so.6(+0x3d6a0) [0x7f01d96af6a0]                                                                                       
#1  /usr/lib/libc.so.6(+0x1645de) [0x7f01d97d65de]                                                                                     
#2  /usr/lib/libCoin.so.80(cc_glglue_instance+0x15d) [0x7f01d91d07cd]
#3  0x7f01d9051af9 in SoGLRenderActionP::isDirectRendering(SoState const*) const from /usr/lib/libCoin.so.80+0x49
#4  0x7f01d9053f6d in SoGLRenderActionP::render(SoNode*) from /usr/lib/libCoin.so.80+0xcd
#5  0x7f01d904d6ba in SoAction::apply(SoNode*) from /usr/lib/libCoin.so.80+0x2ea                                                     
#6  0x7f01db51b88a in Gui::SoBoxSelectionRenderAction::apply(SoNode*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x2a                                                                                                                                                           
#7  0x7f01db5bcd26 in Gui::View3DInventorViewer::renderScene() from /usr/lib/freecad/lib/libFreeCADGui.so+0x156
...


I'm pretty sure I'm following the suggestion here to use opencascade 7.4 with freecad properly, right?

Offline

#8 2020-11-26 00:50:44

slimb
Member
Registered: 2020-07-19
Posts: 1

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

Batou wrote:

Current FreeCAD in the Arch Linux community repo has so many issues. After needing to learn some CAD package to 3D print a part, I decided to learn FreeCAD. The version in the repo (0.18) is ancient and extremely unstable. I've experienced crashes every 10-15 min. Some of the included example files don't even work and you get all kinds of errors. It's extremely frustrating to use. Most tutorials that you find online also assume you're using version 0.19. Many other distros have a "freecad-pre" or "freecad_pre" package that you could use. AUR does have an 0.19 but it's an appimage.

I'm not sure who this 0.18 version is for but if you plan on using FreeCAD, you should be using 0.19. Even though it's a pre-relase it's vastly more stable and has much fewer bugs too. Ideally, 0.19-pre should be in the "community" repo and no one should be using 0.18.

Relevant to the others commenting but quoting you as you mentioned AUR:

As a workaround, one could install freecad-git from the AUR, and it's on 0.19 - https://aur.archlinux.org/packages/freecad-git

Offline

#9 2020-11-26 06:35:03

Batou
Member
Registered: 2017-01-03
Posts: 238

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

slimb wrote:
Batou wrote:

Current FreeCAD in the Arch Linux community repo has so many issues. After needing to learn some CAD package to 3D print a part, I decided to learn FreeCAD. The version in the repo (0.18) is ancient and extremely unstable. I've experienced crashes every 10-15 min. Some of the included example files don't even work and you get all kinds of errors. It's extremely frustrating to use. Most tutorials that you find online also assume you're using version 0.19. Many other distros have a "freecad-pre" or "freecad_pre" package that you could use. AUR does have an 0.19 but it's an appimage.

I'm not sure who this 0.18 version is for but if you plan on using FreeCAD, you should be using 0.19. Even though it's a pre-relase it's vastly more stable and has much fewer bugs too. Ideally, 0.19-pre should be in the "community" repo and no one should be using 0.18.

Relevant to the others commenting but quoting you as you mentioned AUR:

As a workaround, one could install freecad-git from the AUR, and it's on 0.19 - https://aur.archlinux.org/packages/freecad-git

Hi and welcome to forums.
Ideally, this package should be a binary release from the official releases page. It takes a very long time to compile all the dependencies and FreeCAD itself and I'm not 100% sure but I have a feeling that official release has some patches added in that are not compiled in by the default.

I've recently also learned of realthunder's branch and it's by far the best and most user-friendly branch of FreeCAD. Many of the features from this branch have landed in 0.19 but not all of them.

if you're new to FreeCAD, either run 0.19 or preferably realthunder's branch. Don't bother with 0.18 since it's horrible and unstable.

Last edited by Batou (2020-11-26 06:36:32)


Please vote for all the AUR packages you're using. You can mass-vote for all of them by doing: "pacman -Qqm | xargs aurvote -v" (make sure to run "aurvote --configure"  first)

Offline

#10 2020-11-29 18:05:33

Potomac
Member
Registered: 2011-12-25
Posts: 511

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

Alternative is to use an appimage of the 0.19 version :
https://wiki.freecadweb.org/AppImage

all necessary dependencies will be in the image.

Offline

#11 2020-11-29 21:05:05

Batou
Member
Registered: 2017-01-03
Posts: 238

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

Potomac wrote:

Alternative is to use an appimage of the 0.19 version :
https://wiki.freecadweb.org/AppImage

all necessary dependencies will be in the image.

Appimages are the antithesis of everything Arch.


Please vote for all the AUR packages you're using. You can mass-vote for all of them by doing: "pacman -Qqm | xargs aurvote -v" (make sure to run "aurvote --configure"  first)

Offline

#12 2020-11-30 20:24:32

Potomac
Member
Registered: 2011-12-25
Posts: 511

Re: [Solved] FreeCAD issue after upgrade of opencascade to 7.5

It's your opinion, but on some use case appimages are very convenient (for using an old version of a software on an rolling release distro, without worrying about the version of dependencies, for example an appimage of blender 2.7x, useful when the graphic card doesn't support last version of blender 2.9x),
the two philosophies (appimages and distro packages) can be complementary, not necessarily opposed.

But regarded to Freecad appimage is just a "temporary" alternative of course, for those who don't want to compile/install things from AUR.

When the bug will be fixed we can return to the regular freecad archlinux package.

Last edited by Potomac (2020-11-30 20:29:27)

Offline

Board footer

Powered by FluxBB