You are not logged in.

#1 2020-11-16 12:17:14

millus
Member
Registered: 2019-07-21
Posts: 52

[SOLVED:hw] Bluetooth range broken after some recent update

When you move away like 5 meters and behind a wall, reception will go bad and stop. Before that even twice the distance would pose no problem at all.
(Tested it with an android phone to make sure it's not the bt-headset, and it was still working fine.)
I tried switching the a2dp mode to any of: SBC, LDAC, apt-x HD and AAC to no avail (was all the same).
The module is an Intel Dual Band Wireless-AC 8265.

Edit: OR... the wifi module could have a problem? But I'm not sure how to test that..

Last edited by millus (2020-11-17 06:38:36)

Offline

#2 2020-11-16 16:11:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,516

Re: [SOLVED:hw] Bluetooth range broken after some recent update

Is the WiFi connected?  Is it connected to an AP in the 5GHz band, or the 2.4GHz band?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Online

#3 2020-11-17 06:19:36

millus
Member
Registered: 2019-07-21
Posts: 52

Re: [SOLVED:hw] Bluetooth range broken after some recent update

Good point asking about the wifi, thanks. It is connected on 5GHz, not on 2.4GHz.
This notebook has no wifi button, just an airplane mode button which would disable both wifi+bluetooth, so for testing instead I did this:
1) rfkill soft block wifi -> still the same bt problems.
2) in the bios disable wifi, now rfkill wouldn't even display the existance of wifi -> unfortunately still the same bt problems.
So it doesn't seem to be an interference problem with wifi hmm

Can this technically even be a software problem, or should i open the laptop and check if i can see anything? Like, does bt have an antenna of some sort that couldve broken?

Edit:
Zomg I just opened the laptop anyway and the bt antenna seemed to not be connected firmly to the wifi module anymore, so I pressed it onto that tiny little connector of some sort and put a piece of tape on it to be sure it doesnt come off again, and it works fine again 10 meters 2 walls gooooooooo

Last edited by millus (2020-11-17 06:38:19)

Offline

Board footer

Powered by FluxBB