You are not logged in.

#1 2020-11-18 00:35:49

Toad39
Member
Registered: 2020-07-06
Posts: 46

[Solved] LC_ALL is en-US

Hello,

My locale keeps getting set to en-US instead of C.UTF-8. This leaves errors like this one:

/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en-US)

Here is the output of my locale-gen:

% sudo locale-gen
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en-US)
Generating locales...
  en_US.UTF-8... done
Generation complete.

Here is the output for my /etc/locale.conf:

% cat /etc/locale.conf 
LANG=C.UTF-8

I have also tried setting my locale in /etc/environment:

#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
LC_ALL=C.UTF-8

The errors still persist. Any idea what I'm doing wrong?

Thank you.

Last edited by Toad39 (2020-11-21 23:43:52)

Offline

#2 2020-11-18 00:51:29

Chop1n
Member
Registered: 2020-10-20
Posts: 14

Re: [Solved] LC_ALL is en-US

What does

 Locale 

show?

And make sure you've read https://wiki.archlinux.org/index.php/lo … leshooting


"curl -F 'sprunge=<-' http://sprunge.us < path-to-file" is holy

Offline

#3 2020-11-18 02:12:38

loqs
Member
Registered: 2014-03-06
Posts: 12,096

Re: [Solved] LC_ALL is en-US

Generating locales...
  en_US.UTF-8... done
Generation complete.

The only locale generated was for en_US.UTF-8.
Did you patch glibc to add C.UTF-8 support as Fedora do [1]?

[1] https://src.fedoraproject.org/rpms/glib … cale.patch
Edit:
Toad39 was not using Arch:
https://bbs.archlinux.org/viewtopic.php?id=260884

Last edited by loqs (2020-11-18 03:23:14)

Offline

#4 2020-11-18 03:17:30

Toad39
Member
Registered: 2020-07-06
Posts: 46

Re: [Solved] LC_ALL is en-US

loqs wrote:

The post you mentioned was not me. What makes you think that?

Offline

#5 2020-11-18 03:22:35

loqs
Member
Registered: 2014-03-06
Posts: 12,096

Re: [Solved] LC_ALL is en-US

Toad39 wrote:
loqs wrote:

The post you mentioned was not me. What makes you think that?

I have no idea how I thought the two names were the same.
Edit:
Fixed that, I do apologise.  What about the rest of the post?  How have you added C.UTF-8 support?

Last edited by loqs (2020-11-18 03:26:06)

Offline

#6 2020-11-18 05:26:07

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,047

Re: [Solved] LC_ALL is en-US

C.UTF-8 does not exist, so of course setting LC_ALL to it causes a problem. LC_ALL should not be set in general at all.

Offline

#7 2020-11-21 23:43:12

Toad39
Member
Registered: 2020-07-06
Posts: 46

Re: [Solved] LC_ALL is en-US

It turns out that my terminal was changing things; using a different terminal helped. Sorry for the hassle.

(I changed back to en_US.UTF-8, didn't realize that C.UTF-8 wasn't supported.)

Last edited by Toad39 (2020-11-21 23:43:40)

Offline

Board footer

Powered by FluxBB