You are not logged in.

#1 2020-11-19 09:34:15

From: St. Petersburg
Registered: 2020-11-12
Posts: 3

[SOLVED] nvidia mode-setting -> black screen

I experience black screen just after nvidia driver kernel mode setting. No Xorg session. This is reproduced even for the LTS  kernel and driver versions.
According to the system joutnal, nvidia driver loads normally:

nvidia: loading out-of-tree module taints kernel.
nvidia: module license 'NVIDIA' taints kernel.
Disabling lock debugging due to kernel taint
nvidia: module verification failed: signature and/or required key missing - tainting kernel
nvidia-nvlink: Nvlink Core is being initialized, major device number 237
nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  455.38  Thu Oct 22 06:06:59 UTC 2020
nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  455.38  Thu Oct 22 05:57:59 UTC 2020
[drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
audit: type=1130 audit(1605775380.250:6): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-fsck@dev-disk-by\x2duuid-e5c84dac\x2dd2a4\x2d41d3\x2dbcdc\x2dd862674e3e23 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
EXT4-fs (sda1): mounting ext3 file system using the ext4 subsystem
nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
ucsi_ccg 0-0008: i2c_transfer failed -110
ucsi_ccg 0-0008: ucsi_ccg_init failed - -110
ucsi_ccg: probe of 0-0008 failed with error -110

Moreover, CUDA toolkit seems to be working just fine, in spite of the recent incompatibility problems.
If I load nouveau driver instead, display works fine and I can start Xorg session.

Package versions:

What can be looked for?

Last edited by iakremnev (2020-11-19 15:44:22)


#2 2020-11-19 10:06:54

Forum Moderator
Registered: 2012-10-16
Posts: 11,168

Re: [SOLVED] nvidia mode-setting -> black screen

Either use the nomodeset kernel parameter or enable nvidia's actual modesetting support: … de_setting


#3 2020-11-19 11:36:57

From: St. Petersburg
Registered: 2020-11-12
Posts: 3

Re: [SOLVED] nvidia mode-setting -> black screen

Thanks for the piece of advice! I was able to load the nvidia_drm module.
It seems that the following note covers my case:

Note: The NVIDIA driver does not provide an fbdev driver for the high-resolution console for the kernel compiled-in vesafb module. However, the kernel compiled-in efifb module supports a high-resolution console on EFI systems. This method requires GRUB or rEFInd and is described in NVIDIA/Tips and tricks#Fixing terminal resolution.[1][2][3].

The latter link hinted that I can switch off Compability Support Mode for Boot in my BIOS. This helped me to finally get output displayed.
Then, having low-res displayed output I changed the console-mode option in my systemd-boot loader.conf to max instead of auto/keep.
Now everything works smooth in high-res!


#4 2020-11-19 15:36:15

Registered: 2012-09-03
Posts: 17,193

Re: [SOLVED] nvidia mode-setting -> black screen

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.


Board footer

Powered by FluxBB