You are not logged in.

#1 2020-11-19 15:30:00

jlw
Member
Registered: 2020-11-19
Posts: 2

[SOLVED] GNOME titlebar buttons not rendering correctly

I'm running GNOME but briefly tried out KDE. I did not find KDE to my liking and removed it. However, doing so seems to have broken the titlebar buttons in GNOME. They now look like the following:

MoPMose.png

Neither changing between themes nor installing new ones solves the problem. I believe the problem is caused by the `breeze` packages (which is installed with KDE); if I install those again, at least those themes work as they should with regards to the titlebar buttons.

Is reinstalling GNOME the only solution?

Last edited by jlw (2020-11-20 14:44:01)

Offline

#2 2020-11-19 23:18:50

maboleth
Member
Registered: 2020-01-03
Posts: 133

Re: [SOLVED] GNOME titlebar buttons not rendering correctly

Alright this should be a sticky for anyone that tried a KDE then gone back to Gnome. smile

So basically you go to

 /.config/gtk-3.0 

and delete assets dir. You can delete other stuff too. Don't touch bookmarks if you have one. After that just logoff/on and everything'll be ok.

Last edited by maboleth (2020-11-19 23:20:09)

Offline

#3 2020-11-20 14:43:33

jlw
Member
Registered: 2020-11-19
Posts: 2

Re: [SOLVED] GNOME titlebar buttons not rendering correctly

That solved it -- thank you so much.

I should add that for this to work for other themes than just the default, it seems you have to delete all files in the gtk folder (excluding the bookmarks).

Perhaps this is something that should be added to the wiki?

Offline

Board footer

Powered by FluxBB