You are not logged in.

#1 2020-11-20 23:14:34

Registered: 2020-07-02
Posts: 7

I Broke My Wifi

Hello. Ok so for a few weeks my computer was taking over a minute to boot because of some sort of wifi protocol that wasn't working. I got frustrated after a while and decided to look up how to fix it. I deleted the file the person said to and now my wifi doesn't work even though wpa_supplicant does not return errors. If anyone could help me fix this it would be great. it has been a while since this happened and I no longer can find the arch forums page i used.


#2 2020-11-20 23:17:51

Inspector Parrot
Registered: 2011-11-29
Posts: 24,640

Re: I Broke My Wifi

Ah, no, try again.

What "sort" of protocol wasn't working?  What file did you delete?  What person said to do so?

Post journals, logs, etc.  As is there is absolutely nothing here to go on.

Please read the following article, then fix your post:

Last edited by Trilby (2020-11-20 23:19:06)

"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman


#3 2020-11-21 22:25:15

Registered: 2020-11-14
Posts: 3

Re: I Broke My Wifi

I don't know what file you're talking about, post severely needs more detail. But maybe you can do this:

Disclaimer: Both ways assume you messed up wpa_supplicant itself and not something else. You provided too little info, and the only thing i could do was guess.

Way 1, Connect to ethernet, you can use systemd-networkd, then install another networking tool like iwd

Way 2. chroot and install something like iwd

Way 3. Assuming you have iwconfig and ifconfig, you temporarily disable WPA/WPA2 (if you even have it on) encryption protocol in your wifi and set it to open or unencrypted (iwconfig doesn't support WPA/WPA2 or any other encrypted networks). If you do that, run this command:

First run run ifconfig to see your device's name


Second scan for wifi networks

iwlist your_device_name scan

Now if you have an open network

iwconfig your_device_name essid your_wifi_name

If a network with a password then:

iwconfig your_device_name essid your_wifi_name key s:your_password

If your ESSID or password or whatever have a space, you need to use quotation marks in them


Board footer

Powered by FluxBB