You are not logged in.

#1 2006-10-17 14:09:31

Registered: 2004-09-01
Posts: 46

Mount options with Hal and USB Hdd with ntfs-3g


I've a question about hal and mount permision.

I've a external usb hard disk with ntfs filesystem. I've try to automatically mount with hal in kde and i've got it. But sometimes when i connect usb and mount hdd, hal shows alert with this menssage:

Volume is scheduled for check. 
Please boot into Windows TWICE, or use the 'force' mount option.

I've try mount with force option in hal but i've not got it. My conf file is:

(?xml version="1.0" encoding="ISO-8859-1"?) (!-- -*- SGML -*- --)

(deviceinfo version="0.2")

(!-- Para mi disco duro usb Maxtor con label 'HDD 250 - USB Pilli'--)
        (match key="block.is_volume" bool="true")
            (match key="volume.fsusage" string="filesystem")
                (match key="volume.fstype" string="ntfs")
                    (match key="info.product" string="HDD 250 - USB Pilli")
                        (merge key="volume.fstype" type="string")ntfs-3g(/merge)
                        (append key="volume.mount.valid_options" type="strlist")force(/append)
                        (merge key="volume.policy.mount_option.force" type="bool")true(/merge)
                        (merge key="volume.policy.mount_filesystem" type="string")ntfs-3g(/merge)


Change "(" and ")" with "<" and ">"

If i use command line and mount with force option it works well

How can i get it?



Board footer

Powered by FluxBB