You are not logged in.

#1 2020-12-02 09:54:48

GeorgeJP
Member
From: Czech Republic
Registered: 2020-01-28
Posts: 68

[SOLVED] graphviz dependency on gtk2

During today's system update pacman reports:

[2020-12-02T09:11:27+0100] [ALPM] upgraded graphviz (2.44.1-4 -> 2.44.1-6)
[2020-12-02T09:11:27+0100] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
[2020-12-02T09:11:27+0100] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
[2020-12-02T09:11:27+0100] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
[2020-12-02T09:11:27+0100] [ALPM-SCRIPTLET] Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.

It needs gtk2 installed,
gtk2 is listed as optional dependency, should be requiered dependency

Last edited by GeorgeJP (2020-12-02 10:08:27)

Offline

#2 2020-12-02 09:58:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,250

Re: [SOLVED] graphviz dependency on gtk2

Why? Is something not working that you expect to? This is a warning, that is true within that context but it doesn't really point to a problem that would make this inherently required

Last edited by V1del (2020-12-02 09:59:02)

Offline

#3 2020-12-02 10:08:08

GeorgeJP
Member
From: Czech Republic
Registered: 2020-01-28
Posts: 68

Re: [SOLVED] graphviz dependency on gtk2

OK, I don't like warnings, so I install gtk2 :-)

Offline

Board footer

Powered by FluxBB